net-vpn/networkmanager-openvpn: disable legacy libnm-glib compat
authorMart Raudsepp <leio@gentoo.org>
Sun, 19 Apr 2020 19:52:39 +0000 (22:52 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 19 Apr 2020 19:52:49 +0000 (22:52 +0300)
Disable libnm-glib, libnm-glib-vpn and libnm-util usage, as they are
all gone with newer NetworkManager.
This also disables libnm-gtk usage, which requires libnm-glib in turn
as well, and is also gone with newer nm-applet.
Depend on new libnma package instead of nm-applet, as this is what
is needed here.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
net-vpn/networkmanager-openvpn/networkmanager-openvpn-1.8.10-r2.ebuild [new file with mode: 0644]

diff --git a/net-vpn/networkmanager-openvpn/networkmanager-openvpn-1.8.10-r2.ebuild b/net-vpn/networkmanager-openvpn/networkmanager-openvpn-1.8.10-r2.ebuild
new file mode 100644 (file)
index 0000000..513bba2
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME_ORG_MODULE="NetworkManager-${PN##*-}"
+
+inherit gnome2 user
+
+DESCRIPTION="NetworkManager OpenVPN plugin"
+HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gtk test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-libs/glib-2.32:2
+       >=net-misc/networkmanager-1.7.0:=
+       >=net-vpn/openvpn-2.1
+       gtk? (
+               >=app-crypt/libsecret-0.18
+               >=net-libs/libnma-1.7.0
+               >=x11-libs/gtk+-3.4:3
+       )
+"
+DEPEND="${RDEPEND}
+       dev-libs/libxml2:2
+       sys-devel/gettext
+       >=dev-util/intltool-0.35
+       virtual/pkgconfig
+"
+
+pkg_setup() {
+       enewgroup nm-openvpn
+       enewuser nm-openvpn -1 -1 -1 nm-openvpn
+}
+
+src_prepare() {
+       # Test will fail if the machine doesn't have a particular locale installed
+       # FAIL: (tls-import-data) unexpected 'ca' secret value, upstream bug #742708
+       sed '/test_non_utf8_import (plugin, test_dir)/ d' \
+               -i properties/tests/test-import-export.c || die "sed failed"
+
+       gnome2_src_prepare
+}
+
+src_configure() {
+       # --localstatedir=/var needed per bug #536248
+       gnome2_src_configure \
+               --localstatedir=/var \
+               --disable-more-warnings \
+               --disable-static \
+               --with-dist-version=Gentoo \
+               $(use_with gtk gnome) \
+               --without-libnm-glib
+}