net-analyzer/netselect: Respect CC, use CFLAGS while linking
authorJeroen Roovers <jer@gentoo.org>
Wed, 23 Oct 2019 08:30:21 +0000 (10:30 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 23 Oct 2019 08:34:37 +0000 (10:34 +0200)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Fixes: https://bugs.gentoo.org/698312
Reported-by: Peter Levine
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/netselect/netselect-0.4-r1.ebuild [moved from net-analyzer/netselect/netselect-0.4.ebuild with 92% similarity]

similarity index 92%
rename from net-analyzer/netselect/netselect-0.4.ebuild
rename to net-analyzer/netselect/netselect-0.4-r1.ebuild
index 18559af3f1e5b6193f683376fcc8b4a685016a2d..20dbb56b53c2571c6451dd69ea8d67be42b57ea8 100644 (file)
@@ -26,8 +26,10 @@ src_prepare() {
        use ipv6 && eapply "${WORKDIR}"/${PN}-0.4-ipv6.patch
 
        default
+}
 
-       tc-export CC
+src_compile() {
+       emake CC="$(tc-getCC)" LDFLAGS="${CFLAGS} ${LDFLAGS}"
 }
 
 src_install () {