www-servers/puma: add 4.0.1
authorHans de Graaff <graaff@gentoo.org>
Fri, 12 Jul 2019 05:07:04 +0000 (07:07 +0200)
committerHans de Graaff <graaff@gentoo.org>
Fri, 12 Jul 2019 05:07:04 +0000 (07:07 +0200)
Drop ~arm64 due to new nio4r dependency, bug 689710

Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

www-servers/puma/Manifest
www-servers/puma/puma-4.0.1.ebuild [new file with mode: 0644]

index 532c474871b83232ee1e3abe43127b8cb153bf6c..fd68e8144bb3a368d4929a7cabe647fbefe9118d 100644 (file)
@@ -1,2 +1,3 @@
 DIST puma-3.12.1.tar.gz 217543 BLAKE2B 6427c48d17ead515a17fd53ba05baba0ca27b9a3c6b26257e83b21ce099d7ff36666dfe1f1a964d23addd666c5aa83c46e6795ad2e22236de7136e25be689ff5 SHA512 70784ed89403e96d1bdb68f3ee0a5446d98a6f8a1af5ddf369d837e2ae3320118c29c9c33e7a9db7a76b1a80aef66a9b6426140c492721984de50e7cc5fc8300
 DIST puma-4.0.0.tar.gz 224071 BLAKE2B ff8adaf78a6534739e7a93d50ee4a82548d89698f4f9007e38ae7fd92bf97ce19e515a2f31556884655d30bb2f0d8395262a2c32125543728ba3c5d1f14fdebd SHA512 5393a254e213ef4e9378ce1ffd05b5a0db54a356f1293dabca04cd2281673d28dfa619750b618b415f7673c47f6edbec5c1a7332e962901b17fb434b60156373
+DIST puma-4.0.1.tar.gz 224363 BLAKE2B 775814eaa6c71deae90bcef850bb8779b6e2b18ed6a694639354678be684d7369f1be7c2234856289f3ac3adf42fbecbbcf243cb44b07c8f99d6a09fef6e09ab SHA512 5d7c8efcf7740484f017311cc074ef4897f600bb21f90836844a6871389206167a4b646c7782e270f68d173e03b5ee16d34ffc2e04f06cebcd31c795d7410885
diff --git a/www-servers/puma/puma-4.0.1.ebuild b/www-servers/puma/puma-4.0.1.ebuild
new file mode 100644 (file)
index 0000000..e51307b
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
+HOMEPAGE="https://puma.io/"
+SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
+RDEPEND+=" dev-libs/openssl:0"
+
+ruby_add_bdepend "virtual/ruby-ssl
+       test? ( dev-ruby/rack >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
+
+ruby_add_rdepend "dev-ruby/nio4r:2"
+
+all_ruby_prepare() {
+       sed -i -e '/bundler/ s:^:#:' test/helper.rb || die
+
+       # Avoid test failing inconsistently
+       sed -i -e '/phased_restart_via_pumactl/,/^  end/ s:^:#:' test/test_integration.rb || die
+
+       # Avoid test that trigger a bug in ruby very easily and lead to
+       # failure. This affects all current puma versions in combination
+       # with the latest ruby versions, so we add this new version anyway
+       # while allowing these tests to fail.
+       # https://github.com/puma/puma/pull/1345
+       rm -f test/test_puma_server_ssl.rb || die
+
+       # Use correct ruby version
+       sed -i -e 's/ruby -rrubygems/#{Gem.ruby} -rrubygems/' test/shell/t{1,3}.rb || die
+}
+
+each_ruby_prepare() {
+       sed -i -e 's:ruby -rubygems:'${RUBY}' -rubygems:' \
+               -e 's/localhost/127.0.0.1/' test/shell/* || die
+       sed -i -e '1ilog_requests' test/shell/t{1,2}_conf.rb || die
+}
+
+each_ruby_configure() {
+       ${RUBY} -Cext/puma_http11 extconf.rb || die
+}
+
+each_ruby_compile() {
+       emake V=1 -Cext/puma_http11
+       cp ext/puma_http11/puma_http11$(get_modname) lib/puma/ || die
+}
+
+each_ruby_test() {
+       einfo "Running test suite"
+       ${RUBY} -Ilib:.:test -e "gem 'minitest', '~>5.9'; gem 'test-unit', '~>3.0'; require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{|f| require f}" || die
+
+       einfo "Running integration tests"
+       pushd test/shell
+       #sh run.sh || die
+       popd
+}