app-leechcraft/lc-monocle: fix deps, update XDG db
author0xd34df00d <0xd34df00d@gmail.com>
Sat, 18 Apr 2020 17:38:38 +0000 (19:38 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 6 May 2020 11:50:53 +0000 (14:50 +0300)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Georg Rudoy <0xd34df00d@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-leechcraft/lc-monocle/lc-monocle-9999.ebuild

index fcd13b3dd384f27cad767a8fd7ea4f70e1f6a920..4b5bf380ecea02e83a682a39010dd949fe89b597 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit leechcraft
+inherit xdg-utils leechcraft
 
 DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
 
@@ -13,20 +13,23 @@ IUSE="debug +djvu doc +fb2 +mobi +pdf +postscript"
 
 REQUIRED_USE="postscript? ( pdf )"
 
-CDEPEND="~app-leechcraft/lc-core-${PV}
-       dev-qt/qtnetwork:5
-       dev-qt/qtwidgets:5
+DEPEND="~app-leechcraft/lc-core-${PV}
        dev-qt/qtconcurrent:5
+       dev-qt/qtnetwork:5
        dev-qt/qtprintsupport:5
+       dev-qt/qtwidgets:5
        dev-qt/qtxml:5
-       pdf? ( app-text/poppler[qt5] )
-       djvu? ( app-text/djvu )"
+       djvu? ( app-text/djvu )
+       pdf? ( app-text/poppler:= )
+"
 
-RDEPEND="${CDEPEND}
-       postscript? ( app-text/ghostscript-gpl )"
+RDEPEND="${DEPEND}
+       postscript? ( app-text/ghostscript-gpl )
+"
 
-DEPEND="${CDEPEND}
-       doc? ( app-doc/doxygen[dot] )"
+BDEPEND="
+       doc? ( app-doc/doxygen[dot] )
+"
 
 src_configure() {
        local mycmakeargs=(
@@ -37,10 +40,18 @@ src_configure() {
                -DENABLE_MONOCLE_PDF=$(usex pdf)
                -DENABLE_MONOCLE_POSTRUS=$(usex postscript)
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        use doc && dodoc -r "${CMAKE_BUILD_DIR}"/out/html/*
 }
+
+pkg_postinst() {
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+}