app-shells/zsh-completions: Version bump to 0.23.0
authorManuel Rüger <mrueg@gentoo.org>
Thu, 16 Feb 2017 16:24:36 +0000 (17:24 +0100)
committerManuel Rüger <mrueg@gentoo.org>
Thu, 16 Feb 2017 16:24:36 +0000 (17:24 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-shells/zsh-completions/Manifest
app-shells/zsh-completions/zsh-completions-0.23.0.ebuild [new file with mode: 0644]

index 45b3a36c2f36af0be0a780385180c22e83616521..bd265e596ca5715cd81298a580320d93bbde0c25 100644 (file)
@@ -1 +1,2 @@
 DIST zsh-completions-0.22.0.tar.gz 204849 SHA256 cfb8c4af39c3df4c2d087f5829dc6f0c1cfcc2b2110bcc7e47b59cff5615a79f SHA512 46c2db28cb58d9abecd51172978c210b3de3b26956e8f8a6a26ebeeacd105ee904b79e2079b046c53b56e6aacd98fb34ef31e1deacdd9230763931f2ae806001 WHIRLPOOL 5e2ee49660a32671de98507e7408901f9f2e717c52fc5bc8c9985f2cff530ac1f4312bd950907bf84f1832ef1b83295633ce0cc066fb765318a08c9cf2c9383f
+DIST zsh-completions-0.23.0.tar.gz 208471 SHA256 47f3beb9484634f0a7226a3d43f16c532fe12ed47f1557e8b8321dbb4865fb58 SHA512 13dc75b1b98f73b5c74337e4a320069f9507d06e2a780bb3c08d7a75552eb18800d4e9e730fe5601bf2587b84424006d18e4b736117ef0d771f5f8318a04cf76 WHIRLPOOL 90f72c7b55863e35f087e9a5948a1887d80e6fc49b399400f87a3d464a311b7a998d5eae8e35c0aef9c2777368f2dd77f4a536cbf932de344ad5743627ceb0a1
diff --git a/app-shells/zsh-completions/zsh-completions-0.23.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.23.0.ebuild
new file mode 100644 (file)
index 0000000..35340b0
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+       SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+       insinto /usr/share/zsh/site-functions
+       doins src/_*
+}
+
+pkg_postinst() {
+       elog
+       elog "If you happen to compile your functions, you may need to delete"
+       elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+       elog "to your shell."
+       elog
+}