dev-libs/satyr: new package
authorAaron Bauman <bman@gentoo.org>
Tue, 22 May 2018 16:09:08 +0000 (12:09 -0400)
committerAaron Bauman <bman@gentoo.org>
Tue, 22 May 2018 16:09:08 +0000 (12:09 -0400)
Package is to support the revbump of dev-libs/libreport.

Closes: https://bugs.gentoo.org/619538
Package-Manager: Portage-2.3.38, Repoman-2.3.9

dev-libs/satyr/Manifest [new file with mode: 0644]
dev-libs/satyr/metadata.xml [new file with mode: 0644]
dev-libs/satyr/satyr-0.26.ebuild [new file with mode: 0644]

diff --git a/dev-libs/satyr/Manifest b/dev-libs/satyr/Manifest
new file mode 100644 (file)
index 0000000..cb6c836
--- /dev/null
@@ -0,0 +1 @@
+DIST satyr-0.26.tar.gz 434820 BLAKE2B 4463c69e6ac2eb8237f599bfeed308265a906c6e3efa154b14eb6ee7acdc65580da9baf5ecb99e4efa4f8c00f7656ff2a747e607f2293b12a513ed680986fe08 SHA512 45dfc42e05e93fa0417c8c5d6811097cabaa0f4dcfb79df13d3840d789cfd41c84382ae84882ca120b1a3120987123a306656324cf39f306046a5d30547db656
diff --git a/dev-libs/satyr/metadata.xml b/dev-libs/satyr/metadata.xml
new file mode 100644 (file)
index 0000000..3998080
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>gnome@gentoo.org</email>
+       <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-libs/satyr/satyr-0.26.ebuild b/dev-libs/satyr/satyr-0.26.ebuild
new file mode 100644 (file)
index 0000000..400a2a4
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools python-r1 toolchain-funcs
+
+DESCRIPTION="Satyr is a collection of low-level algorithms for program failure processing"
+HOMEPAGE="https://github.com/abrt/satyr"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/3"
+
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+       >=dev-libs/elfutils-0.158
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       default
+       ./gen-version || die # Needs to be run before full autoreconf
+       eautoreconf
+       use python && python_copy_sources
+}
+
+src_configure() {
+       local myargs=(
+               --localstatedir="${EPREFIX}/var"
+               --without-rpm
+               # Build breaks without and we aren't supporting Python2 anyway
+               --without-python2
+               $(usex python "--with-python3" "--without-python3")
+       )
+
+       econf "${myargs[@]}"
+}