app-text/sigil: add USE=plugins
authorZamarin Arthur <arthurzam@gmail.com>
Sun, 21 Jul 2019 05:46:03 +0000 (08:46 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 21 Jul 2019 11:58:35 +0000 (13:58 +0200)
USE flag to disable Python libs deps if no plugin support is desired
depend on system css-parser instead of bundled

Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Zamarin Arthur <arthurzam@gmail.com>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-text/sigil/metadata.xml
app-text/sigil/sigil-0.9.16.ebuild

index 745afeddf711b823c417edb9d3ab2acbf361d369..ec9790cba7878ce7bfc1ded22b536ea545e26f00 100644 (file)
@@ -12,6 +12,7 @@
        <longdescription lang="en">Sigil is a multi-platform WYSIWYG ebook editor.
                It is designed to edit books in ePub format.</longdescription>
        <use>
+               <flag name="plugins">Installed needed Python packages for using Sigil plugins</flag>
                <flag name="system-mathjax">Use the system-wide <pkg>dev-libs/mathjax</pkg> instead of bundled</flag>
        </use>
        <upstream>
index 1ee490a23ec7fdf29463556b4b6ee0de32681e16..2faaf3abb786b275e73856aaea99432cab6f5fe1 100644 (file)
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/Sigil-Ebook/Sigil/archive/${PV}.tar.gz -> ${P}.tar.g
 LICENSE="GPL-3+ Apache-2.0"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="system-mathjax"
+IUSE="+plugins system-mathjax"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND="
@@ -24,13 +24,8 @@ RDEPEND="
        dev-libs/boost:=[threads]
        dev-libs/libpcre:3=[pcre16]
        dev-libs/xerces-c[icu]
-       dev-python/chardet[${PYTHON_USEDEP}]
-       dev-python/cssselect[${PYTHON_USEDEP}]
-       dev-python/cssutils[${PYTHON_USEDEP}]
-       dev-python/html5lib[${PYTHON_USEDEP}]
+       dev-python/css-parser[${PYTHON_USEDEP}]
        dev-python/lxml[${PYTHON_USEDEP}]
-       dev-python/pillow[${PYTHON_USEDEP}]
-       dev-python/regex[${PYTHON_USEDEP}]
        dev-python/six[${PYTHON_USEDEP}]
        >=dev-qt/qtconcurrent-5.12:5
        >=dev-qt/qtcore-5.12:5
@@ -40,6 +35,14 @@ RDEPEND="
        >=dev-qt/qtwidgets-5.12:5
        >=dev-qt/qtxmlpatterns-5.12:5
        sys-libs/zlib[minizip]
+       plugins? (
+               dev-python/chardet[${PYTHON_USEDEP}]
+               dev-python/cssselect[${PYTHON_USEDEP}]
+               dev-python/cssutils[${PYTHON_USEDEP}]
+               dev-python/html5lib[${PYTHON_USEDEP}]
+               dev-python/pillow[${PYTHON_USEDEP}]
+               dev-python/regex[${PYTHON_USEDEP}]
+       )
        system-mathjax? ( dev-libs/mathjax )
 "
 DEPEND="${RDEPEND}"
@@ -66,6 +69,12 @@ For example use & # 1 6 0 ; for non-breaking spaces and etc.
 We strongly recommend enabling Mend On Open in your settings
 for best performance with Sigil."
 
+src_prepare() {
+       # bundled is a exact copy of the package, and upstream plan to switch soon
+       rm -r src/Resource_Files/plugin_launchers/python/css_parser/ || die
+       cmake-utils_src_prepare
+}
+
 src_configure() {
        python_export PYTHON_LIBPATH PYTHON_INCLUDEDIR
        local mycmakeargs=(