dev-perl/Bit-Vector: -r bump for EAPI7
authorKent Fredric <kentnl@gentoo.org>
Wed, 6 May 2020 11:01:25 +0000 (23:01 +1200)
committerKent Fredric <kentnl@gentoo.org>
Wed, 6 May 2020 11:02:25 +0000 (23:02 +1200)
- EAPI7
- Attempt to do something for upstreams license mess
- Parallel tests
- Remove empty assignments

Bug: https://bugs.gentoo.org/721222
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Bit-Vector/Bit-Vector-7.400.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Bit-Vector/Bit-Vector-7.400.0-r1.ebuild b/dev-perl/Bit-Vector/Bit-Vector-7.400.0-r1.ebuild
new file mode 100644 (file)
index 0000000..b8e0d2b
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=STBEY
+DIST_VERSION=7.4
+inherit perl-module
+
+DESCRIPTION="Efficient bit vector, set of integers and big int math library"
+# License note: upstream mess, bug #721222
+LICENSE="|| ( Artistic ( GPL-1 GPL-1+ ) ) LGPL-2 LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+       >=dev-perl/Carp-Clan-5.300.0
+       >=virtual/perl-Storable-2.210.0
+"
+BDEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+"