dev-python/rebulk: Call pytest directly
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 09:44:42 +0000 (10:44 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 11:05:35 +0000 (12:05 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/rebulk/rebulk-0.9.0.ebuild

index 2fc79bb065deaf371410716c9607e7b61c160d57..d0df2d1455caa306314b99971740f38c0971e8df 100644 (file)
@@ -14,17 +14,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="MIT Apache-2.0"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
 RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-runner[${PYTHON_USEDEP}]
-       )
-"
+
+distutils_enable_tests pytest
 
 python_prepare_all() {
        # Remove base64-encoded zip archive with pytest.
@@ -35,7 +28,3 @@ python_prepare_all() {
 
        distutils-r1_python_prepare_all
 }
-
-python_test() {
-       esetup.py test
-}