ebuild.sh: comment on noauto behavior
authorZac Medico <zmedico@gentoo.org>
Thu, 4 Oct 2012 22:17:57 +0000 (15:17 -0700)
committerZac Medico <zmedico@gentoo.org>
Thu, 4 Oct 2012 22:17:57 +0000 (15:17 -0700)
bin/ebuild.sh

index a74a84851fb5c2fda6a7e4ba0af4e4ed13820847..de54e22eb87ee2e64bca8eb2d70765ea55da7e32 100755 (executable)
@@ -520,10 +520,12 @@ if ___eapi_enables_globstar; then
        shopt -s globstar
 fi
 
+# Source the ebuild every time for FEATURES=noauto, so that ebuild
+# modifications take effect immediately.
 if ! has "$EBUILD_PHASE" clean cleanrm ; then
        if [[ $EBUILD_PHASE = depend || ! -f $T/environment || \
-               -f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \
-               has noauto $FEATURES ; then
+               -f $PORTAGE_BUILDDIR/.ebuild_changed || \
+               " ${FEATURES} " == *" noauto "* ]] ; then
                # The bashrcs get an opportunity here to set aliases that will be expanded
                # during sourcing of ebuilds and eclasses.
                __source_all_bashrcs