app-benchmarks/bootchart2: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:51:10 +0000 (09:51 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:51:10 +0000 (09:51 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
app-benchmarks/bootchart2/Manifest
app-benchmarks/bootchart2/bootchart2-0.14.7-r1.ebuild [deleted file]

index c1474b95b81222deb8fbea4b51dc7ffb4522787d..34f275c76d380ae79e9260d11483bc265ae7d76f 100644 (file)
@@ -1,2 +1 @@
-DIST bootchart2-0.14.7.tar.gz 1175145 BLAKE2B dfe56572eb2f85b68e0ad871c939ef16c48b0ee11ca881f03914d6773b86050091b232d80706f0df1d094c2e069c252609a0266d1cfa5159a6a0916321ea1dcf SHA512 82074a6ca6725a1b9ffe2a5d7f7bc6fd7918ab837573c23f75e7ebf209f30284ac7e59d2e84768ed313e4cee80da8e67dde167881d907fe71eff376ae9d16541
 DIST bootchart2-0.14.8.tar.gz 1175527 BLAKE2B 623ca2269420eda79b09d955ab9d4a37af004e9e97ad0e0c6014e53b4b0c63239661cb5359345306504980b060ccd11488970cb0aa3d832bfb55392724e715dd SHA512 58303db91d22ccc44c0dc765e7a6672fb277840555fd87ce64b8987cba85250cfe3db17f3ec7e0e1e726ad59166a5d3d01a7a262c07b5690c595877b46c66bd0
diff --git a/app-benchmarks/bootchart2/bootchart2-0.14.7-r1.ebuild b/app-benchmarks/bootchart2/bootchart2-0.14.7-r1.ebuild
deleted file mode 100644 (file)
index e9a732d..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_5 )
-
-inherit linux-info python-r1 systemd toolchain-funcs
-
-DESCRIPTION="Performance analysis and visualization of the system boot process"
-HOMEPAGE="https://github.com/mmeeks/bootchart/"
-SRC_URI="https://github.com/mmeeks/bootchart/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="svg test X"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
-       X? ( ${PYTHON_REQUIRED_USE} )
-       test? ( X )"
-
-RDEPEND="
-       !app-benchmarks/bootchart
-       X? (
-               dev-python/pycairo[svg(+)?,${PYTHON_USEDEP}]
-               dev-python/pygtk[$(python_gen_usedep 'python2*')]
-               ${PYTHON_DEPS}
-               )
-       sys-apps/lsb-release"
-DEPEND="${PYTHON_DEPS}"
-
-S="${WORKDIR}"/${PN%2}-${PV}
-
-CONFIG_CHECK="~PROC_EVENTS ~TASKSTATS ~TASK_DELAY_ACCT ~TMPFS"
-
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-sysmacros.patch #579922
-       tc-export CC
-       sed \
-               -e "/^install/s:py-install-compile::g" \
-               -e "/^SYSTEMD_UNIT_DIR/s:=.*:= $(systemd_get_unitdir):g" \
-               -i Makefile || die
-       sed \
-               -e '/^EXIT_PROC/s:^.*$:EXIT_PROC="agetty mgetty mingetty:g' \
-               -i bootchartd.conf bootchartd.in || die
-}
-
-src_test() {
-       python_foreach_impl emake test
-}
-
-src_install() {
-       export DOCDIR=/usr/share/doc/${PF}
-       default
-
-       # Note: LIBDIR is hardcoded as /lib in collector/common.h, so we shouldn't
-       # just change it. Since no libraries are installed, /lib is fine.
-       keepdir /lib/bootchart/tmpfs
-
-       installation() {
-               python_domodule pybootchartgui
-
-               python_newscript pybootchartgui.py pybootchartgui
-       }
-       use X && python_foreach_impl installation
-
-       newinitd "${FILESDIR}"/${PN}.init ${PN}
-
-}
-
-pkg_postinst() {
-       elog "If you are using an initrd during boot"
-       echo
-       elog "please add the init script to your default runlevel"
-       elog "rc-update add bootchart2 default"
-       echo
-}