gys-apps/kmscon: bump to new snapshot
authorBen Kohler <bkohler@gentoo.org>
Thu, 24 Oct 2019 16:07:33 +0000 (11:07 -0500)
committerBen Kohler <bkohler@gentoo.org>
Thu, 24 Oct 2019 16:09:24 +0000 (11:09 -0500)
This fork appears to be the new de-facto upstream.  The original
upstream version will remain in repo as long as it works, so users can
mask this new one if they want to stay "vanilla".

Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
sys-apps/kmscon/Manifest
sys-apps/kmscon/kmscon-8_p20180906.ebuild [new file with mode: 0644]

index f74a8b0969e8ac93aaa24e2b8c7055de1289aeb4..3a14ce097c38ab9c98d712db1751ef8caf38e3e2 100644 (file)
@@ -1 +1,2 @@
 DIST kmscon-8.tar.xz 950068 BLAKE2B 7c4bbcc6eb0967d8e38e05a3e6fac60109a0ce468bc8967364b621274a9af4dd12a31af692be2efe0cc234af36f760836ec421b6567460efd4b7b1c3d913f44b SHA512 ac1581c2520a9c30406848dafc27231b38d392b2176e3ed4dd95b03cd54e256dd22f09e04057fc089effbbe08eb25546164bb885e0e5cbdbd752d4c27d07a41d
+DIST kmscon-8_p20180906.tar.gz 1156350 BLAKE2B 52c024ca6e9652b468efb23d38cda34bf0c05e1e2bb4268435e17adb8858439ac6bf0e1783cfdd24a48fcb2dcf7c1cb20eee09aeb90db08c2e94224d01efeff7 SHA512 2ccdc5b30df6d96ac7a75d01d674b295bcdb0d445169716638a20c9884b090bbfe509e0aee79cb674a2d9b0eb18ea6284b9d4e2939cb5bf290cade4c1a02487a
diff --git a/sys-apps/kmscon/kmscon-8_p20180906.ebuild b/sys-apps/kmscon/kmscon-8_p20180906.ebuild
new file mode 100644 (file)
index 0000000..e74c5c7
--- /dev/null
@@ -0,0 +1,136 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT="01dd0a231e2125a40ceba5f59fd945ff29bf2cdc"
+SRC_URI="https://github.com/Aetf/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+inherit autotools flag-o-matic systemd vcs-snapshot
+
+DESCRIPTION="KMS/DRM based virtual Console Emulator"
+HOMEPAGE="https://github.com/Aetf/kmscon"
+
+LICENSE="MIT LGPL-2.1 BSD-2"
+SLOT="0"
+IUSE="debug doc +drm +fbdev +gles2 +optimizations +pango pixman static-libs systemd +unicode"
+
+COMMON_DEPEND="
+       >=virtual/udev-172
+       x11-libs/libxkbcommon
+       >=dev-libs/libtsm-4.0.0:=
+       media-libs/mesa[X(+)]
+       drm? ( x11-libs/libdrm
+               >=media-libs/mesa-8.0.3[egl,gbm] )
+       gles2? ( >=media-libs/mesa-8.0.3[gles2] )
+       systemd? ( sys-apps/systemd )
+       pango? ( x11-libs/pango dev-libs/glib:2 )
+       pixman? ( x11-libs/pixman )"
+RDEPEND="${COMMON_DEPEND}
+       x11-misc/xkeyboard-config"
+DEPEND="${COMMON_DEPEND}
+       virtual/pkgconfig
+       x11-base/xorg-proto
+       doc? ( dev-util/gtk-doc )"
+
+REQUIRED_USE="gles2? ( drm )"
+
+# args - names of renderers to enable
+renderers_enable() {
+       if [[ "x${RENDER}" == "x" ]]; then
+               RENDER="$1"
+               shift
+       else
+               for i in $@; do
+                       RENDER+=",${i}"
+               done
+       fi
+}
+
+# args - names of font renderer backends to enable
+fonts_enable() {
+       if [[ "x${FONTS}" == "x" ]]; then
+               FONTS="$1"
+               shift
+       else
+               for i in $@; do
+                       FONTS+=",${i}"
+               done
+       fi
+}
+
+# args - names of video backends to enable
+video_enable() {
+       if [[ "x${VIDEO}" == "x" ]]; then
+               VIDEO="$1"
+               shift
+       else
+               for i in $@; do
+                       VIDEO+=",${i}"
+               done
+       fi
+}
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       # Video backends
+
+       if use fbdev; then
+               video_enable fbdev
+       fi
+
+       if use drm; then
+               video_enable drm2d
+       fi
+
+       if use gles2; then
+               video_enable drm3d
+       fi
+
+       # Font rendering backends
+
+       if use unicode; then
+               fonts_enable unifont
+       fi
+
+       if use pango; then
+               fonts_enable pango
+       fi
+
+       # Console rendering backends
+
+       renderers_enable bbulk
+
+       if use gles2; then
+               renderers_enable gltex
+       fi
+
+       if use pixman; then
+               renderers_enable pixman
+       fi
+
+       # kmscon sets -ffast-math unconditionally
+       strip-flags
+
+       # xkbcommon not in portage
+       econf \
+               $(use_enable static-libs static) \
+               $(use_enable debug) \
+               $(use_enable optimizations) \
+               $(use_enable systemd multi-seat) \
+               --htmldir=/usr/share/doc/${PF}/html \
+               --with-video=${VIDEO} \
+               --with-fonts=${FONTS} \
+               --with-renderers=${RENDER} \
+               --with-sessions=dummy,terminal
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+       systemd_dounit "${S}/docs"/kmscon{,vt@}.service
+}