app-shells/zsh: fix build w/gcc-5 #547950
authorMike Frysinger <vapier@gentoo.org>
Fri, 2 Oct 2015 13:28:24 +0000 (09:28 -0400)
committerMike Frysinger <vapier@gentoo.org>
Fri, 2 Oct 2015 13:28:24 +0000 (09:28 -0400)
app-shells/zsh/files/zsh-5.1.0-gcc-5.patch [new file with mode: 0644]
app-shells/zsh/zsh-5.1.1.ebuild

diff --git a/app-shells/zsh/files/zsh-5.1.0-gcc-5.patch b/app-shells/zsh/files/zsh-5.1.0-gcc-5.patch
new file mode 100644 (file)
index 0000000..74756d2
--- /dev/null
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/547950
+http://www.zsh.org/mla/workers/2015/msg02660.html
+
+fix building w/gcc-5
+
+--- a/Src/Modules/system.mdd
++++ b/Src/Modules/system.mdd
+@@ -15,7 +15,7 @@
+               touch errtmp.out; \
+          else \
+               $(AWK) -f $(sdir)/errnames1.awk @ERRNO_H@ >errtmp.c; \
+-              $(CPP) errtmp.c >errtmp.out; \
++              $(CPP) -P errtmp.c >errtmp.out; \
+          fi
+          $(AWK) -f $(sdir)/errnames2.awk errtmp.out > $@
+          rm -f errtmp.c errtmp.out
index 695369ab8bfcc20b2fae69b4c782c1ac9fdfc7dd..295b2ca3d67310bc8f1d3b5e96d7607f768a1e6d 100644 (file)
@@ -53,6 +53,7 @@ src_prepare() {
        soelim Doc/zshall.1.soelim > Doc/zshall.1
 
        epatch "${FILESDIR}"/${PN}-init.d-gentoo-r1.diff
+       epatch "${FILESDIR}"/${PN}-5.1.0-gcc-5.patch #547950
 
        cp "${FILESDIR}"/zprofile-1 "${T}"/zprofile || die
        eprefixify "${T}"/zprofile || die