net-libs/liboauth: Fix openssl-1.1 building
authorPacho Ramos <pacho@gentoo.org>
Sat, 26 Jan 2019 16:01:35 +0000 (17:01 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sat, 26 Jan 2019 16:01:52 +0000 (17:01 +0100)
Thanks-to: Wataru Sakurai
Thanks-to: Albert W. Hopkins
Closes: https://bugs.gentoo.org/676080
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
net-libs/liboauth/files/liboauth-1.0.3-openssl-1.1_2.patch [new file with mode: 0644]
net-libs/liboauth/liboauth-1.0.3-r1.ebuild

diff --git a/net-libs/liboauth/files/liboauth-1.0.3-openssl-1.1_2.patch b/net-libs/liboauth/files/liboauth-1.0.3-openssl-1.1_2.patch
new file mode 100644 (file)
index 0000000..c22a775
--- /dev/null
@@ -0,0 +1,22 @@
+diff --git a/src/hash.c b/src/hash.c
+index 551991f..a0bc8b6 100644
+--- a/src/hash.c
++++ b/src/hash.c
+@@ -455,7 +455,7 @@ int oauth_verify_rsa_sha1 (const char *m, const char *c, const char *s) {
+   EVP_VerifyInit(md_ctx, EVP_sha1());
+   EVP_VerifyUpdate(md_ctx, m, strlen(m));
+   err = EVP_VerifyFinal(md_ctx, b64d, slen, pkey);
+-  EVP_MD_CTX_cleanup(md_ctx);
++  EVP_MD_CTX_free(md_ctx);
+   EVP_PKEY_free(pkey);
+   xfree(b64d);
+   return (err);
+@@ -485,7 +485,7 @@ char *oauth_body_hash_file(char *filename) {
+   len=0;
+   md=(unsigned char*) xcalloc(EVP_MD_size(EVP_sha1()),sizeof(unsigned char));
+   EVP_DigestFinal(ctx, md,(unsigned int*) &len);
+-  EVP_MD_CTX_cleanup(ctx);
++  EVP_MD_CTX_free(ctx);
+   return oauth_body_hash_encode(len, md);
+ }
index 96cf577256ea77efd1f737077ba83cfc6c1d7795..90acfdbc1fcc1a7b819e62911c5eb682a5133f89 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -17,6 +17,7 @@ REQUIRED_USE="bindist? ( nss )"
 PATCHES=(
        "${FILESDIR}"/${PN}-1.0.1-doxygen-out-of-tree.patch
        "${FILESDIR}"/${PN}-1.0.3-openssl-1.1.patch
+       "${FILESDIR}"/${PN}-1.0.3-openssl-1.1_2.patch
 )
 
 CDEPEND="