dev-php/pecl-mailparse: Revbump adding 7.4, dropping 5.6 and 7.0
authorBrian Evans <grknight@gentoo.org>
Mon, 14 Oct 2019 13:06:46 +0000 (09:06 -0400)
committerBrian Evans <grknight@gentoo.org>
Mon, 14 Oct 2019 13:06:46 +0000 (09:06 -0400)
Closes: https://bugs.gentoo.org/697682
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Brian Evans <grknight@gentoo.org>
dev-php/pecl-mailparse/pecl-mailparse-3.0.3-r1.ebuild [new file with mode: 0644]

diff --git a/dev-php/pecl-mailparse/pecl-mailparse-3.0.3-r1.ebuild b/dev-php/pecl-mailparse/pecl-mailparse-3.0.3-r1.ebuild
new file mode 100644 (file)
index 0000000..ba94254
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WANT_AUTOMAKE="none"
+PHP_EXT_NAME="mailparse"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_ECONF_ARGS=""
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
+PHP_EXT_NEEDED_USE="unicode"
+DOCS=( README.md )
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="PHP extension for parsing and working with RFC822 and MIME compliant messages"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE=""
+
+src_prepare() {
+       # Missing test source files in archive.  Fixed upstream in next release.
+       rm tests/011.phpt tests/bug001.phpt || die
+       php-ext-source-r3_src_prepare
+}