dev-perl/Authen-SASL: -r bump for EAPI7
authorKent Fredric <kentnl@gentoo.org>
Thu, 30 Apr 2020 11:00:00 +0000 (23:00 +1200)
committerKent Fredric <kentnl@gentoo.org>
Thu, 30 Apr 2020 11:02:00 +0000 (23:02 +1200)
- EAPI7
- Parallel Tests
- Move to "patch" instead of "sed"
- Improve dependencies

Package-Manager: Portage-2.3.97, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Authen-SASL/Authen-SASL-2.160.0-r2.ebuild [new file with mode: 0644]
dev-perl/Authen-SASL/files/Authen-SASL-2.16-no-dot-inc.patch [new file with mode: 0644]

diff --git a/dev-perl/Authen-SASL/Authen-SASL-2.160.0-r2.ebuild b/dev-perl/Authen-SASL/Authen-SASL-2.160.0-r2.ebuild
new file mode 100644 (file)
index 0000000..317928a
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=GBARR
+DIST_VERSION=2.16
+inherit perl-module
+
+DESCRIPTION="A Perl SASL interface"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="kerberos test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-perl/Digest-HMAC
+       virtual/perl-Digest-MD5
+       kerberos? ( dev-perl/GSSAPI )
+"
+BDEPEND="${DEPEND}
+       >=virtual/perl-ExtUtils-MakeMaker-6.42
+       test? (
+               virtual/perl-Test-Simple
+       )
+"
+PATCHES=(
+       "${FILESDIR}/${PN}-2.16-no-dot-inc.patch"
+)
diff --git a/dev-perl/Authen-SASL/files/Authen-SASL-2.16-no-dot-inc.patch b/dev-perl/Authen-SASL/files/Authen-SASL-2.16-no-dot-inc.patch
new file mode 100644 (file)
index 0000000..570457d
--- /dev/null
@@ -0,0 +1,24 @@
+From 3ee765fb6a909e8c22cb1853a9c22c8e4822c67b Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 30 Apr 2020 11:18:48 +1200
+Subject: Include '.' in @INC on Perl 5.28+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 4db553e..eebd90f 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -3,6 +3,7 @@
+ use strict;
+ use warnings;
+ use 5.005;
++use lib '.';
+ use inc::Module::Install;
+ name          'Authen-SASL';
+-- 
+2.26.2
+