sys-block/mtx: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 18 Oct 2019 12:18:38 +0000 (14:18 +0200)
committerDavid Seifert <soap@gentoo.org>
Fri, 18 Oct 2019 12:18:38 +0000 (14:18 +0200)
Closes: https://bugs.gentoo.org/697202
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
sys-block/mtx/files/mtx-1.3.12-fix-buildsystem.patch [new file with mode: 0644]
sys-block/mtx/mtx-1.3.12.ebuild

diff --git a/sys-block/mtx/files/mtx-1.3.12-fix-buildsystem.patch b/sys-block/mtx/files/mtx-1.3.12-fix-buildsystem.patch
new file mode 100644 (file)
index 0000000..6627bfa
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -109,13 +109,13 @@
+ dbgs: $(DBGS)
+ install: $(BINS)
+-      $(INSTALL_DIR) $(sbindir)
++      $(INSTALL_DIR) $(DESTDIR)$(sbindir)
+       for file in $(BINS); do \
+-      $(INSTALL_BIN) "$$file" $(sbindir) ; \
++      $(INSTALL_BIN) "$$file" $(DESTDIR)$(sbindir) ; \
+       done    
+-      $(INSTALL_DIR) $(mandir) $(mandir)/man1
++      $(INSTALL_DIR) $(mandir) $(DESTDIR)$(mandir)/man1
+       for file in mtx.1 tapeinfo.1 scsitape.1 scsieject.1 loaderinfo.1 ; do \
+-      $(INSTALL_DOC) "$$file"  $(mandir)/man1 ; \
++      $(INSTALL_DOC) "$$file"  $(DESTDIR)$(mandir)/man1 ; \
+       done
+ clean:
index 0053c550bc54558dd3cc184b5af9d2463de0f0d0..593c08791e97f85f2c80f963a13017d1b4b85c9f 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 DESCRIPTION="Utilities for controlling SCSI media changers and tape drives"
 HOMEPAGE="https://sourceforge.net/projects/mtx/"
@@ -10,10 +10,8 @@ SRC_URI="mirror://sourceforge/mtx/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
-IUSE=""
 
-src_install () {
-       einstall || die
-       dodoc CHANGES COMPATABILITY FAQ README TODO
-       dohtml mtxl.README.html
-}
+PATCHES=( "${FILESDIR}"/${P}-fix-buildsystem.patch )
+
+DOCS=( CHANGES COMPATABILITY FAQ README TODO )
+HTML_DOCS=( mtxl.README.html )