dev-ros/class_loader: bump to 0.3.3
authorAlexis Ballier <aballier@gentoo.org>
Mon, 14 Mar 2016 11:48:34 +0000 (12:48 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 14 Mar 2016 11:48:34 +0000 (12:48 +0100)
Package-Manager: portage-2.2.28
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/class_loader/Manifest
dev-ros/class_loader/class_loader-0.3.3.ebuild [new file with mode: 0644]

index 10f8543e27147a0578688c22bc9bf03e79f784b1..74e652b3306175c7ea0c4c9d68c76e7892ee6757 100644 (file)
@@ -1 +1,2 @@
 DIST class_loader-0.3.2.tar.gz 27250 SHA256 07668912491eb4ffc6bd97c330cc4d099b1fa46e286e3689b4edaec207932daf SHA512 82eb9bcc0a41f47dc07a4e8e66524c1417820a447b60f0cf49acfac2065ec5a75d5e492277e889b8f14e88c2b28a608d97d9d17cc24c2d34862938afb19267d4 WHIRLPOOL a6e1868a69171146f2cd1bdae4a6f3cf3ce607b3c80f327a70a0a0aa25687b41d4a57b15e1fc9cf82cb0fcf3b0ae1688b599e26a518922af9c777620fce90a02
+DIST class_loader-0.3.3.tar.gz 27821 SHA256 b39fc7ad4da4d092411bb82b5008d9ae480ab7dddd998253c4edb1f6efb48579 SHA512 d138a557f8d63f238016cebb46fc955e43028a8b4e845169fc149ac36f87b4cf6c9b40629e4ac97a672464dd176c3d04a65cc1129e638f822597a0feb977e3f6 WHIRLPOOL 77c41fa788a00d31166ee7bc1c0a10045a2de8c93b8dc7a670e75b487dd982067e6f0185265074929374bfc13018d051c30081c828c526d38e6acc862225e2ec
diff --git a/dev-ros/class_loader/class_loader-0.3.3.ebuild b/dev-ros/class_loader/class_loader-0.3.3.ebuild
new file mode 100644 (file)
index 0000000..d36e7c2
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/class_loader"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS-independent package for loading plugins"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/poco
+       dev-libs/boost:=[threads]
+       dev-ros/cmake_modules
+       dev-libs/console_bridge"
+DEPEND="${RDEPEND}"