sys-libs/compiler-rt: Fix stripping -nodefaultlibs
authorMichał Górny <mgorny@gentoo.org>
Wed, 29 Jan 2020 08:47:41 +0000 (09:47 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 29 Jan 2020 08:47:41 +0000 (09:47 +0100)
Closes: https://bugs.gentoo.org/706266
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild
sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild
sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild
sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild

index b5eea1980e7d7700ddd08460123b6f3246ceeeb6..fb90bbaab7cfed424884927aee57fb4b7cb8a22c 100644 (file)
@@ -62,9 +62,9 @@ src_configure() {
        if use clang; then
                local -x CC=${CHOST}-clang
                local -x CXX=${CHOST}-clang++
+               strip-unsupported-flags
                # ensure we can use clang before installing compiler-rt
                local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
-               strip-unsupported-flags
        elif ! test_compiler; then
                if test_compiler "${nolib_flags[@]}"; then
                        local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
index b5eea1980e7d7700ddd08460123b6f3246ceeeb6..fb90bbaab7cfed424884927aee57fb4b7cb8a22c 100644 (file)
@@ -62,9 +62,9 @@ src_configure() {
        if use clang; then
                local -x CC=${CHOST}-clang
                local -x CXX=${CHOST}-clang++
+               strip-unsupported-flags
                # ensure we can use clang before installing compiler-rt
                local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
-               strip-unsupported-flags
        elif ! test_compiler; then
                if test_compiler "${nolib_flags[@]}"; then
                        local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
index 8339d3420ba3a5099a3340edbb6833b206682261..1962c02d2f22b9e4cfd2dc3f4d37192611cbd7e3 100644 (file)
@@ -66,9 +66,9 @@ src_configure() {
        if use clang; then
                local -x CC=${CHOST}-clang
                local -x CXX=${CHOST}-clang++
+               strip-unsupported-flags
                # ensure we can use clang before installing compiler-rt
                local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
-               strip-unsupported-flags
        elif ! test_compiler; then
                if test_compiler "${nolib_flags[@]}"; then
                        local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
index 5049bf3761b8ca8f403a0c8f2109992e8292d114..403e394f744665ea33836947ade6546de5476cf3 100644 (file)
@@ -67,9 +67,9 @@ src_configure() {
        if use clang; then
                local -x CC=${CHOST}-clang
                local -x CXX=${CHOST}-clang++
+               strip-unsupported-flags
                # ensure we can use clang before installing compiler-rt
                local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
-               strip-unsupported-flags
        elif ! test_compiler; then
                if test_compiler "${nolib_flags[@]}"; then
                        local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
index af2de6ee54e01221d1a33941a3bd9c30a6e1e475..f5ce47c037e86667c7678a77e8e0a52fef3e728d 100644 (file)
@@ -62,9 +62,9 @@ src_configure() {
        if use clang; then
                local -x CC=${CHOST}-clang
                local -x CXX=${CHOST}-clang++
+               strip-unsupported-flags
                # ensure we can use clang before installing compiler-rt
                local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
-               strip-unsupported-flags
        elif ! test_compiler; then
                if test_compiler "${nolib_flags[@]}"; then
                        local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"