net-libs/libupnp: Bump to 1.8.0, introduce 1.8 slot
authorIan Whyman <thev00d00@gentoo.org>
Wed, 4 Jan 2017 23:10:17 +0000 (23:10 +0000)
committerIan Whyman <thev00d00@gentoo.org>
Wed, 4 Jan 2017 23:10:45 +0000 (23:10 +0000)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

net-libs/libupnp/Manifest
net-libs/libupnp/files/libupnp-1.8.0-docs-install.patch [new file with mode: 0644]
net-libs/libupnp/libupnp-1.8.0.ebuild [new file with mode: 0644]

index 63ea80a790b3aeebce476ccad20e9021ca5906b9..f90322e9e04b01dad3148dabf88614160b96d8c4 100644 (file)
@@ -2,3 +2,4 @@ DIST libupnp-1.6.18.tar.bz2 1201056 SHA256 b21bc676365622d3ace1b25292dab8d4d23f6
 DIST libupnp-1.6.19.tar.bz2 1213439 SHA256 b3142b39601243b50532eec90f4a27dba85eb86f58d4b849ac94edeb29d9b22a SHA512 97af62a7483cc19cfe80157cbc3383c1b4b7c9c39b848f4ed063784b74df0b9b0527f7b467e01451e0a44dbf9e8a9eab510619146a6ee1e3dce46f3e4af6e661 WHIRLPOOL fe3ed0115c76872b45eb3f16909e23c61b004f028b745be17346b94dffd7c90108420cf71f50f73aa4ef241403b65b9d1c72926af3044ffacdae11f9649dad68
 DIST libupnp-1.6.20.tar.bz2 1243637 SHA256 ee3537081e3ea56f66ada10387486823989210bc98002f098305551c966e3a63 SHA512 754a3f587963078fc60e8a58f6b04536dac03d053c8cd14d4fd7e505a3417484fa03b72dd09ef92150f00263f270aa19646b7aab1b8707111aff53c43f8a120a WHIRLPOOL df2702b30a9e895371ba0647bfdd017fd17b4478feb691efaf754618fa032cb8ba72317030960676584da44dfc144f8b9bd07218799b40c2afa7fdee28e8b164
 DIST libupnp-1.6.21.tar.bz2 1245353 SHA256 af3f3c0846a1d75baeadae4aa5a2bda427567e2a1fb4559bf73ccff0a4f9a39b SHA512 65a2989497b941dfa1f7ac09fe44267de4a5231af25a304f0f6e754c7cbb578bdcb3c500188b5ebfbff9f579099db7501817d45e1724ef8e384d6d918bcdcdeb WHIRLPOOL b4869189054ac00d57394e0919ad2f672af64f2c2b0ecc676c2b3fc4a3c22caa25ac38b57bbb5cf1ef12a5857b4cdfd450c6bd5955a5eacaf8bdf95a058c9dab
+DIST libupnp-1.8.0.tar.gz 1380524 SHA256 1ddfb4e12e947deb5637e0d5e09bbe7835dfc8fb8a57712346026afa029165b1 SHA512 e2ae54352d747191f3ffc15c50481da515665fb35ddf6a9e488b6e1962e47803937bf078d0c2c5d56f8339cfd226ffba7433975363dc312e484ed22f83eda061 WHIRLPOOL c3d4abf54d25e87a1d650a18c475097a47633e8bf7691248695a7682ecff8aca4419c8eb2db4d24d62ca5a7905321971adf924166c20876ee18dd32d846748a1
diff --git a/net-libs/libupnp/files/libupnp-1.8.0-docs-install.patch b/net-libs/libupnp/files/libupnp-1.8.0-docs-install.patch
new file mode 100644 (file)
index 0000000..f0fbd04
--- /dev/null
@@ -0,0 +1,13 @@
+--- libupnp-1.6.19/upnp/sample/Makefile.am.orig        2013-11-15 19:50:02.000000000 +0400
++++ libupnp-1.6.19/upnp/sample/Makefile.am     2016-06-03 20:30:43.545081667 +0300
+@@ -65,8 +65,8 @@
+ if WITH_DOCUMENTATION
+ examplesdir = $(docdir)/examples
+ examples_DATA = \
+-      $(tv_ctrlpt_1_8_SOURCES) \
+-      $(tv_device_1_8_SOURCES)
++      $(sort $(tv_ctrlpt_1_8_SOURCES) \
++      $(tv_device_1_8_SOURCES) )
+ endif
+ EXTRA_DIST = \
diff --git a/net-libs/libupnp/libupnp-1.8.0.ebuild b/net-libs/libupnp/libupnp-1.8.0.ebuild
new file mode 100644 (file)
index 0000000..abee901
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils flag-o-matic autotools vcs-snapshot
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/mrjimenez/pupnp/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="1.8"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
+IUSE="debug doc ipv6 static-libs"
+
+DOCS="NEWS README.md ChangeLog"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.8.0-docs-install.patch
+)
+
+src_prepare() {
+       default
+
+       # fix tests
+       chmod +x ixml/test/test_document.sh || die
+
+       eautoreconf
+}
+
+src_configure() {
+       use x86-fbsd && append-flags -O1
+       # w/o docdir to avoid sandbox violations
+       econf \
+               $(use_enable debug) \
+               $(use_enable ipv6) \
+               $(use_enable static-libs static) \
+               $(use_with doc documentation "${EPREFIX}/usr/share/doc/${PF}")
+}
+
+src_install () {
+       default
+       dobin upnp/sample/.libs/tv_{combo,ctrlpt,device}-1.8
+       use static-libs || prune_libtool_files
+}