app-admin/eclean-kernel: Switch -9999 back to ek1 repo
authorMichał Górny <mgorny@gentoo.org>
Sun, 24 May 2020 08:18:27 +0000 (10:18 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 24 May 2020 08:35:46 +0000 (10:35 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-admin/eclean-kernel/eclean-kernel-9999.ebuild

index 164b0f4939589b0ed82214a2c50e998a7058bf30..edb37d5f75dc4d708c935963b22ec6e92c1f90d9 100644 (file)
@@ -1,21 +1,22 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-EGIT_REPO_URI="https://github.com/mgorny/eclean-kernel2.git"
-inherit autotools git-r3
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
 
-DESCRIPTION="Clean up old and stale kernel files"
-HOMEPAGE="https://github.com/mgorny/eclean-kernel2"
-SRC_URI=""
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Remove outdated built kernels"
+HOMEPAGE="https://github.com/mgorny/eclean-kernel/"
+EGIT_REPO_URI="https://github.com/mgorny/eclean-kernel.git"
 
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS=""
 IUSE=""
 
-src_prepare() {
-       default
-       eautoreconf
-}
+RDEPEND="kernel_linux? ( dev-python/pymountboot[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest