dev-python/twisted: Bump to 20.3.0
authorMichał Górny <mgorny@gentoo.org>
Fri, 24 Apr 2020 16:17:50 +0000 (18:17 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 24 Apr 2020 19:24:22 +0000 (21:24 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/twisted/Manifest
dev-python/twisted/twisted-20.3.0.ebuild [new file with mode: 0644]

index 64aab758114b1995808f124e343a1228bcaa79d8..36da34ceefad2eac5faee180f3e109c5412f53f5 100644 (file)
@@ -1,4 +1,5 @@
 DIST Twisted-16.6.0.tar.bz2 2979747 BLAKE2B 898e0a0fa3ae8547a801b09118423ec8ad80727dd6d034e3f8a151f084eff5a3fc560f2eb9e76c452a14ec90b36d93e14d3bbb388010c3c5c01fd1c4d5ca16bb SHA512 0b8de0ec7f64457f76c396fced64b366b8e63c6e000a5edc6c6388cd917fb2f95711918cd8edda39e0aa77e2cd32b5d775d23630a5ad10fc013c18f8316300cf
 DIST Twisted-18.4.0.tar.bz2 3037019 BLAKE2B 6fc32f7591493ccc4fe03233307b566899b82cd035ba3329b3faaf950339a6653de697ba3873b37b22f9d7f8a66109694b80496917bf61e79c56eeb7e351ac87 SHA512 3733a6df0196ea580187da3576f5fd08f287437528a4e19813056d019cca213c61b62d879d80a12eef38661d3505ba33aac9a4fc956b19afa6da7d37a6465c83
 DIST Twisted-19.10.0.tar.bz2 3118485 BLAKE2B a0d532b67177aa017e463bf823d7842d4f6ff694f78cd7600865718ffe861023a53ea6a922f7de232133edba26f5255074d7ef277ce8f3bdf02d556ccf4abf41 SHA512 de8d7fd0b2081cebeff68b060c8469377011648bc563a94a993d3530fb007ed42c3a54925c9a10c465ee7a3065cc9108ace12d10d358223fab13494becb9ac4b
+DIST Twisted-20.3.0.tar.bz2 3127793 BLAKE2B 2e85fc3ec26d89e563c9e79a5d2adea81ff1745d18f0f92b8d45ae3729fbddf09998664257880372c7a4caeb5977c5cad7c863596b8c27ad7890275cead9f763 SHA512 1b850e5fc21a3630ead4c2cc3622c16e78bb3be38ab11d021779b7ce3d3c30acc4e19d79c7791a5fce6c5c6e09c2baa349901dffe952de67dd98eec419846365
 DIST twisted-regen-cache.gz 911 BLAKE2B ffd3fcda6c67ffe6fd3ef581c8d507548396b66ed0708e9a5c790095e579c0d5f0f71596acf05712989da2ddef2b8d437eca973bc4d80ef8a9fa852915f38305 SHA512 95a9b931c73017d16d1b5e6b41345dddffe62b6af1a8e93b5e40d06d3d15be17b0dd0181c767ffeeb791534d463764ef9e066fa6c2ee2ac4b53c86d1da8fce03
diff --git a/dev-python/twisted/twisted-20.3.0.ebuild b/dev-python/twisted/twisted-20.3.0.ebuild
new file mode 100644 (file)
index 0000000..5ec7908
--- /dev/null
@@ -0,0 +1,176 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 virtualx
+
+TWISTED_PN="Twisted"
+TWISTED_P="${TWISTED_PN}-${PV}"
+TWISTED_RELEASE=$(ver_cut 1-2)
+
+DESCRIPTION="An asynchronous networking framework written in Python"
+HOMEPAGE="https://www.twistedmatrix.com/trac/"
+SRC_URI="https://twistedmatrix.com/Releases/${TWISTED_PN}"
+SRC_URI="${SRC_URI}/${TWISTED_RELEASE}/${TWISTED_P}.tar.bz2
+       https://dev.gentoo.org/~mgorny/dist/twisted-regen-cache.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="conch crypt http2 serial test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+       >=dev-python/automat-0.3.0[${PYTHON_USEDEP}]
+       >=dev-python/constantly-15.1.0[${PYTHON_USEDEP}]
+       >=dev-python/hyperlink-17.1.1[${PYTHON_USEDEP}]
+       >=dev-python/incremental-16.10.1[${PYTHON_USEDEP}]
+       >=dev-python/pyhamcrest-1.9.0[${PYTHON_USEDEP}]
+       >=dev-python/zope-interface-4.4.2[${PYTHON_USEDEP}]
+       conch? (
+               dev-python/pyasn1[${PYTHON_USEDEP}]
+               >=dev-python/cryptography-1.5.0[${PYTHON_USEDEP}]
+               >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+       )
+       crypt? (
+               >=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
+               dev-python/service_identity[${PYTHON_USEDEP}]
+               >=dev-python/idna-0.6[${PYTHON_USEDEP}]
+       )
+       serial? ( >=dev-python/pyserial-3.0[${PYTHON_USEDEP}] )
+       http2? (
+               >=dev-python/hyper-h2-3.0.0[${PYTHON_USEDEP}]
+               <dev-python/hyper-h2-4.0.0[${PYTHON_USEDEP}]
+               >=dev-python/priority-1.1.0[${PYTHON_USEDEP}]
+               <dev-python/priority-2.0[${PYTHON_USEDEP}]
+       )
+       !dev-python/twisted-core
+       !dev-python/twisted-conch
+       !dev-python/twisted-lore
+       !dev-python/twisted-mail
+       !dev-python/twisted-names
+       !dev-python/twisted-news
+       !dev-python/twisted-pair
+       !dev-python/twisted-runner
+       !dev-python/twisted-words
+       !dev-python/twisted-web
+"
+DEPEND="
+       dev-python/bcrypt
+       >=dev-python/incremental-16.10.1[${PYTHON_USEDEP}]
+       test? (
+               dev-python/gmpy[${PYTHON_USEDEP}]
+               dev-python/pyasn1[${PYTHON_USEDEP}]
+               >=dev-python/cryptography-0.9.1[${PYTHON_USEDEP}]
+               >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+               >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+               dev-python/service_identity[${PYTHON_USEDEP}]
+               dev-python/idna[${PYTHON_USEDEP}]
+               dev-python/pyserial[${PYTHON_USEDEP}]
+               >=dev-python/constantly-15.1.0[${PYTHON_USEDEP}]
+               net-misc/openssh
+       )
+"
+
+S=${WORKDIR}/${TWISTED_P}
+
+python_prepare_all() {
+       # upstream test for making releases; not very useful and requires
+       # sphinx (including on py2)
+       rm src/twisted/python/test/test_release.py || die
+
+       # puts system in EMFILE state, then the exception handler may fail
+       # trying to open more files due to some gi magic
+       sed -e '/SKIP_EMFILE/s:None:"Fails on non-pristine systems":' \
+               -i src/twisted/internet/test/test_tcp.py || die
+
+       # multicast tests fail within network-sandbox
+       sed -e 's:test_joinLeave:_&:' \
+               -e 's:test_loopback:_&:' \
+               -e 's:test_multiListen:_&:' \
+               -e 's:test_multicast:_&:' \
+               -i src/twisted/test/test_udp.py || die
+
+       # accesses /dev/net/tun
+       sed -e '/class RealDeviceTestsMixin/a\
+    skip = "Requires extra permissions"' \
+               -i src/twisted/pair/test/test_tuntap.py || die
+
+       # TODO: figure it out, probably doesn't accept DST date here
+       sed -e 's:test_getTimezoneOffsetWithoutDaylightSavingTime:_&:' \
+               -i src/twisted/test/test_log.py || die
+
+       # TODO: failures specific to Python 2
+       sed -e 's:testLookupProcNetTcp:_&:' \
+               -i src/twisted/test/test_ident.py || die
+       sed -e 's:test_loggingFactoryOpensLogfileAutomatically:_&:' \
+               -i src/twisted/test/test_policies.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+src_test() {
+       virtx distutils-r1_src_test
+}
+
+python_test() {
+       # TODO: upstream seems to override our build paths
+       distutils_install_for_testing
+
+       "${EPYTHON}" -m twisted.trial twisted ||
+               die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+       distutils-r1_python_install
+
+       cd "${D}$(python_get_sitedir)" || die
+
+       # own the dropin.cache so we don't leave orphans
+       touch twisted/plugins/dropin.cache || die
+
+       python_doscript "${WORKDIR}"/twisted-regen-cache
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       newconfd "${FILESDIR}/twistd.conf" twistd
+       newinitd "${FILESDIR}/twistd.init" twistd
+}
+
+python_postinst() {
+       twisted-regen-cache || die
+}
+
+pkg_postinst() {
+       python_foreach_impl python_postinst
+
+       einfo "Install complete"
+       if use test ; then
+               einfo ""
+               einfo "Some tests have been disabled during testing due to"
+               einfo "known incompatibilities with the emerge sandboxes and/or"
+               einfo "not runnable as the root user."
+               einfo "For a complete test suite run on the code."
+               einfo "Run the tests as a normal user for each python it is installed to."
+               einfo "  ie:  $ python3.6 /usr/bin/trial twisted"
+       fi
+}
+
+python_postrm() {
+       rm -f "${ROOT}$(python_get_sitedir)/twisted/plugins/dropin.cache" || die
+}
+
+pkg_postrm() {
+       # if we're removing the last version, remove the cache file
+       if [[ ! ${REPLACING_VERSIONS} ]]; then
+               python_foreach_impl python_postrm
+       fi
+}