net-misc/grive: RDEPEND on sys-libs/binutils-libs is needed (#528088)
authorPacho Ramos <pacho@gentoo.org>
Sat, 3 Oct 2015 09:16:02 +0000 (11:16 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sat, 3 Oct 2015 09:16:21 +0000 (11:16 +0200)
Package-Manager: portage-2.2.22

net-misc/grive/grive-0.4.0_pre20150905-r1.ebuild [new file with mode: 0644]

diff --git a/net-misc/grive/grive-0.4.0_pre20150905-r1.ebuild b/net-misc/grive/grive-0.4.0_pre20150905-r1.ebuild
new file mode 100644 (file)
index 0000000..7929b2f
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+if [[ ${PV} = *9999 ]]; then
+       inherit git-2
+       EGIT_REPO_URI="git://github.com/vitalif/${PN}2.git"
+else
+       inherit vcs-snapshot
+       COMMIT="5dc7028c8aebb26d35ed31c4b07ac180cc1887c9"
+       SRC_URI="https://github.com/vitalif/${PN}2/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="An open source Linux client for Google Drive"
+HOMEPAGE="https://github.com/vitalif/grive2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       dev-libs/boost:=
+       dev-libs/expat
+       >=dev-libs/json-c-0.11-r1:=
+       dev-libs/libgcrypt:0=
+       net-misc/curl
+       sys-libs/binutils-libs:0=
+       sys-libs/glibc
+       dev-libs/yajl
+"
+DEPEND="${RDEPEND}"