Add a patch to improve xinerama support, by Lubos Lunak.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Fri, 24 Nov 2006 15:17:48 +0000 (15:17 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Fri, 24 Nov 2006 15:17:48 +0000 (15:17 +0000)
Package-Manager: portage-2.1.2_rc2-r1

kde-base/kdelibs/ChangeLog
kde-base/kdelibs/files/digest-kdelibs-3.5.5-r7 [new file with mode: 0644]
kde-base/kdelibs/kdelibs-3.5.5-r7.ebuild [new file with mode: 0644]
kde-base/kdesktop/ChangeLog
kde-base/kdesktop/files/digest-kdesktop-3.5.5-r1 [new file with mode: 0644]
kde-base/kdesktop/files/kdesktop-3.5.5-seli-xinerama.patch [new file with mode: 0644]
kde-base/kdesktop/kdesktop-3.5.5-r1.ebuild [new file with mode: 0644]
kde-base/kwin/ChangeLog
kde-base/kwin/files/digest-kwin-3.5.5-r2 [new file with mode: 0644]
kde-base/kwin/kwin-3.5.5-r2.ebuild [new file with mode: 0644]

index 32490e7daeb034e5f867341afa89319e2d602594..cf07153073a7f777b1ea24f1ed0a61b5a3ea3702 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for kde-base/kdelibs
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.392 2006/11/23 11:00:15 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.393 2006/11/24 15:10:28 flameeyes Exp $
+
+*kdelibs-3.5.5-r7 (24 Nov 2006)
+
+  24 Nov 2006; Diego Pettenò <flameeyes@gentoo.org>
+  +files/kdelibs-3.5.5-seli-xinerama.patch, +kdelibs-3.5.5-r7.ebuild:
+  Add a patch to improve xinerama support, by Lubos Lunak.
 
   23 Nov 2006; Guy Martin <gmsoft@gentoo.org> kdelibs-3.5.5-r5.ebuild:
   Stable on hppa.
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.5.5-r7 b/kde-base/kdelibs/files/digest-kdelibs-3.5.5-r7
new file mode 100644 (file)
index 0000000..cec88e0
--- /dev/null
@@ -0,0 +1,9 @@
+MD5 6f8254317dd43af7aea2a347656f552a kdelibs-3.5-patchset-05.tar.bz2 36423
+RMD160 684bb235f3b5b3cb900632e11aa912670f641b96 kdelibs-3.5-patchset-05.tar.bz2 36423
+SHA256 f237ccd3a35c629740355fbcf69b0d706690acac832a4d35db5c0d3a30235e0a kdelibs-3.5-patchset-05.tar.bz2 36423
+MD5 d8ce997461cb1aa2255032f02fd14326 kdelibs-3.5.5-seli-xinerama.patch.bz2 5470
+RMD160 46ed378f1ff2f7e2fa113aa0bf51eae1758264f9 kdelibs-3.5.5-seli-xinerama.patch.bz2 5470
+SHA256 8d002a55954aabdb91a534a1b1f1f37c706faebbae0398fb5a2ff29eeb66954c kdelibs-3.5.5-seli-xinerama.patch.bz2 5470
+MD5 2cba792e3b0a766431b837c8ef924117 kdelibs-3.5.5.tar.bz2 15486690
+RMD160 8e389869f9a53445754c76a0f7535ef2fffc6d03 kdelibs-3.5.5.tar.bz2 15486690
+SHA256 e487cdd56aa14eec3e100501a5e14658c6329fac30ea0ce812c860e3564c31e3 kdelibs-3.5.5.tar.bz2 15486690
diff --git a/kde-base/kdelibs/kdelibs-3.5.5-r7.ebuild b/kde-base/kdelibs/kdelibs-3.5.5-r7.ebuild
new file mode 100644 (file)
index 0000000..e9860b4
--- /dev/null
@@ -0,0 +1,198 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.5-r7.ebuild,v 1.1 2006/11/24 15:10:28 flameeyes Exp $
+
+inherit kde flag-o-matic eutils multilib
+set-kdedir 3.5
+
+DESCRIPTION="KDE libraries needed by all KDE programs."
+HOMEPAGE="http://www.kde.org/"
+SRC_URI="mirror://kde/stable/${PV}/src/${P}.tar.bz2
+       mirror://gentoo/kdelibs-3.5-patchset-05.tar.bz2
+       mirror://gentoo/${P}-seli-xinerama.patch.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.5"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="acl alsa arts cups doc jpeg2k kerberos legacyssl utempter openexr spell ssl tiff
+zeroconf avahi kernel_linux fam lua linguas_he"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
+# so we recreate the entire DEPEND from scratch.
+
+# Added aspell-en as dependency to work around bug 131512.
+RDEPEND="$(qt_min_version 3.3.3)
+       arts? ( ~kde-base/arts-${PV} )
+       app-arch/bzip2
+       >=media-libs/freetype-2
+       media-libs/fontconfig
+       >=dev-libs/libxslt-1.1.16
+       >=dev-libs/libxml2-2.6.6
+       >=dev-libs/libpcre-4.2
+       media-libs/libart_lgpl
+       net-dns/libidn
+       acl? ( kernel_linux? ( sys-apps/acl ) )
+       ssl? ( >=dev-libs/openssl-0.9.7d )
+       alsa? ( media-libs/alsa-lib )
+       cups? ( >=net-print/cups-1.1.19 )
+       tiff? ( media-libs/tiff )
+       kerberos? ( virtual/krb5 )
+       jpeg2k? ( media-libs/jasper )
+       openexr? ( >=media-libs/openexr-1.2.2-r2 )
+       zeroconf? (     !avahi? ( net-misc/mDNSResponder !kde-misc/kdnssd-avahi ) )
+       fam? ( virtual/fam )
+       virtual/ghostscript
+       utempter? ( sys-libs/libutempter )
+       !kde-base/kde-env
+       lua? ( dev-lang/lua )
+       spell? ( app-text/aspell app-dicts/aspell-en
+               linguas_he? ( >=app-text/hspell-1.0 ) )"
+
+DEPEND="${RDEPEND}
+       doc? ( app-doc/doxygen )
+       sys-devel/gettext"
+
+RDEPEND="${RDEPEND}
+       || ( ( x11-apps/rgb x11-apps/iceauth ) <virtual/x11-7 ) "
+
+PDEPEND="zeroconf? ( avahi? ( kde-misc/kdnssd-avahi ) )"
+
+# Testing code is rather broken and merely for developer purposes, so disable it.
+RESTRICT="test"
+
+pkg_setup() {
+       if use legacyssl ; then
+               echo ""
+               elog "You have the legacyssl use flag enabled, which fixes issues with some broken"
+               elog "sites, but breaks others instead. It is strongly discouraged to use it."
+               elog "For more information, see bug #128922."
+               echo ""
+       fi
+       if ! use utempter ; then
+               echo ""
+               elog "On some setups that relies on the correct update of utmp records, not using"
+               elog "utempter might not update them correctly. If you experience unexpected"
+               elog "behaviour, try to rebuild kde-base/kdelibs with utempter use-flag enabled."
+               echo ""
+       fi
+}
+
+src_unpack() {
+       kde_src_unpack
+       if use legacyssl ; then
+               # This patch won't be included upstream, see bug #128922
+               epatch "${WORKDIR}/patches/kdelibs_3.5.4-kssl-3des.patch" || die "Patch did not apply."
+       fi
+
+       # Apply the following patch on the next revision of kdelibs-3.5.5 (fixes kde
+       # bug #135409), which corrects a nasty regression in the cstyle indenter.
+       epatch "${FILESDIR}/${P}-kate-cstyle-indenter-fix.diff"
+
+       # Fix kdeprint timeout when trying to connect to cupsd. Bug #151261.
+       epatch "${FILESDIR}/${P}-kdeprint-cupsd-timeout-fix.patch"
+
+       # Fix rendering (see upstream bug #135639).
+       epatch "${FILESDIR}/${P}-khtml.patch"
+
+       # Allow notification with arts disabled
+       epatch "${FILESDIR}/${P}-noarts.patch"
+       epatch "${FILESDIR}/${P}-noarts-2.patch"
+
+       # xinerama patch from Lubos Lunak
+       # http://ktown.kde.org/~seli/xinerama/
+       epatch "${DISTDIR}/${P}-seli-xinerama.patch"
+}
+
+src_compile() {
+       rm -f "${S}/configure"
+
+       myconf="--with-distribution=Gentoo --disable-fast-malloc
+                       $(use_enable fam libfam) $(use_enable kernel_linux dnotify)
+                       --with-libart --with-libidn
+                       $(use_with acl) $(use_with ssl)
+                       $(use_with alsa) $(use_with arts)
+                       $(use_with kerberos gssapi) $(use_with tiff)
+                       $(use_with jpeg2k jasper) $(use_with openexr)
+                       $(use_enable cups)
+                       $(use_with utempter) $(use_with lua)
+                       $(use_enable kernel_linux sendfile) --enable-mitshm
+                       $(use_with spell aspell)"
+
+       if use zeroconf && ! use avahi; then
+               myconf="${myconf} --enable-dnssd"
+       else
+               myconf="${myconf} --disable-dnssd"
+       fi
+
+       if use spell; then
+               myconf="${myconf} $(use_with linguas_he hspell)"
+       else
+               myconf="${myconf} --without-hspell"
+       fi
+
+       if has_version x11-apps/rgb; then
+               myconf="${myconf} --with-rgbfile=/usr/share/X11/rgb.txt"
+       fi
+
+       # fix bug 58179, bug 85593
+       # kdelibs-3.4.0 needed -fno-gcse; 3.4.1 needs -mminimal-toc; this needs a
+       # closer look... - corsair
+       use ppc64 && append-flags "-mminimal-toc"
+
+       # work around bug #120858, gcc 3.4.x -Os miscompilation
+       use x86 && replace-flags "-Os" "-O2" # see bug #120858
+
+       export BINDNOW_FLAGS="$(bindnow-flags)"
+
+       kde_src_compile
+
+       if use doc; then
+               make apidox || die
+       fi
+}
+
+src_install() {
+       kde_src_install
+
+       if use doc; then
+               make DESTDIR="${D}" install-apidox || die
+       fi
+
+       # Needed to create lib -> lib64 symlink for amd64 2005.0 profile
+       if [ "${SYMLINK_LIB}" = "yes" ]; then
+               dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) ${KDEDIR}/lib
+       fi
+
+       # Get rid of the disabled version of the kdnsd libraries
+       if use zeroconf && use avahi; then
+               rm -rf "${D}/${PREFIX}"/$(get_libdir)/libkdnssd.*
+       fi
+
+       dodir /etc/env.d
+
+       # List all the multilib libdirs
+       local libdirs
+       for libdir in $(get_all_libdirs); do
+               libdirs="${libdirs}:${PREFIX}/${libdir}"
+       done
+
+       cat <<EOF > "${D}"/etc/env.d/45kdepaths-${SLOT} # number goes down with version upgrade
+PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
+LDPATH=${libdirs:1}
+CONFIG_PROTECT="${PREFIX}/share/config ${PREFIX}/env ${PREFIX}/shutdown /usr/share/config"
+KDEDIRS="${PREFIX}:/usr:/usr/local"
+#KDE_IS_PRELINKED=1
+EOF
+}
+
+pkg_postinst() {
+       if use zeroconf; then
+               echo
+               elog "To make zeroconf support available in KDE make sure that the 'mdnsd' daemon"
+               elog "is running. Make sure also that multicast dns lookups are enabled by editing"
+               elog "the 'hosts:' line in /etc/nsswitch.conf to include 'mdns', e.g.:"
+               elog "  hosts: files mdns dns"
+               echo
+       fi
+}
index 92126ff609dcea377fbe1de9dd7cd19869da5e23..0759f758d8d7b052d05badff6ee1118fee028331 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for kde-base/kdesktop
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/ChangeLog,v 1.70 2006/11/18 17:25:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/ChangeLog,v 1.71 2006/11/24 15:17:48 flameeyes Exp $
+
+*kdesktop-3.5.5-r1 (24 Nov 2006)
+
+  24 Nov 2006; Diego Pettenò <flameeyes@gentoo.org>
+  +files/kdesktop-3.5.5-seli-xinerama.patch, +kdesktop-3.5.5-r1.ebuild:
+  Add a patch to improve xinerama support, by Lubos Lunak.
 
   18 Nov 2006; Diego Pettenò <flameeyes@gentoo.org> -kdesktop-3.5.3.ebuild,
   -kdesktop-3.5.3-r1.ebuild, -kdesktop-3.5.4.ebuild,
diff --git a/kde-base/kdesktop/files/digest-kdesktop-3.5.5-r1 b/kde-base/kdesktop/files/digest-kdesktop-3.5.5-r1
new file mode 100644 (file)
index 0000000..f51965c
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 420445e2dbddfd83ebc25e85a9b9cdda kdebase-3.5-patchset-03.tar.bz2 21409
+RMD160 941b919097d03347b10bccb51db2fa5e89d7ba16 kdebase-3.5-patchset-03.tar.bz2 21409
+SHA256 59c691754627f78daf7693e82496d808cf1cc31e2d6f32af829ec4ccfd776574 kdebase-3.5-patchset-03.tar.bz2 21409
+MD5 0c685af1cbca75f9c77b3ed231ba0468 kdebase-3.5.5.tar.bz2 23851886
+RMD160 6cf804de0487347a3e1d4ea6e5ba5114d23d9806 kdebase-3.5.5.tar.bz2 23851886
+SHA256 f77632e44214648e2d0adfe1a79dd61a6a738c21fe5abb0baff16b72432baaa0 kdebase-3.5.5.tar.bz2 23851886
diff --git a/kde-base/kdesktop/files/kdesktop-3.5.5-seli-xinerama.patch b/kde-base/kdesktop/files/kdesktop-3.5.5-seli-xinerama.patch
new file mode 100644 (file)
index 0000000..18e637d
--- /dev/null
@@ -0,0 +1,87 @@
+Index: kdebase-3.5.5/kdesktop/desktop.cc
+===================================================================
+--- kdebase-3.5.5.orig/kdesktop/desktop.cc
++++ kdebase-3.5.5/kdesktop/desktop.cc
+@@ -516,9 +516,12 @@ void KDesktop::popupExecuteCommand(const
+   if ( m_miniCli->isVisible() ) {
+       KWin::forceActiveWindow( m_miniCli->winId() );
+   } else {
+-      QRect rect = KGlobalSettings::desktopGeometry(QCursor::pos());
+-      m_miniCli->move(rect.x() + (rect.width() - m_miniCli->width())/2,
+-                      rect.y() + (rect.height() - m_miniCli->height())/2);
++      NETRootInfo i( qt_xdisplay(), NET::Supported );
++      if( !i.isSupported( NET::WM2FullPlacement )) {
++          QRect rect = KGlobalSettings::desktopGeometry(QCursor::pos());
++          m_miniCli->move(rect.x() + (rect.width() - m_miniCli->width())/2,
++                          rect.y() + (rect.height() - m_miniCli->height())/2);
++      }
+       m_miniCli->show(); // non-modal
+   }
+ }
+Index: kdebase-3.5.5/kdesktop/minicli.cpp
+===================================================================
+--- kdebase-3.5.5.orig/kdesktop/minicli.cpp
++++ kdebase-3.5.5/kdesktop/minicli.cpp
+@@ -369,6 +369,17 @@ int Minicli::runCommand()
+     cmd = uri.path();
+   else
+     cmd = uri.url();
++    
++  QCString asn;
++  if( qApp->desktop()->isVirtualDesktop())
++  {
++    asn = KStartupInfo::createNewStartupId();
++    KStartupInfoId id;
++    id.initId( asn );
++    KStartupInfoData data;
++    data.setXinerama( qApp->desktop()->screenNumber( this ));
++    KStartupInfo::sendChange( id, data );
++  }
+   // Determine whether the application should be run through
+   // the command line (terminal) interface...
+@@ -504,7 +515,7 @@ int Minicli::runCommand()
+         case KURIFilterData::HELP:
+         {
+           // No need for kfmclient, KRun does it all (David)
+-          (void) new KRun( m_filterData->uri(), parentWidget());
++          (void) new KRun( m_filterData->uri(), parentWidget(), asn );
+           return 0;
+         }
+         case KURIFilterData::EXECUTABLE:
+@@ -516,7 +527,7 @@ int Minicli::runCommand()
+             if (service && service->isValid() && service->type() == "Application")
+             {
+               notifyServiceStarted(service);
+-              KRun::run(*service, KURL::List());
++              KRun::run(*service, KURL::List(), parentWidget(), asn );
+               return 0;
+             }
+           }
+@@ -551,7 +562,7 @@ int Minicli::runCommand()
+           if (service && service->isValid() && service->type() == "Application")
+           {
+             notifyServiceStarted(service);
+-            KRun::run(*service, KURL::List(), this);
++            KRun::run(*service, KURL::List(), parentWidget(), asn );
+             return 0;
+           }
+@@ -559,7 +570,7 @@ int Minicli::runCommand()
+           if (service && service->isValid() && service->type() == "Application")
+           {
+             notifyServiceStarted(service);
+-            KRun::run(*service, KURL::List(), this);
++            KRun::run(*service, KURL::List(), parentWidget(), asn );
+             return 0;
+           }
+@@ -571,7 +582,7 @@ int Minicli::runCommand()
+       }
+     }
+-    if ( KRun::runCommand( cmd, exec, m_iconName ) )
++    if ( KRun::runCommand( cmd, exec, m_iconName, parentWidget(), asn ) )
+       return 0;
+     else
+     {
diff --git a/kde-base/kdesktop/kdesktop-3.5.5-r1.ebuild b/kde-base/kdesktop/kdesktop-3.5.5-r1.ebuild
new file mode 100644 (file)
index 0000000..3c0513b
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/kdesktop-3.5.5-r1.ebuild,v 1.1 2006/11/24 15:17:48 flameeyes Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+       mirror://gentoo/kdebase-3.5-patchset-03.tar.bz2"
+
+DESCRIPTION="KDesktop is the KDE interface that handles the icons, desktop popup menus and the screensaver system."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="xscreensaver"
+
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkonq)
+       $(deprange $PV $MAXKDEVER kde-base/kcontrol)
+       xscreensaver? ( || ( x11-proto/scrnsaverproto <virtual/x11-7 ) )"
+       # Requires the desktop background settings module,
+       # so until we separate the kcontrol modules into separate ebuilds :-),
+       # there's a dep here
+RDEPEND="${DEPEND}
+       $(deprange 3.5.0 $MAXKDEVER kde-base/kcheckpass)
+       $(deprange $PV $MAXKDEVER kde-base/kdialog)
+       $(deprange $PV $MAXKDEVER kde-base/konqueror)
+       xscreensaver? ( || ( x11-libs/libXScrnSaver <virtual/x11-7 ) )"
+
+KMCOPYLIB="libkonq libkonq/"
+KMEXTRACTONLY="kcheckpass/kcheckpass.h
+       libkonq/
+       kdm/kfrontend/themer/
+       kioslave/thumbnail/configure.in.in" # for the HAVE_LIBART test
+KMCOMPILEONLY="kcontrol/background
+       kdmlib/"
+KMNODOCS=true
+
+PATCHES="${FILESDIR}/${P}-seli-xinerama.patch"
+
+src_compile() {
+       myconf="${myconf} $(use_with xscreensaver)"
+       kde-meta_src_compile
+}
+
+src_install() {
+       # ugly, needs fixing: don't install kcontrol/background
+       kde-meta_src_install
+
+       rmdir "${D}/${PREFIX}/share/templates/.source/emptydir"
+}
+
+pkg_postinst() {
+       mkdir -p "${PREFIX}/share/templates/.source/emptydir"
+}
index caa4688fbb6ff4f6d5de87e716a881e20a8d3429..2eb37b3de737ffc9083c1ba7d6cf20d5f7f8e25c 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for kde-base/kwin
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.74 2006/11/18 19:19:27 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.75 2006/11/24 15:15:03 flameeyes Exp $
+
+*kwin-3.5.5-r2 (24 Nov 2006)
+
+  24 Nov 2006; Diego Pettenò <flameeyes@gentoo.org> +kwin-3.5.5-r2.ebuild:
+  Add a patch to improve xinerama support, by Lubos Lunak.
 
   18 Nov 2006; Diego Pettenò <flameeyes@gentoo.org> -kwin-3.5.3.ebuild,
   -kwin-3.5.4.ebuild, -kwin-3.5.5.ebuild:
diff --git a/kde-base/kwin/files/digest-kwin-3.5.5-r2 b/kde-base/kwin/files/digest-kwin-3.5.5-r2
new file mode 100644 (file)
index 0000000..c20b37f
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 0c685af1cbca75f9c77b3ed231ba0468 kdebase-3.5.5.tar.bz2 23851886
+RMD160 6cf804de0487347a3e1d4ea6e5ba5114d23d9806 kdebase-3.5.5.tar.bz2 23851886
+SHA256 f77632e44214648e2d0adfe1a79dd61a6a738c21fe5abb0baff16b72432baaa0 kdebase-3.5.5.tar.bz2 23851886
+MD5 82502eb472e384005994143b8e78e999 kwin-3.5.5-seli-xinerama.patch.bz2 7362
+RMD160 e1c83cd6ca967b24e82851c0f286d57ab68d7730 kwin-3.5.5-seli-xinerama.patch.bz2 7362
+SHA256 20baec02a66f500ea6e16a239aa123d2a62c2f80107b3a0a72b72ecd918aa0d3 kwin-3.5.5-seli-xinerama.patch.bz2 7362
diff --git a/kde-base/kwin/kwin-3.5.5-r2.ebuild b/kde-base/kwin/kwin-3.5.5-r2.ebuild
new file mode 100644 (file)
index 0000000..98f25e2
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-3.5.5-r2.ebuild,v 1.1 2006/11/24 15:15:03 flameeyes Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="xcomposite"
+RDEPEND="xcomposite? ( || ( (
+                       x11-libs/libXcomposite
+                       x11-libs/libXdamage
+                       ) <x11-base/xorg-x11-7 )
+               )"
+DEPEND="${RDEPEND}
+       xcomposite? ( || ( (
+                       x11-proto/compositeproto
+                       x11-proto/damageproto
+                       ) <x11-base/xorg-x11-7 )
+               )"
+
+SRC_URI="${SRC_URI}
+       mirror://gentoo/${P}-seli-xinerama.patch.bz2"
+
+PATCHES="${FILESDIR}/${P}-input-shape.patch
+       ${DISTDIR}/${P}-seli-xinerama.patch.bz2"
+
+src_compile() {
+       myconf="$myconf $(use_with xcomposite composite)"
+       kde-meta_src_compile
+}