x11-themes/arc-theme: Bump to 20200502 snapshot, fixes Inkscape issue
authorJames Le Cuirot <chewi@gentoo.org>
Sun, 10 May 2020 10:29:54 +0000 (11:29 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 10 May 2020 10:31:39 +0000 (11:31 +0100)
Upstream has changed yet again! The new repository may get merged back
into the old but they haven't decided yet.

Closes: https://bugs.gentoo.org/700524
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
x11-themes/arc-theme/Manifest
x11-themes/arc-theme/arc-theme-20200502.ebuild [new file with mode: 0644]
x11-themes/arc-theme/metadata.xml

index a52dc02a5ac8fbefbfe2625b54ed1cdd6ed7063a..eeaa8e4d3bc8f93b0192ebe5888dc961cbc205c4 100644 (file)
@@ -2,3 +2,5 @@ DIST arc-theme-20190330-pngs.tar.xz 87632 BLAKE2B a860abe61d98c1ba2c7e13d21cb24e
 DIST arc-theme-20190330.tar.xz 227936 BLAKE2B 35815019884c55ce2d22dbb2d78892c00b35839b017fb7f0c1e9e1f1bad1bf94703e0c15205045eed96add556381c28fdd702c7657226fd75492304abaafd41d SHA512 ac4f1bde028e027314004999502dcc914abf6070ffd4345021df486084de2c943e6c110776b3b6af55143962a40b368c060a11754ffaf30300b87cb923bc55b9
 DIST arc-theme-20190917-pngs.tar.xz 87664 BLAKE2B 8f4cd7cf4eaeef6e71113178776e35f81df1c7a86c5a4e1727ddac9e2c18f81ff51f0b8c2ca578c176fddb969fcbdef7135080c1a8851f56e1b1a33d8c2b86e6 SHA512 5ded6dd5f0c7067c8abefef8fae4620caf795f10b5fe46c30ab7b430379f3b3e2eb27ec85c752bb4a77288a640bcf6a5f4d60e19a97f96af1b31143014afde37
 DIST arc-theme-20190917.tar.xz 308592 BLAKE2B 0ca3b6bb9c501891243755984799c404645a524fd5e65e6ed5d509d3c3b0b54d60a2219030b86d6e8a19a12106da832ff4a4fcd35ff1f02766b57d104e9e642b SHA512 da3e98e696160542fc77678193ff4fdeecc1cab7b4c1ec57e1bd850486a80547e1d688c9784f5ef422f097449f1105c071a3ff917c25a6a315fe970bedf10c6f
+DIST arc-theme-20200502-pngs.tar.xz 88116 BLAKE2B 18dfee1f51a0e1e272f73523617600490584d9044539717d8a4712083d6cb87751449818b38d503bbc0a8ef016690d606a7f23ba253eda48aecfbadc0cb1b483 SHA512 c25df3088c6edcd88799200e33005b56bf048dff606a06678c8cc7af6d0d84eb9237fcc76b16057bbee538ffa01ae7e983ab94dd184b140ec45d12a8d06d3a1f
+DIST arc-theme-20200502.tar.gz 1090296 BLAKE2B 10feeecee89007b6ae1aab2e7ad95f2f3513660e2d4dafccf659b0829047b0cb551b4d8e6923d409ededba2ec5ff9f6c93f0b2c3959e3a68d5e51ccbb76861d5 SHA512 95ebf8e434af1b5976ebef7489b9b5c51c919cd161cb6dc86056559f7b34c56a8d5580b74a30bf32dc1a32636f1c7633ab20ad204f6102d92509cf1e21032fcd
diff --git a/x11-themes/arc-theme/arc-theme-20200502.ebuild b/x11-themes/arc-theme/arc-theme-20200502.ebuild
new file mode 100644 (file)
index 0000000..1c0b07e
--- /dev/null
@@ -0,0 +1,100 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT="958b9b554cde5a8be7280bdf4a908ebe833cbd81"
+
+# USE="-* gtk2 gtk3 xfce" ebuild ${P}.ebuild clean compile
+# cd ~portage/x11-themes/${P}/work
+# make -j -C */common/gtk-3.0/3.18
+# find */common/{gtk-2.0,gtk-3.0/3.*,xfwm4} -name "*.png" ! -path "*/menubar-toolbar/*" | xargs tar Jcvf /usr/portage/distfiles/${P}-pngs.tar.xz --owner=root --group=root
+
+inherit autotools
+
+DESCRIPTION="A flat theme with transparent elements for GTK+3, GTK+2 and GNOME Shell"
+HOMEPAGE="https://github.com/jnsh/arc-theme"
+SRC_URI="https://github.com/jnsh/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz
+       pre-rendered? ( https://dev.gentoo.org/~chewi/distfiles/${P}-pngs.tar.xz )"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="cinnamon gnome-shell +gtk2 +gtk3 mate +pre-rendered xfce"
+
+SASSC_DEPEND="
+       dev-lang/sassc
+"
+
+SVG_DEPEND="
+       !pre-rendered? (
+               media-gfx/inkscape
+               media-gfx/optipng
+       )
+"
+
+# Supports various GTK+3 versions and uses pkg-config to determine which
+# set of files to install. Updates will break it but only this fix will
+# help. See https://github.com/horst3180/arc-theme/pull/436. The same
+# applies to GNOME Shell but I don't know whether that's fixable.
+BDEPEND="
+       cinnamon? (
+               ${SASSC_DEPEND}
+       )
+       gnome-shell? (
+               ${SASSC_DEPEND}
+               >=gnome-base/gnome-shell-3.18
+       )
+       gtk2? (
+               ${SVG_DEPEND}
+       )
+       gtk3? (
+               ${SASSC_DEPEND}
+               ${SVG_DEPEND}
+               virtual/pkgconfig
+               >=x11-libs/gtk+-3.18:3
+       )
+       xfce? (
+               ${SVG_DEPEND}
+       )
+"
+
+# gnome-themes-standard is only needed by GTK+2 for the Adwaita
+# engine. This engine is built into GTK+3.
+RDEPEND="
+       gtk2? (
+               x11-themes/gnome-themes-standard
+               x11-themes/gtk-engines-murrine
+       )
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       use pre-rendered &&
+               export INKSCAPE="${BROOT}"/bin/false OPTIPNG="${BROOT}"/bin/false
+
+       econf \
+               --disable-openbox \
+               --disable-plank \
+               --disable-unity \
+               $(use_enable cinnamon) \
+               $(use_enable gtk2) \
+               $(use_enable gtk3) \
+               $(use_enable gnome-shell) \
+               $(use_enable mate metacity) \
+               $(use_enable xfce xfwm)
+}
+
+src_compile() {
+       # fontconfig issue?
+       # https://bugs.gentoo.org/666418#c28
+       use pre-rendered ||
+               addpredict "${EPREFIX}"/usr/share/inkscape/fonts/.uuid.TMP-XXXXXX
+
+       default
+}
index cec57cceb9c0d9fc4daba0d13e05b0038ffcf17a..7b1d8564373b424aa85fcc4015dd296086f0ee82 100644 (file)
@@ -6,7 +6,7 @@
                <name>James Le Cuirot</name>
        </maintainer>
        <upstream>
-               <remote-id type="github">arc-design/arc-theme</remote-id>
+               <remote-id type="github">jnsh/arc-theme</remote-id>
        </upstream>
        <use>
                <flag name="cinnamon">Install theme for <pkg>gnome-extra/cinnamon</pkg></flag>