sys-apps/shadow: Security revbump to fix CVE-2017-2616 (bug #610804).
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 24 Feb 2017 12:42:44 +0000 (13:42 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 24 Feb 2017 12:43:48 +0000 (13:43 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sys-apps/shadow/files/shadow-4.4-CVE-2017-2616.patch [new file with mode: 0644]
sys-apps/shadow/shadow-4.4-r2.ebuild [new file with mode: 0644]

diff --git a/sys-apps/shadow/files/shadow-4.4-CVE-2017-2616.patch b/sys-apps/shadow/files/shadow-4.4-CVE-2017-2616.patch
new file mode 100644 (file)
index 0000000..b788ec3
--- /dev/null
@@ -0,0 +1,62 @@
+From 08fd4b69e84364677a10e519ccb25b71710ee686 Mon Sep 17 00:00:00 2001
+From: Tobias Stoeckmann <tobias@stoeckmann.org>
+Date: Thu, 23 Feb 2017 09:47:29 -0600
+Subject: [PATCH] su: properly clear child PID
+
+If su is compiled with PAM support, it is possible for any local user
+to send SIGKILL to other processes with root privileges. There are
+only two conditions. First, the user must be able to perform su with
+a successful login. This does NOT have to be the root user, even using
+su with the same id is enough, e.g. "su $(whoami)". Second, SIGKILL
+can only be sent to processes which were executed after the su process.
+It is not possible to send SIGKILL to processes which were already
+running. I consider this as a security vulnerability, because I was
+able to write a proof of concept which unlocked a screen saver of
+another user this way.
+---
+ src/su.c | 19 +++++++++++++++++--
+ 1 file changed, 17 insertions(+), 2 deletions(-)
+
+diff --git a/src/su.c b/src/su.c
+index f20d230..d86aa86 100644
+--- a/src/su.c
++++ b/src/su.c
+@@ -379,11 +379,13 @@ static void prepare_pam_close_session (void)
+                               /* wake child when resumed */
+                               kill (pid, SIGCONT);
+                               stop = false;
++                      } else {
++                              pid_child = 0;
+                       }
+               } while (!stop);
+       }
+-      if (0 != caught) {
++      if (0 != caught && 0 != pid_child) {
+               (void) fputs ("\n", stderr);
+               (void) fputs (_("Session terminated, terminating shell..."),
+                             stderr);
+@@ -393,9 +395,22 @@ static void prepare_pam_close_session (void)
+               snprintf (wait_msg, sizeof wait_msg, _(" ...waiting for child to terminate.\n"));
+               (void) signal (SIGALRM, kill_child);
++              (void) signal (SIGCHLD, catch_signals);
+               (void) alarm (2);
+-              (void) wait (&status);
++              sigemptyset (&ourset);
++              if ((sigaddset (&ourset, SIGALRM) != 0)
++                  || (sigprocmask (SIG_BLOCK, &ourset, NULL) != 0)) {
++                      fprintf (stderr, _("%s: signal masking malfunction\n"), Prog);
++                      kill_child (0);
++              } else {
++                      while (0 == waitpid (pid_child, &status, WNOHANG)) {
++                              sigsuspend (&ourset);
++                      }
++                      pid_child = 0;
++                      (void) sigprocmask (SIG_UNBLOCK, &ourset, NULL);
++              }
++
+               (void) fputs (_(" ...terminated.\n"), stderr);
+       }
diff --git a/sys-apps/shadow/shadow-4.4-r2.ebuild b/sys-apps/shadow/shadow-4.4-r2.ebuild
new file mode 100644 (file)
index 0000000..b28554f
--- /dev/null
@@ -0,0 +1,215 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils libtool pam multilib
+
+DESCRIPTION="Utilities to deal with user accounts"
+HOMEPAGE="https://github.com/shadow-maint/shadow http://pkg-shadow.alioth.debian.org/"
+SRC_URI="https://github.com/shadow-maint/shadow/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="acl audit cracklib nls pam selinux skey xattr"
+# Taken from the man/Makefile.am file.
+LANGS=( cs da de es fi fr hu id it ja ko pl pt_BR ru sv tr zh_CN zh_TW )
+IUSE+=" $(printf 'linguas_%s ' ${LANGS[*]})"
+
+RDEPEND="acl? ( sys-apps/acl:0= )
+       audit? ( >=sys-process/audit-2.6:0= )
+       cracklib? ( >=sys-libs/cracklib-2.7-r3:0= )
+       pam? ( virtual/pam:0= )
+       skey? ( sys-auth/skey:0= )
+       selinux? (
+               >=sys-libs/libselinux-1.28:0=
+               sys-libs/libsemanage:0=
+       )
+       nls? ( virtual/libintl )
+       xattr? ( sys-apps/attr:0= )"
+DEPEND="${RDEPEND}
+       app-arch/xz-utils
+       nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+       pam? ( >=sys-auth/pambase-20150213 )"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-4.1.3-dots-in-usernames.patch
+       "${FILESDIR}"/${P}-su-snprintf.patch
+       "${FILESDIR}"/${P}-prototypes.patch
+       "${FILESDIR}"/${P}-load_defaults.patch
+       "${FILESDIR}"/${P}-CVE-2017-2616.patch #610804
+)
+
+src_prepare() {
+       epatch "${PATCHES[@]}"
+       epatch_user
+       #eautoreconf
+       elibtoolize
+}
+
+src_configure() {
+       econf \
+               --without-group-name-max-length \
+               --without-tcb \
+               --enable-shared=no \
+               --enable-static=yes \
+               $(use_with acl) \
+               $(use_with audit) \
+               $(use_with cracklib libcrack) \
+               $(use_with pam libpam) \
+               $(use_with skey) \
+               $(use_with selinux) \
+               $(use_enable nls) \
+               $(use_with elibc_glibc nscd) \
+               $(use_with xattr attr)
+       has_version 'sys-libs/uclibc[-rpc]' && sed -i '/RLOGIN/d' config.h #425052
+
+       if use nls ; then
+               local l langs="po" # These are the pot files.
+               for l in ${LANGS[*]} ; do
+                       use linguas_${l} && langs+=" ${l}"
+               done
+               sed -i "/^SUBDIRS = /s:=.*:= ${langs}:" man/Makefile || die
+       fi
+}
+
+set_login_opt() {
+       local comment="" opt=$1 val=$2
+       if [[ -z ${val} ]]; then
+               comment="#"
+               sed -i \
+                       -e "/^${opt}\>/s:^:#:" \
+                       "${ED}"/etc/login.defs || die
+       else
+               sed -i -r \
+                       -e "/^#?${opt}\>/s:.*:${opt} ${val}:" \
+                       "${ED}"/etc/login.defs
+       fi
+       local res=$(grep "^${comment}${opt}\>" "${ED}"/etc/login.defs)
+       einfo "${res:-Unable to find ${opt} in /etc/login.defs}"
+}
+
+src_install() {
+       emake DESTDIR="${D}" suidperms=4711 install
+
+       # Remove libshadow and libmisc; see bug 37725 and the following
+       # comment from shadow's README.linux:
+       #   Currently, libshadow.a is for internal use only, so if you see
+       #   -lshadow in a Makefile of some other package, it is safe to
+       #   remove it.
+       rm -f "${ED}"/{,usr/}$(get_libdir)/lib{misc,shadow}.{a,la}
+
+       insinto /etc
+       if ! use pam ; then
+               insopts -m0600
+               doins etc/login.access etc/limits
+       fi
+
+       # needed for 'useradd -D'
+       insinto /etc/default
+       insopts -m0600
+       doins "${FILESDIR}"/default/useradd
+
+       # move passwd to / to help recover broke systems #64441
+       mv "${ED}"/usr/bin/passwd "${ED}"/bin/ || die
+       dosym /bin/passwd /usr/bin/passwd
+
+       cd "${S}"
+       insinto /etc
+       insopts -m0644
+       newins etc/login.defs login.defs
+
+       set_login_opt CREATE_HOME yes
+       if ! use pam ; then
+               set_login_opt MAIL_CHECK_ENAB no
+               set_login_opt SU_WHEEL_ONLY yes
+               set_login_opt CRACKLIB_DICTPATH /usr/$(get_libdir)/cracklib_dict
+               set_login_opt LOGIN_RETRIES 3
+               set_login_opt ENCRYPT_METHOD SHA512
+               set_login_opt CONSOLE
+       else
+               dopamd "${FILESDIR}"/pam.d-include/shadow
+
+               for x in chpasswd chgpasswd newusers; do
+                       newpamd "${FILESDIR}"/pam.d-include/passwd ${x}
+               done
+
+               for x in chage chsh chfn \
+                                user{add,del,mod} group{add,del,mod} ; do
+                       newpamd "${FILESDIR}"/pam.d-include/shadow ${x}
+               done
+
+               # comment out login.defs options that pam hates
+               local opt sed_args=()
+               for opt in \
+                       CHFN_AUTH \
+                       CONSOLE \
+                       CRACKLIB_DICTPATH \
+                       ENV_HZ \
+                       ENVIRON_FILE \
+                       FAILLOG_ENAB \
+                       FTMP_FILE \
+                       LASTLOG_ENAB \
+                       MAIL_CHECK_ENAB \
+                       MOTD_FILE \
+                       NOLOGINS_FILE \
+                       OBSCURE_CHECKS_ENAB \
+                       PASS_ALWAYS_WARN \
+                       PASS_CHANGE_TRIES \
+                       PASS_MIN_LEN \
+                       PORTTIME_CHECKS_ENAB \
+                       QUOTAS_ENAB \
+                       SU_WHEEL_ONLY
+               do
+                       set_login_opt ${opt}
+                       sed_args+=( -e "/^#${opt}\>/b pamnote" )
+               done
+               sed -i "${sed_args[@]}" \
+                       -e 'b exit' \
+                       -e ': pamnote; i# NOTE: This setting should be configured via /etc/pam.d/ and not in this file.' \
+                       -e ': exit' \
+                       "${ED}"/etc/login.defs || die
+
+               # remove manpages that pam will install for us
+               # and/or don't apply when using pam
+               find "${ED}"/usr/share/man \
+                       '(' -name 'limits.5*' -o -name 'suauth.5*' ')' \
+                       -delete
+
+               # Remove pam.d files provided by pambase.
+               rm "${ED}"/etc/pam.d/{login,passwd,su} || die
+       fi
+
+       # Remove manpages that are handled by other packages
+       find "${ED}"/usr/share/man \
+               '(' -name id.1 -o -name passwd.5 -o -name getspnam.3 ')' \
+               -delete
+
+       cd "${S}"
+       dodoc ChangeLog NEWS TODO
+       newdoc README README.download
+       cd doc
+       dodoc HOWTO README* WISHLIST *.txt
+}
+
+pkg_preinst() {
+       rm -f "${EROOT}"/etc/pam.d/system-auth.new \
+               "${EROOT}/etc/login.defs.new"
+}
+
+pkg_postinst() {
+       # Enable shadow groups.
+       if [ ! -f "${EROOT}"/etc/gshadow ] ; then
+               if grpck -r -R "${EROOT}" 2>/dev/null ; then
+                       grpconv -R "${EROOT}"
+               else
+                       ewarn "Running 'grpck' returned errors.  Please run it by hand, and then"
+                       ewarn "run 'grpconv' afterwards!"
+               fi
+       fi
+
+       einfo "The 'adduser' symlink to 'useradd' has been dropped."
+}