Add a fix for parllel make builds
authorCaleb Tennis <caleb@gentoo.org>
Wed, 10 Mar 2004 03:23:53 +0000 (03:23 +0000)
committerCaleb Tennis <caleb@gentoo.org>
Wed, 10 Mar 2004 03:23:53 +0000 (03:23 +0000)
kde-base/kdepim/ChangeLog
kde-base/kdepim/Manifest
kde-base/kdepim/files/kpilot-parallel-make-fix.patch [new file with mode: 0644]
kde-base/kdepim/kdepim-3.2.1.ebuild

index ce94bc37eacdee0a63ff3a47a7b90b0a1b9a26eb..fe7633ca3f07ac7b6d9f5ba4afb2b1c07afcfbd0 100644 (file)
Binary files a/kde-base/kdepim/ChangeLog and b/kde-base/kdepim/ChangeLog differ
index 0e18b152dcdee95962a0a542bddce4b34a8feb35..5f929f75dff5a3212ecf6b5e8205f150d4e328d3 100644 (file)
@@ -1,14 +1,15 @@
 MD5 a5246276a2ba2c18912e24556ecb88ce kdepim-3.2.0-r2.ebuild 826
 MD5 371e5c3368c91d600adf57559ddf06eb kdepim-3.1.5.ebuild 796
 MD5 bb8e62370b86408792fbf3fdde2df702 kdepim-3.1.4.ebuild 852
-MD5 21d33fe20fd154f27805e5c381c9fe64 ChangeLog 9885
+MD5 b987ce2d24f296a8f77310236ab47183 ChangeLog 10064
 MD5 14889ab75f97d76e58b0c1154e7683a9 metadata.xml 161
-MD5 a8f07dcb2acc8602c28c03bac66d4d89 kdepim-3.2.1.ebuild 743
+MD5 1d626775e49addb64b0a76ebd45b3ab4 kdepim-3.2.1.ebuild 839
 MD5 917d71da75c5eac3a6ef30c8551fc347 kdepim-3.0.5b.ebuild 575
 MD5 10f1253acc1418066ffea529e8818b43 files/digest-kdepim-3.1.4 66
 MD5 0658e29c8e0fa024884f165bf129e8e9 files/digest-kdepim-3.1.5 66
 MD5 af91bc84a08ead68b8cc99511ff098ab files/digest-kdepim-3.2.1 66
 MD5 bf481282b9583a3e4095dcdef1aee22c files/KMail-inboxEater-BRANCH.diff 1619
+MD5 6f3f2b21eacb5869a9cbb821ffcf48a6 files/kpilot-parallel-make-fix.patch 737
 MD5 d833726815dce86df6d79630ceeecfdc files/digest-kdepim-3.0.5b 67
 MD5 bafdafa3d2488fa1168ccbb4a981dd87 files/digest-kdepim-3.2.0-r2 66
 MD5 ee45bc53826f95bcf3a3367db4d3845e files/kmfilter.cpp.patch 1528
diff --git a/kde-base/kdepim/files/kpilot-parallel-make-fix.patch b/kde-base/kdepim/files/kpilot-parallel-make-fix.patch
new file mode 100644 (file)
index 0000000..c7a7c7b
--- /dev/null
@@ -0,0 +1,17 @@
+--- kpilot/conduits/vcalconduit/Makefile.am.orig       2004-03-09 17:14:39.000000000 -0500
++++ kpilot/conduits/vcalconduit/Makefile.am    2004-03-09 17:16:32.000000000 -0500
+@@ -26,12 +26,14 @@
+ conduit_vcal_la_LIBADD = ../../lib/libkpilot.la \
+       ../../../libkcal/libkcal.la \
+       libvcalconduit_shared.la
++conduit_vcal_la_COMPILE_FIRST = korganizerConduit.h
+ conduit_todo_la_SOURCES = todo-factory.cc todo-setup.cc todo-conduit.cc
+ conduit_todo_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+ conduit_todo_la_LIBADD = ../../lib/libkpilot.la \
+       ../../../libkcal/libkcal.la \
+       libvcalconduit_shared.la
++conduit_todo_la_COMPILE_FIRST = korganizerConduit.h
+ libvcalconduit_shared_la_SOURCES = korganizerConduit.ui \
+       vcal-factorybase.cc \
index 864a315501cf1b144eb45d90f3024a18a325e88b..4c8a6e7d19a9de88567a3c72573495d9d3f3f249 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/kdepim-3.2.1.ebuild,v 1.2 2004/03/09 12:34:44 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/kdepim-3.2.1.ebuild,v 1.3 2004/03/10 03:23:53 caleb Exp $
 
 inherit kde-dist
 
@@ -14,6 +14,11 @@ DEPEND="~kde-base/kdenetwork-${PV}
        ldap? ( net-nds/openldap )
        crypt? ( app-crypt/cryptplug app-crypt/gnupg )"
 
+src_unpack() {
+       kde_src_unpack
+       cd ${S} && epatch ${FILESDIR}/kpilot-parallel-make-fix.patch
+}
+
 src_compile() {
        use pda && myconf="$myconf --with-extra-includes=/usr/include/libpisock"
        kde_src_compile