Adding maxima-5.10.0.patch
authorJeffrey Gardner <je_fro@gentoo.org>
Tue, 31 Oct 2006 12:31:08 +0000 (12:31 +0000)
committerJeffrey Gardner <je_fro@gentoo.org>
Tue, 31 Oct 2006 12:31:08 +0000 (12:31 +0000)
Package-Manager: portage-2.1.1-r1

sci-mathematics/maxima/Manifest
sci-mathematics/maxima/files/maxima-5.10.0.patch [new file with mode: 0644]

index 88dbe05fe2fb4c1ed384bc3f158505c080113981..eec9cfd3987403389c490786ea4ab808f43e2e72 100644 (file)
@@ -2,6 +2,10 @@ AUX 50maxima-gentoo.el 625 RMD160 f82dced83cb2f6361ba15992bbaf982006bac9a5 SHA1
 MD5 b97aaf31b888a90139f3e81e504b63ce files/50maxima-gentoo.el 625
 RMD160 f82dced83cb2f6361ba15992bbaf982006bac9a5 files/50maxima-gentoo.el 625
 SHA256 f384d9bfe98f24b40acc32f6abbc6c4180865690f1cf80944ec6028f5cfaef5a files/50maxima-gentoo.el 625
+AUX maxima-5.10.0.patch 5406 RMD160 84d905721c86e15ce4b4614d602445f3aa0042aa SHA1 87d77347a4d9f97b151d265501cbafc85639149b SHA256 52a0d03919a016a6a5a6629f2e62b6a909a26e035be747344b7b0d1d5d17d47e
+MD5 c75e18ca4f173e29d973b445c152ab6f files/maxima-5.10.0.patch 5406
+RMD160 84d905721c86e15ce4b4614d602445f3aa0042aa files/maxima-5.10.0.patch 5406
+SHA256 52a0d03919a016a6a5a6629f2e62b6a909a26e035be747344b7b0d1d5d17d47e files/maxima-5.10.0.patch 5406
 AUX maxima-5.9.1-fix-clisp-getpid.patch 473 RMD160 60874eaf099746cecb10556b3e94d8fcf87d40cd SHA1 e1e1341c06711c1b78c2686ed3ea63bd9612da5d SHA256 255e8300e92cecb6781d3e9f8b6c022354a7db8cb2c3c3581a86395d9c6333ce
 MD5 801d6f51244585c2fa72877f708e9843 files/maxima-5.9.1-fix-clisp-getpid.patch 473
 RMD160 60874eaf099746cecb10556b3e94d8fcf87d40cd files/maxima-5.9.1-fix-clisp-getpid.patch 473
diff --git a/sci-mathematics/maxima/files/maxima-5.10.0.patch b/sci-mathematics/maxima/files/maxima-5.10.0.patch
new file mode 100644 (file)
index 0000000..7490637
--- /dev/null
@@ -0,0 +1,125 @@
+diff -r -U4 maxima-5.10.0.orig/interfaces/emacs/emaxima/maxima.el maxima-5.10.0/interfaces/emacs/emaxima/maxima.el
+--- maxima-5.10.0.orig/interfaces/emacs/emaxima/maxima.el      2005-06-22 05:48:42.000000000 +0200
++++ maxima-5.10.0/interfaces/emacs/emaxima/maxima.el   2006-09-21 20:04:48.000000000 +0200
+@@ -2704,9 +2704,9 @@
+               (process-mark inferior-maxima-process))))
+ (defun inferior-maxima-wait-for-output ()
+   "Wait for output from the Maxima process."
+-  (while (and 
++  (when (and 
+           inferior-maxima-waiting-for-output
+           (inferior-maxima-running))
+     (accept-process-output inferior-maxima-process))
+   (if maxima-running-xemacs
+@@ -2759,10 +2759,10 @@
+         (add-to-list 'comint-output-filter-functions
+                      'inferior-maxima-output-filter)
+ ;        (add-to-list 'comint-output-filter-functions
+ ;                     'inferior-maxima-replace-tabs-by-spaces)
+-        (add-to-list 'comint-output-filter-functions
+-                     'inferior-maxima-remove-double-input-prompt)
++;        (add-to-list 'comint-output-filter-functions
++;                     'inferior-maxima-remove-double-input-prompt)
+       (if maxima-fix-double-prompt
+             (add-to-list 'comint-output-filter-functions
+                          'inferior-maxima-remove-double-prompt))
+         (inferior-maxima-wait-for-output)
+diff -r -U4 maxima-5.10.0.orig/interfaces/emacs/misc/bookmode.el maxima-5.10.0/interfaces/emacs/misc/bookmode.el
+--- maxima-5.10.0.orig/interfaces/emacs/misc/bookmode.el       2000-05-08 08:09:44.000000000 +0200
++++ maxima-5.10.0/interfaces/emacs/misc/bookmode.el    2006-09-21 20:18:03.000000000 +0200
+@@ -679,9 +679,9 @@
+                           'book-set-postscript-value beg end (nth 1 tem)))
+               
+                 (and tem
+                      (list (concat "View "(nth 1 tem))
+-                           'call-process  "ghostview" nil nil nil
++                           'call-process  "gv" nil nil nil
+                            (expand-file-name(nth 1 tem))
+                            ))
+                 (list "Cancel")
+                 )))
+@@ -704,9 +704,9 @@
+                        ;; construct command to pass to the shell.
+                        (concat
+                         (cond ((looking-at "%PS") "")
+                               (t "gzip -dc | "))
+-                        "ghostview -")
++                        "gv -")
+                        
+       )))
+        
+ (defun book-set-postscript-value ( beg end &optional file)
+diff -r -U4 maxima-5.10.0.orig/interfaces/xmaxima/Tkmaxima/Constants.tcl maxima-5.10.0/interfaces/xmaxima/Tkmaxima/Constants.tcl
+--- maxima-5.10.0.orig/interfaces/xmaxima/Tkmaxima/Constants.tcl       2006-08-03 15:21:57.000000000 +0200
++++ maxima-5.10.0/interfaces/xmaxima/Tkmaxima/Constants.tcl    2006-09-21 20:20:32.000000000 +0200
+@@ -142,9 +142,9 @@
+     text/plain netmath
+     image/gif  netmath
+     image/png  netmath
+     image/jpeg netmath
+-    application/postscript "ghostview -safer %s"
++    application/postscript "gv -safer %s"
+     application/pdf "acroread %s"
+     application/x-dvi "xdvi %s"
+ }
+ set maxima_priv(imagecounter) 0
+diff -r -U4 maxima-5.10.0.orig/interfaces/xmaxima/Tkmaxima/Menu.tcl maxima-5.10.0/interfaces/xmaxima/Tkmaxima/Menu.tcl
+--- maxima-5.10.0.orig/interfaces/xmaxima/Tkmaxima/Menu.tcl    2006-09-11 17:38:01.000000000 +0200
++++ maxima-5.10.0/interfaces/xmaxima/Tkmaxima/Menu.tcl 2006-09-21 20:08:45.000000000 +0200
+@@ -214,11 +214,11 @@
+           lappend browse cmd.exe /c start
+       }
+     } else {
+       
+-      set selectedbrowser mozilla
++      set selectedbrowser firefox
+-      foreach b { mozilla konqueror epiphany firefox netscape } {
++      foreach b { firefox konqueror epiphany mozilla opera netscape } {
+           if { ! [catch {exec which $b} ] } {
+               set selectedbrowser $b
+               break } }
+diff -r -U4 maxima-5.10.0.orig/src/Makefile.am maxima-5.10.0/src/Makefile.am
+--- maxima-5.10.0.orig/src/Makefile.am 2006-09-05 01:52:42.000000000 +0200
++++ maxima-5.10.0/src/Makefile.am      2006-09-21 20:11:16.000000000 +0200
+@@ -150,9 +150,9 @@
+ endif
+ if SBCL
+-EXECUTESBCL = $(SBCL_NAME) --noinform --noprint --eval
++EXECUTESBCL = $(SBCL_NAME) --noinform --noprint --disable-debugger --eval
+ all-local: binary-sbcl/maxima.core
+ install-exec-local: install-sbcl
+ uninstall: uninstall-sbcl
+ clean: clean-sbcl
+diff -r -U4 maxima-5.10.0.orig/src/Makefile.in maxima-5.10.0/src/Makefile.in
+--- maxima-5.10.0.orig/src/Makefile.in 2006-09-21 06:00:57.000000000 +0200
++++ maxima-5.10.0/src/Makefile.in      2006-09-21 20:14:59.000000000 +0200
+@@ -203,9 +203,9 @@
+ @CLISP_TRUE@EXECUTECLISP = $(CLISP_NAME) -norc -q -x
+ @CMUCL_TRUE@EXECUTECMUCL = $(CMUCL_NAME) -noinit -batch
+ @SCL_TRUE@EXECUTESCL = $(SCL_NAME) -noinit -batch
+ @ACL_TRUE@EXECUTEACL = $(ACL_NAME) -batch
+-@SBCL_TRUE@EXECUTESBCL = $(SBCL_NAME) --noinform --noprint --eval
++@SBCL_TRUE@EXECUTESBCL = $(SBCL_NAME) --noinform --noprint --disable-debugger --eval
+ @GCL_TRUE@EXECUTEGCL = $(GCL_NAME) -batch -eval
+ @OPENMCL_TRUE@EXECUTEOPENMCL = $(OPENMCL_NAME) -e
+ genericdir = $(instsrcdir)
+ real_lisp_sources = acall.lisp \
+diff -r -U4 maxima-5.10.0.orig/src/plot.lisp maxima-5.10.0/src/plot.lisp
+--- maxima-5.10.0.orig/src/plot.lisp   2006-08-26 13:13:40.000000000 +0200
++++ maxima-5.10.0/src/plot.lisp        2006-09-21 20:19:02.000000000 +0200
+@@ -74,9 +74,9 @@
+                         ((mlist) $logy nil)
+                         ((mlist) $plot_realpart nil)
+                         ))
+-(defvar $viewps_command  "(ghostview \"~a\")")
++(defvar $viewps_command  "(gv \"~a\")")
+ ;; $plot_realpart option is false by default but *plot-realpart* is true because coerce-float-fun
+ ;; is used outside of plot package too.
+ (defvar *plot-realpart* t)