dev-perl/Fatal-Exception: EAPI6 / Test
authorKent Fredric <kentnl@gentoo.org>
Sat, 21 Oct 2017 06:36:51 +0000 (19:36 +1300)
committerKent Fredric <kentnl@gentoo.org>
Sat, 21 Oct 2017 08:37:59 +0000 (21:37 +1300)
- EAPI6
- Enable tests

Package-Manager: Portage-2.3.8, Repoman-2.3.3

dev-perl/Fatal-Exception/Fatal-Exception-0.50.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Fatal-Exception/Fatal-Exception-0.50.0-r2.ebuild b/dev-perl/Fatal-Exception/Fatal-Exception-0.50.0-r2.ebuild
new file mode 100644 (file)
index 0000000..8fb3915
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DEXTER
+DIST_VERSION=0.05
+inherit perl-module
+
+DESCRIPTION="Succeed or throw exception"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/Exception-Died
+       >=dev-perl/Exception-Base-0.22.01"
+DEPEND="${RDEPEND}
+       dev-perl/Module-Build
+       test? ( >=dev-perl/Test-Unit-Lite-0.12
+               dev-perl/Test-Assert
+               dev-perl/Exception-Warning )"