x11-plugins/wmblob: 1.0.4 bump
authorBernard Cafarelli <voyageur@gentoo.org>
Mon, 27 Nov 2017 12:26:23 +0000 (13:26 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Mon, 27 Nov 2017 12:28:52 +0000 (13:28 +0100)
Package-Manager: Portage-2.3.16, Repoman-2.3.6

x11-plugins/wmblob/Manifest
x11-plugins/wmblob/wmblob-1.0.4.ebuild [new file with mode: 0644]

index 7222601f0a98d23d3473d2f3d14ad624697149a2..cdc2ee8d0de681e54f5eace13c284e9601970335 100644 (file)
@@ -1 +1,2 @@
 DIST wmblob-1.0.3.tar.bz2 160657 BLAKE2B e36f7b8c6dd38466da490bd85d03ff2f378caced8d5908b00422428223aaa1fc3754bfd35dcacb2f162b0d44c8c04b509cf5c00d678d687e5b90cad886ce98a6 SHA512 4d8c7e30218d9ec7dc965c69e69b0fb5839c468f695ec2cc9fd9bb0b8fbc89b1386122e11b75906169bb16d13dae16cd8287c5bcf8bd28ccbbad4d4f057b3414
+DIST wmblob-1.0.4.tar.bz2 179284 BLAKE2B 79025a4d80c05bd8f9d1a962762680e24ae0eb09c8bf961833f4f4c59b086ecc8563ef71c28678c969da75f1f074c691c9fd6a6919358886e64f7fcb814611a3 SHA512 d325711e6c6c865a97386793a7c3f0e0833044001ccc336f2a4e9974799e5ff00936b0d90a0dc4a3280ba27a8d1f97239ba51d61e6e5b104e7cf82c8aeed5ec1
diff --git a/x11-plugins/wmblob/wmblob-1.0.4.ebuild b/x11-plugins/wmblob/wmblob-1.0.4.ebuild
new file mode 100644 (file)
index 0000000..a1a61a7
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools multilib
+
+DESCRIPTION="a fancy but useless dockapp with moving blobs"
+HOMEPAGE="https://github.com/bbidulock/wmblob"
+SRC_URI="https://github.com/bbidulock/wmblob/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+       x11-libs/libX11
+       x11-libs/libXpm
+       x11-libs/libXext"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       x11-libs/libXt"
+
+DOCS="AUTHORS ChangeLog NEWS README doc/how_it_works"
+
+src_prepare() {
+       default
+
+       sed -i \
+               -e "s:-O2:${CFLAGS}:g" \
+               -e "s:\$x_libraries:/usr/$(get_libdir):" \
+               configure.ac || die
+
+       eautoreconf
+}