app-arch/zopfli: Version bump
authorHanno Böck <hanno@gentoo.org>
Wed, 1 Jan 2020 08:21:03 +0000 (09:21 +0100)
committerHanno Böck <hanno@gentoo.org>
Wed, 1 Jan 2020 08:21:03 +0000 (09:21 +0100)
Use cmake build instead of plain Makefile, avoids needing to patch
the buggy makefile from upstream.
Raise EAPI to 7.

Signed-off-by: Hanno Böck <hanno@gentoo.org>
Package-Manager: Portage-2.3.84, Repoman-2.3.20

app-arch/zopfli/Manifest
app-arch/zopfli/zopfli-1.0.3.ebuild [new file with mode: 0644]

index e618e56d29dabf87fae631d15a932f96bc02d55e..4fa484c5845e44de37a191230ab4ac4911ab73ab 100644 (file)
@@ -1 +1,2 @@
 DIST zopfli-1.0.2.tar.gz 136035 BLAKE2B 23b9af324f50f2fa7276cdb8ac042e251f4e295617638c6e3999b8ecaef5d61d1fe21dd7b8d84e19f7f682f3a592674fcd6c19f359efb86ac4ea57acaac3761e SHA512 290a9506a0c1f3d0510230ca21017e1d2bed830f3f96f9d38c9f27210d89123c3baebd05a1da988eccd5395a7b007f6690f08eb9087550a06eaa69d7531f074e
+DIST zopfli-1.0.3.tar.gz 195227 BLAKE2B fed322e6d0baf8e9008e91fef4c459e8f67f0e7d62942469893d89b8ca39ace6d1ac68cbbc322e938e66a613ea9a36e3ae9f59550b5f4964107bec490a07038a SHA512 362cbeee0b3f04a4c5da512f82671491f874d4ec7b693dca9724ae42123d7ac184cc4d5de1872b4f1fc938c97f79dfdb482f62d1fca4a17cff6d267f6021e8d2
diff --git a/app-arch/zopfli/zopfli-1.0.3.ebuild b/app-arch/zopfli/zopfli-1.0.3.ebuild
new file mode 100644 (file)
index 0000000..12b52c0
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Very good, but slow, deflate or zlib compression"
+HOMEPAGE="https://github.com/google/zopfli/"
+SRC_URI="https://github.com/google/zopfli/archive/${P}.tar.gz"
+
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( CONTRIBUTORS README README.zopflipng )