net-dns/resolv_wrapper: EAPI-7 bump, use cmake.eclass
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 19 Mar 2020 13:20:47 +0000 (14:20 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 21 Mar 2020 14:10:21 +0000 (15:10 +0100)
Dropping unused USE test.

Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
net-dns/resolv_wrapper/resolv_wrapper-1.1.5.ebuild

index ba89b7e9fb90392d22e7842c128f4cfec17f8856..f936bc18a14318f405614d1bb752bc9b73be2680 100644 (file)
@@ -1,25 +1,22 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
+CMAKE_ECLASS=cmake
 inherit cmake-multilib
 
-DESCRIPTION="A wrapper for DNS name resolving or DNS faking"
+DESCRIPTION="Wrapper for DNS name resolving or DNS faking"
 HOMEPAGE="https://cwrap.org/resolv_wrapper.html"
 SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
 
 # Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
 # Because of this we cannot use cmake-multilib_src_configure() here.
 multilib_src_configure() {
        local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
-       cmake-utils_src_configure
+       cmake_src_configure
 }