games-misc/doge: add version 3.6.0
authorRobert Siebeck <gentoo.2019@r123.de>
Thu, 23 Apr 2020 22:05:15 +0000 (00:05 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 26 Apr 2020 13:36:47 +0000 (16:36 +0300)
Add support for Python 3.7 and 3.8

Closes: https://bugs.gentoo.org/718312
Signed-off-by: Robert Siebeck <gentoo.2019@r123.de>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
games-misc/doge/Manifest
games-misc/doge/doge-3.6.0.ebuild [new file with mode: 0644]
profiles/package.mask

index 77d8d1535e151a915ed2f8d10558421ee79865e4..2310b6e27a411bd3a8db58122aa5ee0969c7625b 100644 (file)
@@ -1 +1,2 @@
 DIST doge-3.5.0.tar.gz 16145 BLAKE2B dea9ca7009580a795644413eccc5b0a823b802655bb62464110f8060d35099e91a2b302b62fcfd93cfe0d547031800c9ba1f68aae2dd4933b20bfbb65869de12 SHA512 8e8f27077261626b27d0ce36c827b399345f2e96f157bfdf1b5437c75cf40b285533631ce5ec847b4b99bf87037faf85fb4aa4ab93604f54fbdfba03aa8e5609
+DIST doge-3.6.0.tar.gz 19530 BLAKE2B 016b5d90aa6c1a29ded035de2d17db4ff6470235969ade60d85c4b1d91baba14d635025308dbb072acd3a37da990a5713a281f70774226c5dca7fcad95e3d90d SHA512 6c03b32c03f2503476fdc979053a586bc62cc8f82eba4c4f4bf6d7fc4d37526b0d9fe4c0f5cd709ef983b7e3e3885e60f765bc4aafb58243ff24d92851d6a39f
diff --git a/games-misc/doge/doge-3.6.0.ebuild b/games-misc/doge/doge-3.6.0.ebuild
new file mode 100644 (file)
index 0000000..3662572
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="wow very terminal doge"
+HOMEPAGE="https://github.com/thiderman/doge https://pypi.org/project/doge/"
+SRC_URI="https://github.com/thiderman/doge/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+       sys-process/procps
+"
index 3077219f11f3341be67baaca6b7ec688f15a2ac3..96f5d7dacaffd514cbef6571452b0f0da2cb2a58 100644 (file)
@@ -353,11 +353,6 @@ media-sound/beets
 # Removal in 30 days.  Bug #718340.
 media-gfx/qrencode-python
 
-# Michał Górny <mgorny@gentoo.org> (2020-04-19)
-# Unmaintained.  Stuck on Python 3.6.  Last release in 2014.
-# Removal in 30 days.  Bug #718312.
-games-misc/doge
-
 # Michał Górny <mgorny@gentoo.org> (2020-04-19)
 # Unmaintained.  Stuck on Python 3.6.
 # Removal in 30 days.  Bug #718308.