net-ftp/proftpd: Fix test suite detection, bug #697782
authorSergei Trofimovich <slyfox@gentoo.org>
Tue, 15 Oct 2019 22:27:24 +0000 (23:27 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Tue, 15 Oct 2019 22:27:59 +0000 (23:27 +0100)
Reported-by: Toralf Förster
Closes: https://bugs.gentoo.org/697782
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
net-ftp/proftpd/files/proftpd-1.3.6a-fix-libcheck.patch [new file with mode: 0644]
net-ftp/proftpd/proftpd-1.3.6a.ebuild

diff --git a/net-ftp/proftpd/files/proftpd-1.3.6a-fix-libcheck.patch b/net-ftp/proftpd/files/proftpd-1.3.6a-fix-libcheck.patch
new file mode 100644 (file)
index 0000000..93752c4
--- /dev/null
@@ -0,0 +1,28 @@
+Fix test suite detection.
+
+https://github.com/proftpd/proftpd/pull/839
+
+Reported-by: Toralf Förster
+Bug: https://bugs.gentoo.org/697782
+--- a/configure.in
++++ b/configure.in
+@@ -991,7 +991,7 @@ AC_ARG_ENABLE(tests,
+     [enable unit tests (default=no)])
+   ],
+   [
+-    if test "$enableval" != xno ; then
++    if test x"$enableval" != xno ; then
+       AC_CHECK_HEADERS(check.h)
+       AC_CHECK_LIB(check, tcase_create,
+--- a/configure
++++ b/configure
+@@ -20639,7 +20639,7 @@ ENABLE_TESTS="\"\""
+ # Check whether --enable-tests was given.
+ if test "${enable_tests+set}" = set; then
+   enableval=$enable_tests;
+-    if test "$enableval" != xno ; then
++    if test x"$enableval" != xno ; then
+ for ac_header in check.h
+ do
index cc22d06099aff92ee242ee24abf84a177e9c4cbb..adb025d7e1fdde82220a8dd9d9249865ccb5d00c 100644 (file)
@@ -71,6 +71,7 @@ S="${WORKDIR}/${P/_/}"
 PATCHES=(
        "${FILESDIR}"/${PN}-1.3.6-use-trace.patch
        "${FILESDIR}"/${PN}-1.3.6-mysql-8.patch
+       "${FILESDIR}"/${PN}-1.3.6a-fix-libcheck.patch
 )
 
 RESTRICT=test # tests corrupt memory. need to be fixed upstream first