dev-python/python-troveclient: 2.17.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 12 Apr 2019 21:44:27 +0000 (16:44 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 12 Apr 2019 22:47:08 +0000 (17:47 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/python-troveclient/Manifest
dev-python/python-troveclient/python-troveclient-2.17.0.ebuild [new file with mode: 0644]

index fd03176477bb03ea4e0aa14cb488ea219e51ebb9..5f7d54deb09125f7d9c573cfcc571790d8f97766 100644 (file)
@@ -1,2 +1,3 @@
 DIST python-troveclient-1.3.0.tar.gz 130542 BLAKE2B 335358dd589ce2feeb03f2fe7da5185bc203c9f0823bb3695feeefa9d05dc4aafdfc6f582d87f05b4ac31c6c0028a3620fa2efe12ef22b36871eb6f0ad93b660 SHA512 aa26b587d8e2bd15bb65ff760b89354638f6a77a4e73ec5f37ab6dc3c374d6b8c238391c09347e7fc897138fc0bdc375f69ab479f57e14f21d0882b74cc7c978
+DIST python-troveclient-2.17.0.tar.gz 189560 BLAKE2B 680d76af88b8242956eb8e7a8644c11b47fee785eb0940bca1d3b8c5c500c3c233ac0e452d7a609d10028571e68ad52d47d3834898e98642cbb93b0b17f0db40 SHA512 b314115d2c50c87658b02f5dfe9a22f68cb31ba89c3baedf45bf87c4f482aeb235c751753da538bb38c514600b374b1d3f43e17d4a8b929738b4c742e28c63d8
 DIST python-troveclient-2.5.0.tar.gz 149926 BLAKE2B 11acb39afed5ed018a83861fa344e1d482bfa179e0bce97e517e392daf982d868b0c24aeae2406732ddb39e71ab977832df76b55354975d671ee17421cca72cd SHA512 83e7cafec8ce4d65a55d8854bc2e2fbc657d567e4dc2b42a64c527c656ba5f253839511582c5ca2dda970bebb4555390b895a882b87a2eacb86ccbfac9c09a97
diff --git a/dev-python/python-troveclient/python-troveclient-2.17.0.ebuild b/dev-python/python-troveclient/python-troveclient-2.17.0.ebuild
new file mode 100644 (file)
index 0000000..cc854cc
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Trove API, a scalable relational database service"
+HOMEPAGE="https://github.com/openstack/python-troveclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+       test? (
+               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+               !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+               >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+               >=dev-python/python-openstackclient-3.12.0[${PYTHON_USEDEP}]
+               >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+               >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+               >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+               >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+               >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+       )"
+RDEPEND="
+       >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+       <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+       >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+       >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/python-swiftclient-3.2.0[${PYTHON_USEDEP}]
+       >=dev-python/python-mistralclient-3.1.0[${PYTHON_USEDEP}]
+       !~dev-python/python-mistralclient-3.2.0[${PYTHON_USEDEP}]
+       >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       testr init
+       testr run --parallel || die "testsuite failed under python2.7"
+}