net-misc/apt-cacher-ng: Version 3.4_p1
authorJeroen Roovers <jer@gentoo.org>
Thu, 9 Apr 2020 07:58:43 +0000 (09:58 +0200)
committerJeroen Roovers <jer@gentoo.org>
Thu, 9 Apr 2020 07:58:54 +0000 (09:58 +0200)
Package-Manager: Portage-2.3.97, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-misc/apt-cacher-ng/Manifest
net-misc/apt-cacher-ng/apt-cacher-ng-3.4_p1.ebuild [new file with mode: 0644]

index c04034341dfca997ff4df4ee54cdedf86b5b97b7..6921cc917295f3f0ef8b002a1a3ef5c151825f19 100644 (file)
@@ -3,3 +3,5 @@ DIST apt-cacher-ng_3.3.1-1.debian.tar.xz 50912 BLAKE2B a873c4e718765a7161d9f87b6
 DIST apt-cacher-ng_3.3.1-2.debian.tar.xz 49772 BLAKE2B b864859e7f0ad5eba24b2f1ced74dbdb7a1878fbc2190863929f45534163c18ed2a67c4c75b5fe8011d93312ab9a67d899b09669e7aacb1ad3ae15a2bc1fba12 SHA512 653ca59c1d9c89a9586ccf963da480524ff8195222435e4a89f0c08ca64586e1993a92d00a05dbf738b0814869a5e6b539a05d1d59cb956e66b2dbe5ad95eeb8
 DIST apt-cacher-ng_3.3.1.orig.tar.xz 321996 BLAKE2B b630a31414ee86256f2e2ebe950b56d182d61dffd1603ce8387b5cd677d18fcda3ed17864bb99c253b11e2d29163b172c2d0bc91a3f5b14fb9f0ef321d656b40 SHA512 0d412e4a488fa4c55f1292c1fc7346bdf88228528455ce1d2ad20137ddb84df211a3bc5911c12662428335d8f624979d166b0ed31f74e466228df3ab108e67f3
 DIST apt-cacher-ng_3.3.orig.tar.xz 320884 BLAKE2B c4bda8de90f76e7cb8335fdb758571db030c1298881afceb865f84e506aeb82e4db69c5c091debfdcf6c85bc8d4e703b75725ae6b06f2e412ba4b4362d568a05 SHA512 01a09bc13d2a9d24ee3012a21ae954362715bc0b69ef021a3446ad7d78157209aaaf941fbb02b0e5323bfb0337a1e3d6450c07b680d42f7bf93855d7ac65c60f
+DIST apt-cacher-ng_3.4-1.debian.tar.xz 49880 BLAKE2B a49dc9ca415cd00f275f8aab61836ef002b9463a8ce22b2fbf1379ce908737d0df813e9d112e64667790e0c9c29ae44ca12291ff531fa565a30b0345c3970824 SHA512 49879c8786ba5aa6398ce43d733a71529a5c2a93a0e8e3e856bb7bf6d6dd0d8dcf9f6a96b291a3e77e0a71a9a990b5d0ade9134e5ec670a33592c9a1ab61a48e
+DIST apt-cacher-ng_3.4.orig.tar.xz 324040 BLAKE2B 0164ac35815fb42a2197830134172c4b93677f6ee6add71d115e975a3b8538db18e635fae2fe9556346229dc076c732b3b3f6fb9958e347fee8876f0f2363c9e SHA512 956366431f4671afd46f3bc0cdb9acaf02378606a7e210a190902e519ed25d2d102a336032c31fcc8b71c879bd219f249f411af732bfb6f9213e485ba6981c5d
diff --git a/net-misc/apt-cacher-ng/apt-cacher-ng-3.4_p1.ebuild b/net-misc/apt-cacher-ng/apt-cacher-ng-3.4_p1.ebuild
new file mode 100644 (file)
index 0000000..0b5dc00
--- /dev/null
@@ -0,0 +1,137 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-utils toolchain-funcs user
+
+DESCRIPTION="Yet another caching HTTP proxy for Debian/Ubuntu software packages"
+HOMEPAGE="
+       https://www.unix-ag.uni-kl.de/~bloch/acng/
+       https://packages.qa.debian.org/a/apt-cacher-ng.html
+"
+LICENSE="BSD-4 ZLIB public-domain"
+SLOT="0"
+SRC_URI="
+       mirror://debian/pool/main/a/${PN}/${PN}_${PV/_*}.orig.tar.xz
+       mirror://debian/pool/main/a/${PN}/${PN}_${PV/_p/-}.debian.tar.xz
+"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fuse systemd tcpd"
+
+COMMON_DEPEND="
+       app-arch/bzip2
+       app-arch/xz-utils
+       dev-libs/openssl:0=
+       sys-libs/zlib
+       systemd? (
+               sys-apps/systemd
+       )
+"
+BDEPEND="
+       ${COMMON_DEPEND}
+       dev-util/cmake
+       >sys-devel/gcc-4.8
+       virtual/pkgconfig
+"
+RDEPEND="
+       ${COMMON_DEPEND}
+       dev-lang/perl
+       fuse? ( sys-fs/fuse )
+       tcpd? ( sys-apps/tcp-wrappers )
+"
+PATCHES=(
+       "${FILESDIR}"/${PN}-3.3.1-flags.patch
+       "${WORKDIR}"/debian/patches/debian-changes
+)
+S=${WORKDIR}/${P/_*}
+
+pkg_pretend() {
+       if [[ $(gcc-major-version) -lt 4 ]]; then
+               die "GCC 4.8 or greater is required but you have $(gcc-major-version).$(gcc-minor-version)"
+       elif [[ $(gcc-major-version) = 4 ]] && [[ $(gcc-minor-version) -lt 8 ]]; then
+               die "GCC 4.8 or greater is required but you have $(gcc-major-version).$(gcc-minor-version)"
+       fi
+}
+
+pkg_setup() {
+       # add new user & group for daemon
+       enewgroup ${PN}
+       enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_configure() {
+       local mycmakeargs=()
+       if use fuse; then
+               mycmakeargs+=( "-DHAVE_FUSE_25=yes" )
+       else
+               mycmakeargs+=( "-DHAVE_FUSE_25=no" )
+       fi
+       if use tcpd; then
+               mycmakeargs+=( "-DHAVE_LIBWRAP=yes" )
+       else
+               mycmakeargs+=( "-DHAVE_LIBWRAP=no" )
+       fi
+       if tc-ld-is-gold; then
+               mycmakeargs+=( "-DUSE_GOLD=yes" )
+       else
+               mycmakeargs+=( "-DUSE_GOLD=no" )
+       fi
+
+       cmake-utils_src_configure
+
+       sed -i -e '/LogDir/s|/var/tmp|/var/log/'"${PN}"'|g' "${BUILD_DIR}"/conf/acng.conf || die
+}
+
+src_install() {
+       pushd "${BUILD_DIR}" || die
+       dosbin ${PN} acngtool
+       dolib.so libsupacng.so
+       if use fuse; then
+               dobin acngfs
+       fi
+       popd || die
+
+       newinitd "${FILESDIR}"/initd-r2 ${PN}
+       newconfd "${FILESDIR}"/confd-r1 ${PN}
+
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}"/logrotate ${PN}
+
+       doman doc/man/${PN}*
+       if use fuse; then
+               doman doc/man/acngfs*
+       fi
+
+       # Documentation
+       dodoc doc/README TODO VERSION INSTALL ChangeLog
+       if use doc; then
+               dodoc doc/*.pdf
+
+               docinto html
+               dodoc doc/html/*
+
+               find conf -name '*.gz' -exec gzip -d {} \; || die
+               docinto examples/conf
+               dodoc conf/*
+       fi
+
+       newdoc "${WORKDIR}"/debian/changelog debian.changelog
+
+       # perl daily cron script
+       dosbin scripts/expire-caller.pl
+       exeinto /etc/cron.daily
+       newexe "${FILESDIR}"/cron.daily ${PN}
+
+       # default configuration
+       insinto /etc/${PN}
+       newins "${BUILD_DIR}"/conf/acng.conf ${PN}.conf
+       doins $( echo conf/* | sed 's|conf/acng.conf.in||g' )
+
+       keepdir /var/log/${PN}
+       # Some directories must exists
+       keepdir /var/log/${PN}
+       fowners -R ${PN}:${PN} \
+               /etc/${PN} \
+               /var/log/${PN}
+}