dev-python/storm: Use append-cflags
authorJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:53:11 +0000 (18:53 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:53:47 +0000 (18:53 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/storm/storm-0.20-r1.ebuild

index 68da3aa854faca5b7d22375a59bccbc25fc3c084..684949424f6ce9ed9eea2d94e885240b042ee610 100644 (file)
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python2_7 )
 DISTUTILS_SINGLE_IMPL=1
 PYTHON_REQ_USE="sqlite?"
 
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
 
 DESCRIPTION="An object-relational mapper for Python developed at Canonical"
 HOMEPAGE="https://storm.canonical.com/ https://pypi.python.org/pypi/storm"
@@ -24,11 +24,10 @@ RDEPEND="mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/fixtures[${PYTHON_USEDEP}] )"
 
-CFLAGS="${CFLAGS} -fno-strict-aliasing"
-
 DOCS="tests/tutorial.txt"
 
 pkg_setup() {
+       append-cflags -fno-strict-aliasing
        python-single-r1_pkg_setup
 }