dev-python/gnome-python-base: Revert "Remove last-rited pkg"
authorMichał Górny <mgorny@gentoo.org>
Sun, 19 Apr 2020 09:03:05 +0000 (11:03 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 19 Apr 2020 09:04:42 +0000 (11:04 +0200)
It was supposed to be gnome-python-desktop-base.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/gnome-python-base/Manifest [new file with mode: 0644]
dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild [new file with mode: 0644]
dev-python/gnome-python-base/metadata.xml [new file with mode: 0644]
profiles/package.deprecated
profiles/package.mask

diff --git a/dev-python/gnome-python-base/Manifest b/dev-python/gnome-python-base/Manifest
new file mode 100644 (file)
index 0000000..31f334b
--- /dev/null
@@ -0,0 +1 @@
+DIST gnome-python-2.28.1.tar.bz2 562220 BLAKE2B 9bd14132974b6d42183debfc8f492fcee168a1671dfd27eead7aaa8d5ca12108bcda239b30df87bf41de3a0ab68191f095d63fdad05c151f6204f34f3bf14bdf SHA512 632d91d416f8209c2bc8d576d1229069e00f2cfeedb3441a5f151e12973ed740c0bb26d18d5c16cfeeb64ca35933537997277450001cffd96d8d5077027d45f2
diff --git a/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild b/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
new file mode 100644 (file)
index 0000000..dc93502
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit versionator eutils gnome2 python-r1
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+
+MY_PN="gnome-python"
+DESCRIPTION="Provides the base files for the gnome-python bindings"
+HOMEPAGE="http://pygtk.org/"
+PVP="$(get_version_component_range 1-2)"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+LICENSE="LGPL-2.1"
+SLOT="2"
+RESTRICT="${RESTRICT} test"
+
+# From the gnome-python eclass
+RDEPEND=">=x11-libs/gtk+-2.6:2
+       >=dev-libs/glib-2.6:2
+       ${PYTHON_DEPS}
+       >=dev-python/pygtk-2.14.0:2[${PYTHON_USEDEP}]
+       >=dev-python/pygobject-2.17:2[${PYTHON_USEDEP}]
+       !<dev-python/gnome-python-2.22.1"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+KEYWORDS="~alpha amd64 arm ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+       python_setup
+}
+
+src_configure() {
+       gnome2_src_configure \
+               --disable-allbindings
+}
diff --git a/dev-python/gnome-python-base/metadata.xml b/dev-python/gnome-python-base/metadata.xml
new file mode 100644 (file)
index 0000000..e4e250d
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>python@gentoo.org</email>
+       <name>Python</name>
+</maintainer>
+<maintainer type="project">
+       <email>gnome@gentoo.org</email>
+       <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>
index 588986e296ef12ba695aef91bd192fb78a10a775..499da317742f67f7b081f33272f083be0278c86a 100644 (file)
@@ -40,6 +40,7 @@ dev-python/pytest-runner
 # Deprecated GNOME 2 era packages
 # Bugs #640022, #713010
 dev-python/gconf-python
+dev-python/gnome-python-base
 dev-python/pygobject:2
 dev-python/pygtksourceview
 gnome-base/gnome-vfs
index f72868ee6f1cc3f80d683aeb052d71259b58fbd4..a805abc02f82da8283c81eb57e230a011adf1a61 100644 (file)
@@ -510,6 +510,12 @@ media-sound/galan
 # No reverse deps. GNOME 2 era slot. Removal in 30 days
 gnome-base/gnome-desktop:2
 
+# Michał Górny <mgorny@gentoo.org> (2020-03-20)
+# Deprecated GNOME libraries, replaced by introspection.  Python 2 only.
+# No reverse dependencies.
+# Removal in 30 days.  Bug #713566.
+dev-python/gnome-python-desktop-base
+
 # Andreas Sturmlechner <asturm@gentoo.org> (2020-03-14)
 # Breaks at least dev-games/simgear right now, bug #709878.
 ~dev-games/openscenegraph-3.6.5