sci-libs/galib: remove 2.4.6/2.4.7
authorMichael Palimaka <kensington@gentoo.org>
Sat, 30 Sep 2017 05:10:13 +0000 (15:10 +1000)
committerMichael Palimaka <kensington@gentoo.org>
Sat, 30 Sep 2017 05:11:24 +0000 (15:11 +1000)
Package-Manager: Portage-2.3.8, Repoman-2.3.3

sci-libs/galib/Manifest
sci-libs/galib/files/galib-2.4.6-gcc4-gentoo.patch [deleted file]
sci-libs/galib/files/galib-2.4.6-makefile.patch [deleted file]
sci-libs/galib/galib-2.4.6.ebuild [deleted file]
sci-libs/galib/galib-2.4.7.ebuild [deleted file]

index af2e1d51d8063c13c5b2ce8b483001103969f056..83c5cf4fbcc9d482dfad3ce81645e05b83d29cb1 100644 (file)
@@ -1,2 +1 @@
-DIST galib246.tgz 378431 SHA256 441150c728d401a93ed6d9e745eae85f9ddbd413cfe06396f1a426cd31c7cc00 SHA512 3c2451c9124cfe7b4b11f67f0aa7f9cbd9819b6e50c3a48478c3f429c8d8a66a57c92a0dd3a720e68d81a6f80c86ef34c27303c3b3292ee28842c74e74f8289d WHIRLPOOL adff31eebb01dd5f94229743dc6623d82efca260911d7d91cfcfac9c59f831625d95d33301f85044ccd41ac487c1d3d2fb9fe0c95eca620a42aabc60ddf40dc3
 DIST galib247.tgz 374912 SHA256 ea76b66ce4db4db2ed86e20d6d3ff144abaf73e33620104246639d9b2a465329 SHA512 9c2aca29f24d3f8401ba65c246a0ca7d1fa67e4f756a5258cdb0da111842ea2903c2d70cfd9d60823c9703bcb3415ca670a731924e99878d5536c2f7eb0faba4 WHIRLPOOL 027e1d8999bb09e31da717fb3fb84f023d4488cc161c173e55fdc545b58583f386b6bb9cab631c30f84eae8a8b58c4e669049507bc0ca8561a8ecfba2e57f480
diff --git a/sci-libs/galib/files/galib-2.4.6-gcc4-gentoo.patch b/sci-libs/galib/files/galib-2.4.6-gcc4-gentoo.patch
deleted file mode 100644 (file)
index ed26216..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -Naur galib246/ga/gaconfig.h galib246-new/ga/gaconfig.h
---- galib246/ga/gaconfig.h     2005-01-31 10:46:09.000000000 -0500
-+++ galib246-new/ga/gaconfig.h 2006-09-26 19:38:09.000000000 -0400
-@@ -192,7 +192,9 @@
- // determine the compiler
- #if defined(__GNUG__) || defined(__GNUC__)
--#if __GNUC__ == 3
-+#if __GNUC__ == 4
-+#define GALIB_COMPILER "gcc4"
-+#elif __GNUC__ == 3
- #define GALIB_COMPILER "gcc3"
- #elif __GNUC__ == 2
- #define GALIB_COMPILER "gcc2"
-@@ -365,7 +367,7 @@
- #define GALIB_USE_PID
- #define GALIB_USE_EMPTY_TEMPLATES
- #define GALIB_NEED_INSTANTIATION_PREFIX
--#if __GNUC__ == 3
-+#if __GNUC__ >= 3
- #define GALIB_USE_ANSI_HEADERS
- #define GALIB_USE_STD_NAMESPACE
- #define GALIB_USE_COMP_OPERATOR_TEMPLATES
diff --git a/sci-libs/galib/files/galib-2.4.6-makefile.patch b/sci-libs/galib/files/galib-2.4.6-makefile.patch
deleted file mode 100644 (file)
index a2ced02..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- galib246/ga/makefile.sources       2000-02-03 14:00:46.000000000 -0600
-+++ galib246-new/ga/makefile.sources   2006-04-30 09:30:13.000000000 -0500
-@@ -8,7 +8,8 @@
-  GA1DBinStrGenome.h GA2DBinStrGenome.h GA3DBinStrGenome.h GABin2DecGenome.h \
-  GA1DArrayGenome.h GA2DArrayGenome.h GA3DArrayGenome.h \
-  GAStringGenome.h GARealGenome.h \
-- GATreeBASE.h GATree.h GATreeGenome.h GAListBASE.h GAList.h GAListGenome.h 
-+ GATreeBASE.h GATree.h GATreeGenome.h GAListBASE.h GAList.h GAListGenome.h \
-+ std_stream.h
- SRCS= garandom.C gaerror.C GAParameter.C GAStatistics.C \
-  GABaseGA.C GASStateGA.C GASimpleGA.C GAIncGA.C GADemeGA.C GADCrowdingGA.C \
-  GASelector.C GAScaling.C GAPopulation.C GAGenome.C \
diff --git a/sci-libs/galib/galib-2.4.6.ebuild b/sci-libs/galib/galib-2.4.6.ebuild
deleted file mode 100644 (file)
index d0612ad..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-inherit eutils
-
-MYPV="${PV//\./}"
-
-DESCRIPTION="Library for genetic algorithms in C++ programs"
-HOMEPAGE="http://lancet.mit.edu/ga/"
-SRC_URI="http://lancet.mit.edu/ga/dist/galib${MYPV}.tgz"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 x86"
-IUSE=""
-
-S="${WORKDIR}/galib${MYPV}"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       epatch \
-               "${FILESDIR}"/${P}-makefile.patch \
-               "${FILESDIR}"/${P}-gcc4-gentoo.patch
-}
-
-src_compile() {
-       emake CXXFLAGS="${CXXFLAGS}" || die "make failed"
-}
-
-src_install() {
-       dodir /usr/lib /usr/include
-       emake LIB_DEST_DIR="${D}"/usr/lib/ HDR_DEST_DIR="${D}"/usr/include/ install || die
-       dohtml -r doc/*
-       dodoc RELEASE-NOTES README
-       cp -r examples "${D}"/usr/share/doc/${PF}/
-}
diff --git a/sci-libs/galib/galib-2.4.7.ebuild b/sci-libs/galib/galib-2.4.7.ebuild
deleted file mode 100644 (file)
index eaca1b7..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit multilib
-
-MYPV="${PV//\./}"
-
-DESCRIPTION="Library for genetic algorithms in C++ programs"
-HOMEPAGE="http://lancet.mit.edu/ga/"
-SRC_URI="http://lancet.mit.edu/ga/dist/galib${MYPV}.tgz"
-
-LICENSE="BSD examples? ( GPL-2 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-S="${WORKDIR}/galib${MYPV}"
-
-src_prepare() {
-       sed -i \
-               -e 's:/include:${EPREFIX}/usr/include:' \
-               -e "s:/lib:${EPREFIX}/usr/$(get_libdir):" \
-               -e '/^CXX/d' \
-               -e '/^CXXFLAGS/d' \
-               -e '/^LD/d' \
-               makevars || die "sed makevars failed"
-}
-
-src_compile() {
-       emake lib
-}
-
-src_install() {
-       dodir /usr/$(get_libdir)
-       default
-
-       if use doc; then
-               insinto /usr/share/doc/${PF}
-               doins -r doc/*
-       fi
-
-       if use examples; then
-               insinto /usr/share/doc/${PF}/examples
-               cd examples
-               make clean
-               sed -i \
-                       -e '/^include/d' \
-                       -e '/^INC_DIRS/d' \
-                       -e '/^LIB_DIRS/d' \
-                       makefile || die "sed makefile failed"
-               doins -r *
-       fi
-}