dev-python/oslo-service: bup for mitaka
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 25 Mar 2016 04:13:13 +0000 (23:13 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 25 Mar 2016 04:13:13 +0000 (23:13 -0500)
Package-Manager: portage-2.2.26

dev-python/oslo-service/Manifest
dev-python/oslo-service/oslo-service-1.7.0.ebuild [new file with mode: 0644]

index 5889a761b2b0b52332712328bffe4091675a648e..70ecf583f4981e3d4cb7104e8f9488d54883477a 100644 (file)
@@ -1 +1,2 @@
 DIST oslo.service-0.9.0.tar.gz 57558 SHA256 f77753910391a1b2bd7fd9b5b863d7230b1ff727443dd2efcb725ce937ffb566 SHA512 6e17d1e28682732c8866e43f509a7fd7f69d2718493de3dab939600207e56fd0622036ff62928b9855b6219729e1173e62e1a1c949959a5d2d58eeeded97a1e2 WHIRLPOOL be645ac0d461056d5df4d17bbfe6f3819d6eba4fd2764459d287badf056d5c962e2c690b64fceba72160094ca1d29ff5f6c7708fef90bd192faa8ba532a4d4bb
+DIST oslo.service-1.7.0.tar.gz 66128 SHA256 a3f67202ceaaf9b0a58c375bbaa7297d3fa80377bce98e4f6b1c650b578a1d85 SHA512 07493573c6405a134eede66cb6a7e55557ef59bb656f9c0e9eb66fb706ee9dacd25d8518b0a5467e67eeb0e013507a6c3964c651e648d599973863ded70b3597 WHIRLPOOL cfbaa65f8a7c47c0aa939f29bdca5a2d4d2918041d5b4aca3545c7a48b317adc01c16115d30346336386aa14f12b2929493ff0309114d7cf2be9fd9bdf700b48
diff --git a/dev-python/oslo-service/oslo-service-1.7.0.ebuild b/dev-python/oslo-service/oslo-service-1.7.0.ebuild
new file mode 100644 (file)
index 0000000..14f031e
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for running OpenStack services"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.service"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.service/oslo.service-${PV}.tar.gz"
+S="${WORKDIR}/oslo.service-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND="
+       >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
+       <dev-python/pbr-2.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+       test? (
+               >=dev-python/fixtures-1.3.0[${PYTHON_USEDEP}]
+               >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+               >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+               >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+               !~dev-python/oslo-sphinx-3.4.0[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+               !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+               <dev-python/sphinx-1.3.0[${PYTHON_USEDEP}]
+               >=dev-python/bandit-0.17.3[${PYTHON_USEDEP}]
+       )"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+       >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+       >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+       >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
+       >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-3.5.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-concurrency-3.5.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-config-3.4.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+       >=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
+       >=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
+       !~dev-python/routes-2.0[${PYTHON_USEDEP}]
+       !~dev-python/routes-2.1[$(python_gen_usedep 'python2_7')]
+       dev-python/paste[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       nosetests tests/ || die "test failed under ${EPYTHON}"
+}