dev-python/subvertpy: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 09:25:38 +0000 (11:25 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 09:49:59 +0000 (11:49 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/subvertpy/Manifest
dev-python/subvertpy/subvertpy-0.9.1.ebuild [deleted file]

index 946d0a8c0ae304a380214e0c17e8d598433aa37f..7e2ba249948454dd6d76ae316da64390bd5c2857 100644 (file)
@@ -1,2 +1 @@
 DIST subvertpy-0.10.1.tar.gz 116661 BLAKE2B 81fdc21352f168c1a8d31398be21ad83ed72adc824dbbca7764fb1836cba4a7d7f03e4a96636ab29f4804682658ce834eea3fd433b5f161e61a702dfc6790e22 SHA512 083174ca6516541c48474673e6d601ff3098f19d204f311101f4de81bcd70d73bdb1e73dffe43fc584f35d286020cab1381dc1c44b514442735a139d2a9cd356
-DIST subvertpy-0.9.1.tar.gz 110972 BLAKE2B 1f11b55b81705b6b144e0c4ac53f2e0e5a847b96bb43589894c8c910492b443d61bfc5bdcbdba1e2bb757fbd587b029d0be113084a45c17aec8c0befdff0e12a SHA512 977e291c011e680cff9e26312b4235c0479374076964c7c4a4c3c7ec75bcc44ff7c458513ab89f1aa2b599d3bd8f94cbc6d1000afcf725a9f937a90b39456148
diff --git a/dev-python/subvertpy/subvertpy-0.9.1.ebuild b/dev-python/subvertpy/subvertpy-0.9.1.ebuild
deleted file mode 100644 (file)
index 9802235..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Alternative Python bindings for Subversion"
-HOMEPAGE="https://www.samba.org/~jelmer/subvertpy/ https://pypi.org/project/subvertpy/"
-SRC_URI="https://www.samba.org/~jelmer/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 LGPL-3 )"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-vcs/subversion-1.4"
-DEPEND="${RDEPEND}
-       test? ( || (
-               dev-python/testtools
-       ) )"
-
-DOCS=( NEWS AUTHORS )
-S=${WORKDIR}
-
-python_compile() {
-       python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
-       distutils-r1_python_compile
-}
-
-python_test() {
-       distutils_install_for_testing
-       pushd man > /dev/null
-       # hack: the subvertpy in . has no compiled modules, so cd into any
-       # directory to give the installed version precedence on PYTHONPATH
-       ${PYTHON} -m unittest subvertpy.tests.test_suite
-       popd man > /dev/null
-}