revision bump, snapshots removed
authorKathryn Kulick <gothgirl@gentoo.org>
Mon, 9 Oct 2006 02:02:32 +0000 (02:02 +0000)
committerKathryn Kulick <gothgirl@gentoo.org>
Mon, 9 Oct 2006 02:02:32 +0000 (02:02 +0000)
Package-Manager: portage-2.1.2_pre2-r5

x11-wm/openbox/ChangeLog
x11-wm/openbox/files/digest-openbox-3.3.1 [new file with mode: 0644]
x11-wm/openbox/openbox-3.3.1.ebuild [new file with mode: 0644]

index 67ea720c43faf0f6c2eeb85a2ab405b46d78c4e0..5c7c5b67efc924cdfce13911de89efc1dfa8c815 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for x11-wm/openbox
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.111 2006/07/15 10:35:05 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.112 2006/10/09 02:02:32 gothgirl Exp $
+
+*openbox-3.3.1 (09 Oct 2006)
+
+  09 Oct 2006; gothgirl <gothgirl@gentoo.org> +openbox-3.3.1.ebuild,
+  -openbox-20060509.ebuild, -openbox-20060509-r1.ebuild,
+  -openbox-20060509-r2.ebuild:
+  added revision 3.3.1 removed stale versions of snapshot
 
   15 Jul 2006; Bryan Ã˜stergaard <kloeri@gentoo.org> metadata.xml:
   Remove anarchy from metadata.xml as he's retired.
diff --git a/x11-wm/openbox/files/digest-openbox-3.3.1 b/x11-wm/openbox/files/digest-openbox-3.3.1
new file mode 100644 (file)
index 0000000..054f33b
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 6dc25d5fbff5d6277593b89974f950d8 openbox-3.3.1.tar.gz 603402
+RMD160 b796d807c17661cff506b641f121056aa146c8d9 openbox-3.3.1.tar.gz 603402
+SHA256 a70b7bc8c28427dff350aa17882d6916b678fd12d1119e4c3ad4b86f3371f033 openbox-3.3.1.tar.gz 603402
diff --git a/x11-wm/openbox/openbox-3.3.1.ebuild b/x11-wm/openbox/openbox-3.3.1.ebuild
new file mode 100644 (file)
index 0000000..ae0bf64
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.3.1.ebuild,v 1.1 2006/10/09 02:02:32 gothgirl Exp $
+
+inherit eutils
+
+DESCRIPTION="A standards compliant, fast, light-weight, extensible window manager."
+HOMEPAGE="http://icculus.org/openbox/"
+SRC_URI="http://icculus.org/openbox/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="nls pango startup-notification xinerama"
+
+RDEPEND=">=dev-libs/glib-2
+       >=dev-libs/libxml2-2.0
+       >=media-libs/fontconfig-2
+       virtual/xft
+       x11-libs/libXrandr
+       x11-libs/libXt
+       pango? ( x11-libs/pango )
+       startup-notification? ( x11-libs/startup-notification )
+       xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig
+       x11-proto/xextproto
+       x11-proto/xf86vidmodeproto
+       xinerama? ( x11-proto/xineramaproto )"
+
+src_compile() {
+       econf \
+               $(use_enable nls) \
+               $(use_enable pango) \
+               $(use_enable startup-notification) \
+               || die "econf failed"
+       emake || die "emake failed"
+}
+
+src_install() {
+       dodir /etc/X11/Sessions
+       echo "/usr/bin/openbox" > "${D}/etc/X11/Sessions/openbox"
+       fperms a+x /etc/X11/Sessions/openbox
+
+       insinto /usr/share/xsessions
+       doins "${FILESDIR}/${PN}.desktop"
+
+       emake DESTDIR="${D}" install || die "emake install failed"
+       dodoc ABOUT-NLS AUTHORS CHANGELOG COMPLIANCE README
+}