dev-python/sphinx: Reenable pypy3
authorMichał Górny <mgorny@gentoo.org>
Mon, 6 Apr 2020 19:56:47 +0000 (21:56 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 6 Apr 2020 19:57:21 +0000 (21:57 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinx/sphinx-3.0.0.ebuild

index c5058d4ee17b250bb88f6dab23dd86b6d7f3b997..1a71657e28638d6d29d4c3d34df5ce03cf561b48 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
 PYTHON_REQ_USE="threads(+)"
 
 inherit distutils-r1
@@ -72,6 +72,10 @@ python_prepare_all() {
        sed -i -e '/def test_partialfunction/i\
 @pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
                -e '/def test_autodoc_typed_instance_variables/i\
+@pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
+               -e '/def test_autodoc_inherited_members_None/i\
+@pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
+               -e '/def test_cython/i\
 @pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
                tests/test_autodoc.py || die
        sed -i -e '11aimport sys' \