Change /etc/gentoolkit-version to /usr/share/gentoolkit/VERSION
authorfuzzyray <fuzzyray@gentoo.org>
Thu, 21 May 2009 01:57:59 +0000 (01:57 -0000)
committerfuzzyray <fuzzyray@gentoo.org>
Thu, 21 May 2009 01:57:59 +0000 (01:57 -0000)
svn path=/trunk/gentoolkit/; revision=651

ChangeLog
bin/eclean
bin/epkginfo
bin/euse
bin/glsa-check
pym/gentoolkit/equery/__init__.py

index 92f3f27a0fd66f58c1c879000939dff0491af132..03e413f7757c287c59720cd2e080ec03190a560d 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2009-05-20: Paul Varner <fuzzyray@gentoo.org>
+       * All: Convert from using /etc/gentoolkit-version to
+       /usr/share/gentoolkit/VERSION
+
 2009-05-20: Paul Varner <fuzzyray@gentoo.org>
        * glsa-check: Add patches from Robert Buchholz to do the following:
        Handle unicode encoding better, python tweaks to speedup execution,
index 5497cf39cd3d061ea10c9b18af7fa3c818cb5fcf..9953fa7390930843011cbb77e29caa3aae1bb60e 100644 (file)
@@ -9,7 +9,7 @@ from __future__ import with_statement
 # Meta:
 __author__ = "Thomas de Grenier de Latour (tgl)"
 __email__ = "degrenier@easyconnect.fr"
-__version__ = open('/etc/gentoolkit-version').read().strip()
+__version__ = open('/usr/share/gentoolkit/VERSION').read().strip()
 __productname__ = "eclean"
 __description__ = "A cleaning tool for Gentoo distfiles and binaries."
 
index 313170a815e5db4496803c7f2aac84b70648de3a..b7d6f63ad15f9c62cb8649f4740fdfff416f9a46 100755 (executable)
@@ -19,7 +19,7 @@ from xml.sax.handler import feature_namespaces
 import portage
 from portage.output import *
 
-version = open('/etc/gentoolkit-version').read().strip()
+version = open('/usr/share/gentoolkit/VERSION').read().strip()
 
 def getvar(pkg, var):
        file = open(pkg + ".ebuild")
index df61e32bfb9aa9b066a8088d6f703add4e6f0358..10f75b0dda735034da3c9b77fd7f2b7ebb5f9aba 100755 (executable)
--- a/bin/euse
+++ b/bin/euse
@@ -7,7 +7,7 @@
 # Licensed under the GPL v2
 
 PROGRAM_NAME=euse
-PROGRAM_VERSION=$(cat /etc/gentoolkit-version)
+PROGRAM_VERSION=$(cat /usr/share/gentoolkit/VERSION)
 
 MAKE_CONF_PATH=/etc/make.conf
 MAKE_GLOBALS_PATH=/etc/make.globals
index 3c91d5e6cb0c904f78b0d27f51f3b134b183bd4b..c24ef23a4b83cceab783999c7f02f36bc748d882 100644 (file)
@@ -21,7 +21,7 @@ from getopt import getopt, GetoptError
 
 __program__ = "glsa-check"
 __author__ = "Marius Mauch <genone@gentoo.org>"
-__version__ = open("/etc/gentoolkit-version").read().strip()
+__version__ = open("/usr/share/gentoolkit/VERSION").read().strip()
 
 optionmap = [
 ["-l", "--list", "list all unapplied GLSA"],
index 6bb04a96cdcd43df1c5a39d89c25e57d364ea4dc..c270eb9cccdfd072cb527952b7fc9a62fad2a282 100644 (file)
@@ -333,7 +333,7 @@ def print_version():
        """Print the version of this tool to the console."""
 
        try:
-               with open('/etc/gentoolkit-version') as gentoolkit_version:
+               with open('/usr/share/gentoolkit/VERSION') as gentoolkit_version:
                        version = gentoolkit_version.read().strip()
        except IOError, err:
                pp.die(2, str(err))