media-libs/gst-plugins-good: Version bump, 1.16.2
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>
Sat, 15 Feb 2020 22:06:36 +0000 (23:06 +0100)
committerMart Raudsepp <leio@gentoo.org>
Sun, 3 May 2020 19:12:03 +0000 (22:12 +0300)
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
media-libs/gst-plugins-good/Manifest
media-libs/gst-plugins-good/files/gst-plugins-good-1.16.2-make43.patch [new file with mode: 0644]
media-libs/gst-plugins-good/gst-plugins-good-1.16.2.ebuild [new file with mode: 0644]

index ff83b44437dd1028e766469044a956452489cc3e..32073ca6e9835f2fd4bed5fcde4eafd45d4886d8 100644 (file)
@@ -1 +1,2 @@
 DIST gst-plugins-good-1.14.5.tar.xz 3800104 BLAKE2B acb8ba559c8f4d96cb548fa05e88a556dbfd3aed8572d91cee4fc7b652ab1e814a615713f1372a0acdaa723ddf2d9af9c84c599bc4128b8f61d03bfbc096dcce SHA512 11bfadaf39b28a0a6a6c87c4ade8513496e8f13873cb0c2ddc8b8241029b8775d4839f2de441bda664bc67c66c4ca1d6839dd7570f7d79c1f485d5a25cc9d236
+DIST gst-plugins-good-1.16.2.tar.xz 3897172 BLAKE2B b6341bb2f2456e2c558f71e9f18726eced88cbc703fa017067415297cc7ccdf70b4ceb18e9e3c7c64fc7c55806c7373d9a05eac582067ab764a02c1bafef4b33 SHA512 ab0dfd51af3ea345db466618547c35c78b5f08e725096b66074a5a7e0a83ca25ac51d2d915b7a8c07b70f8e4c9fc65d51c1851f147a5a5a71fbca58e1eb5ffd4
diff --git a/media-libs/gst-plugins-good/files/gst-plugins-good-1.16.2-make43.patch b/media-libs/gst-plugins-good/files/gst-plugins-good-1.16.2-make43.patch
new file mode 100644 (file)
index 0000000..b7e43f3
--- /dev/null
@@ -0,0 +1,57 @@
+--- a/common/glib-gen.mak
++++ b/common/glib-gen.mak
+@@ -1,11 +1,13 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_enum_prefix=gst_color_balance
+-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ # these are all the rules generating the relevant files
+ %-marshal.h: %-marshal.list
+--- a/common/gst-glib-gen.mak
++++ b/common/gst-glib-gen.mak
+@@ -1,13 +1,15 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+ #glib_gen_basename=colorbalance
+ #glib_gen_decl_banner=GST_EXPORT
+ #glib_gen_decl_include=\#include <gst/foo/foo-prelude.h>
+-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ # these are all the rules generating the relevant files
+ $(glib_gen_basename)-marshal.h: $(glib_gen_basename)-marshal.list
+--- a/sys/v4l2/Makefile.in
++++ b/sys/v4l2/Makefile.in
+@@ -17,6 +17,8 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+@@ -669,7 +671,7 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ plugin_LTLIBRARIES = libgstvideo4linux2.la
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ libgstvideo4linux2_la_SOURCES = gstv4l2.c \
+                               gstv4l2allocator.c \
+                               gstv4l2colorbalance.c \
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.16.2.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.16.2.ebuild
new file mode 100644 (file)
index 0000000..3c07812
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE="gst-plugins-good"
+
+inherit flag-o-matic gstreamer
+
+DESCRIPTION="Basepack of plugins for GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+orc"
+
+RDEPEND="
+       >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+       >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+       >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+       >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
+       >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+       orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+       >=dev-util/gtk-doc-am-1.12
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.16.2-make43.patch # remove when bumping and switching to Meson
+)
+
+multilib_src_configure() {
+       # Always enable optional bz2 support for matroska
+       # Always enable optional zlib support for qtdemux and matroska
+       # Many media files require these to work, as some container headers are often
+       # compressed, bug #291154
+       gstreamer_multilib_src_configure \
+               --enable-bz2 \
+               --enable-zlib \
+               --disable-examples \
+               --with-default-audiosink=autoaudiosink \
+               --with-default-visualizer=goom
+
+       if multilib_is_native_abi; then
+               ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+       fi
+
+}
+
+multilib_src_install_all() {
+       DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+       einstalldocs
+       find "${ED}" -name '*.la' -delete || die
+}