sys-block/gpart: Drop old (EAPI 0)
authorMichał Górny <mgorny@gentoo.org>
Sat, 12 Oct 2019 07:57:16 +0000 (09:57 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 12 Oct 2019 07:57:16 +0000 (09:57 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-block/gpart/Manifest
sys-block/gpart/files/gpart-0.1h-l64seek.patch [deleted file]
sys-block/gpart/files/gpart-0.1h-ntfs.patch [deleted file]
sys-block/gpart/files/gpart-0.1h-openmode.patch [deleted file]
sys-block/gpart/files/gpart-0.1h-vfat.patch [deleted file]
sys-block/gpart/gpart-0.1h-r2.ebuild [deleted file]

index 5c3054c455341705d0fc1a102d5490bfc55f30b6..c20e98b76fb7f8e5abd4ab352d299418ad93eba5 100644 (file)
@@ -1,3 +1 @@
-DIST gpart-0.1h-reiserfs-3.6.patch.gz 3658 BLAKE2B b0c9232b54efbf61d5c7fa9ed9cfb611fdfe7266c2da2066747368f978d43bae3f88748c9034705c33361ec22b0115da49b69e6ac1f937665a1ff573be5c2da6 SHA512 c39433e1d6dc0a995322f9985cb1735e89e3c3c7230193609ab2c82fa4cc3fc921d8743b37f6fba18cdda71d29cd83afcb36870fceb88d2a26f7113022226a60
-DIST gpart-0.1h.tar.gz 52352 BLAKE2B 59e719dd62cd84ba31e89f7cd9b1e6cbb4fc2432e50059d77a95beca27143552ac100da1b3f72b0e5b3d0c88e9968eb19bad75a6470f3416de4d5f1f13b53b11 SHA512 673cc99ccc2342c18be3f6395bf7258ab1d8e2ffeac6fd68a4bd75c89825031cb9d7ae628c51bad4da47a8d0625f1608cf4c78345aae5205fd98a9a908a3d45c
 DIST gpart-0.3.tar.gz 53589 BLAKE2B fd479f05219cc3b65ac91318c294728c115dfbab684269d7b5d6dbfa7575902094d3c7e611d296214170713aa23d6909814179208c2599219e94f4bae56d0ccd SHA512 5ee8bc551050d26dc71898d3232549d2b96e0806071571b120cbf819282da0ec2246147a0dfc44576e62d68092bb0183c1a9bb71db7ddca12c0922da60aeea35
diff --git a/sys-block/gpart/files/gpart-0.1h-l64seek.patch b/sys-block/gpart/files/gpart-0.1h-l64seek.patch
deleted file mode 100644 (file)
index 8a14411..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
---- gpart-0.1h.orig/src/l64seek.c
-+++ gpart-0.1h/src/l64seek.c
-@@ -25,30 +25,11 @@
- } ostck[OSTACKLEN];
- static int            osptr = -1;
--#if defined(__linux__) && defined(__i386__)
--_syscall5(int,_llseek,uint,fd,ulong,hi,ulong,lo,loff_t *,res,uint,wh)
--#endif
--
--
--
- off64_t l64seek(int fd,off64_t offset,int whence)
- {
-       off64_t         ret = (off64_t)-1;
--#if defined(__linux__) && defined(__i386__)
--      int             iret;
--      unsigned long   ohi, olo;
--
--      ohi = (unsigned long)((offset >> 32) & 0xFFFFFFFF);
--      olo = (unsigned long)(offset & 0xFFFFFFFF);
--      iret = _llseek(fd,ohi,olo,&ret,whence);
--      if (iret == -1)
--              ret = (off64_t)-1;
--#endif
--
--#if defined(__FreeBSD__) || (defined(__linux__) && defined(__alpha__))
-       ret = lseek(fd,offset,whence);
--#endif
-       return (ret);
- }
---- gpart-0.1h.orig/src/l64seek.h
-+++ gpart-0.1h/src/l64seek.h
-@@ -17,6 +17,8 @@
- #ifndef _L64SEEK_H
- #define _L64SEEK_H
-+#include <sys/stat.h>
-+#include <sys/types.h>
- #include <unistd.h>
- /*
-@@ -25,19 +27,7 @@
-  * offsets.
-  */
--
--#if defined(__linux__)
--#     include <linux/unistd.h>
--#     include <sys/types.h>
--      typedef int64_t off64_t;
--#endif
--
--
--#if defined(__FreeBSD__)
--      typedef off_t off64_t;
--#endif
--
--
-+typedef loff_t off64_t;
- typedef off64_t s64_t;
- off64_t l64seek(int fd, off64_t offset, int whence);
-@@ -45,5 +35,4 @@
- int l64opush(int);
- s64_t l64opop(int);
--
- #endif
diff --git a/sys-block/gpart/files/gpart-0.1h-ntfs.patch b/sys-block/gpart/files/gpart-0.1h-ntfs.patch
deleted file mode 100644 (file)
index 1f887ac..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-Ripped out of debian
-
---- gpart-0.1h.orig/src/gm_ntfs.h
-+++ gpart-0.1h/src/gm_ntfs.h
-@@ -14,6 +14,9 @@
-  *
-  */
-+#include <stdint.h>
-+#include <asm/byteorder.h>
-+
- #ifndef _GM_NTFS_H
- #define _GM_NTFS_H
-@@ -29,32 +32,38 @@
- /* 'NTFS' in little endian */
- #define NTFS_SUPER_MAGIC      0x5346544E
--#if defined(i386) || defined(__i386__) || defined(__alpha__)
--
- /* unsigned integral types */
- #ifndef NTFS_INTEGRAL_TYPES
- #define NTFS_INTEGRAL_TYPES
--typedef unsigned char         ntfs_u8;
--typedef unsigned short                ntfs_u16;
--typedef unsigned int          ntfs_u32;
--typedef s64_t                 ntfs_u64;
-+typedef uint8_t                       ntfs_u8;
-+typedef uint16_t              ntfs_u16;
-+typedef uint32_t              ntfs_u32;
-+typedef uint64_t              ntfs_u64;
-+typedef int8_t                        ntfs_s8;
-+typedef int16_t                       ntfs_s16;
- #endif /* NTFS_INTEGRAL_TYPES */
--#endif /* defined(i386) || defined(__i386__) || defined(__alpha__) */
--
--
--/* Macros reading unsigned integers from a byte pointer */
--/* these should work for all little endian machines */
--#define NTFS_GETU8(p)         (*(ntfs_u8*)(p))
--#define NTFS_GETU16(p)                (*(ntfs_u16*)(p))
--#define NTFS_GETU24(p)                (NTFS_GETU32(p) & 0xFFFFFF)
--#define NTFS_GETU32(p)                (*(ntfs_u32*)(p))
--#define NTFS_GETU64(p)                (*(ntfs_u64*)(p))
--
--/* Macros reading signed integers, returning int */
--#define NTFS_GETS8(p)         ((int)(*(char*)(p)))
--#define NTFS_GETS16(p)                ((int)(*(short*)(p)))
--#define NTFS_GETS24(p)                (NTFS_GETU24(p) < 0x800000 ? (int)NTFS_GETU24(p) :
--
-+#define CPU_TO_LE16(a) __cpu_to_le16(a)
-+#define CPU_TO_LE32(a) __cpu_to_le32(a)
-+#define CPU_TO_LE64(a) __cpu_to_le64(a)
-+
-+#define LE16_TO_CPU(a) __cpu_to_le16(a)
-+#define LE32_TO_CPU(a) __cpu_to_le32(a)
-+#define LE64_TO_CPU(a) __cpu_to_le64(a)
-+
-+/* Macros reading unsigned integers */
-+#define NTFS_GETU8(p)      (*(ntfs_u8*)(p))
-+#define NTFS_GETU16(p)     ((ntfs_u16)LE16_TO_CPU(*(ntfs_u16*)(p)))
-+#define NTFS_GETU24(p)     ((ntfs_u32)NTFS_GETU16(p) | \
-+                         ((ntfs_u32)NTFS_GETU8(((char*)(p)) + 2) << 16))
-+#define NTFS_GETU32(p)     ((ntfs_u32)LE32_TO_CPU(*(ntfs_u32*)(p)))
-+#define NTFS_GETU64(p)     ((ntfs_u64)LE64_TO_CPU(*(ntfs_u64*)(p)))
-+
-+/* Macros reading signed integers */
-+#define NTFS_GETS8(p)        ((*(ntfs_s8*)(p)))
-+#define NTFS_GETS16(p)       ((ntfs_s16)LE16_TO_CPU(*(short*)(p)))
-+#define NTFS_GETS24(p)       (NTFS_GETU24(p) < 0x800000 ? \
-+                                      (int)NTFS_GETU24(p) : \
-+                                      (int)(NTFS_GETU24(p) - 0x1000000))
- #endif /* _GM_NTFS_H */
diff --git a/sys-block/gpart/files/gpart-0.1h-openmode.patch b/sys-block/gpart/files/gpart-0.1h-openmode.patch
deleted file mode 100644 (file)
index ca13cc9..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- gpart.orig/src/gpart.c     2008-10-19 15:06:06.000000000 +0000
-+++ gpart/src/gpart.c  2008-11-25 07:34:47.000000000 +0000
-@@ -1221,7 +1221,7 @@ static int make_mbr_backup(disk_desc *d,
- {
-       int             fd, ret = 0;
--      if ((fd = open(bfile,O_WRONLY|O_CREAT)) < 0)
-+      if ((fd = open(bfile,O_WRONLY|O_CREAT, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH)) < 0)
-               return (ret);
-       if (write(fd,d->d_pt.t_boot,512) == 512)
diff --git a/sys-block/gpart/files/gpart-0.1h-vfat.patch b/sys-block/gpart/files/gpart-0.1h-vfat.patch
deleted file mode 100644 (file)
index 7234ac6..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-Ripped out of debian
-
---- gpart-0.1h.orig/src/gm_fat.h
-+++ gpart-0.1h/src/gm_fat.h
-@@ -60,6 +60,10 @@
-       __u16   info_sector;    /* filesystem info sector */
-       __u16   backup_boot;    /* backup boot sector */
-       __u16   reserved2[6];   /* Unused */
--};
--
-+} __attribute__ ((packed));
-+/*  "__attribute__ ((packed))" 
-+    added by davidc@debian.org,
-+    as suggested by falk@zxmjz18.extern.uni-tuebingen.de 
-+    Fri Jul 07 18:04:15 2000
-+    in debian bug report #66893 "FAT detection broken on Alpha" */
- #endif /* _GM_FAT_H */
diff --git a/sys-block/gpart/gpart-0.1h-r2.ebuild b/sys-block/gpart/gpart-0.1h-r2.ebuild
deleted file mode 100644 (file)
index ef944c9..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils
-
-DESCRIPTION="Partition table rescue/guessing tool"
-HOMEPAGE="http://www.stud.uni-hannover.de/user/76201/gpart/"
-SRC_URI="http://www.stud.uni-hannover.de/user/76201/gpart/${P}.tar.gz
-       ftp://ftp.namesys.com/pub/misc-patches/gpart-0.1h-reiserfs-3.6.patch.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 hppa x86"
-IUSE=""
-
-RDEPEND=""
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       epatch "${FILESDIR}"/${P}-errno.patch
-       epatch "${FILESDIR}"/${P}-vfat.patch
-       epatch "${FILESDIR}"/${P}-ntfs.patch
-       epatch "${WORKDIR}"/gpart-0.1h-reiserfs-3.6.patch
-       epatch "${FILESDIR}"/${P}-l64seek.patch
-       epatch "${FILESDIR}"/${P}-openmode.patch
-       sed -i -e "/^CFLAGS/s: -O2 : ${CFLAGS} :" make.defs
-       sed -i -e "/^LDFLAGS/s:=:=${LDFLAGS} :" make.defs
-}
-
-src_install() {
-       dobin src/gpart || die
-       doman man/gpart.8
-       dodoc README Changes INSTALL LSM
-}