dev-util/bustle: remove unused patches.
authorMichael Mair-Keimberger (asterix) <m.mairkeimberger@gmail.com>
Thu, 6 Oct 2016 16:55:41 +0000 (18:55 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 9 Oct 2016 07:53:26 +0000 (09:53 +0200)
Closes: https://github.com/gentoo/gentoo/pull/2495

Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-util/bustle/files/0001-bustle-dbus-monitor-fix-linking-order-libs-go-after-.patch [deleted file]
dev-util/bustle/files/bustle-0.2.3-ghc-7.4.patch [deleted file]
dev-util/bustle/files/bustle-0.2.3-restrict-gtk2hs-deps-to-gtkplus2.patch [deleted file]
dev-util/bustle/files/bustle-0.4.0-ghc-7.4.patch [deleted file]
dev-util/bustle/files/bustle-0.4.0-restrict-gtk2hs-deps-to-gtkplus2.patch [deleted file]

diff --git a/dev-util/bustle/files/0001-bustle-dbus-monitor-fix-linking-order-libs-go-after-.patch b/dev-util/bustle/files/0001-bustle-dbus-monitor-fix-linking-order-libs-go-after-.patch
deleted file mode 100644 (file)
index 206bcbc..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-From b1d7a9b492a8fbe38f60585f6d5a25908e79c973 Mon Sep 17 00:00:00 2001
-From: Sergei Trofimovich <st@anti-virus.by>
-Date: Mon, 7 Feb 2011 15:58:56 +0200
-Subject: [PATCH] bustle-dbus-monitor: fix linking order (libs go after object/source files)
-
-Fixes the following failure:
-
-    cc -O2 -pipe  -Wl,--hash-style=gnu -Wl,-O1 -Wl,--as-needed \
-            -g -O2 `pkg-config --cflags --libs dbus-1` \
-            -Wall -Wunused \
-            -o bustle-dbus-monitor bustle-dbus-monitor.c
-    bustle-0.2.3/temp/ccodU65H.o: In function `main':
-    bustle-0.2.3/work/bustle-0.2.3/bustle-dbus-monitor.c:347: undefined reference to `dbus_error_init'
-    bustle-0.2.3/work/bustle-0.2.3/bustle-dbus-monitor.c:348: undefined reference to `dbus_bus_get'
-    bustle-0.2.3/temp/ccodU65H.o: In function `get_well_known_names':
-    bustle-0.2.3/work/bustle-0.2.3/bustle-dbus-monitor.c:241: undefined reference to `dbus_message_new_method_call'
-    bustle-0.2.3/work/bustle-0.2.3/bustle-dbus-monitor.c:249: undefined reference to `dbus_error_init'
-    bustle-0.2.3/work/bustle-0.2.3/bustle-dbus-monitor.c:250: undefined reference to `dbus_connection_send_with_reply_and_block'
-    bustle-0.2.3/work/bustle-0.2.3/bustle-dbus-monitor.c:252: undefined reference to `dbus_error_is_set'
-
-Signed-off-by: Sergei Trofimovich <st@anti-virus.by>
----
- Makefile |    5 +++--
- 1 files changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 707790e..3f50370 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,8 +1,9 @@
- bustle-dbus-monitor: bustle-dbus-monitor.c
-       $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) \
--      -g -O2 `pkg-config --cflags --libs dbus-1` \
-+      -g -O2 \
-       -Wall -Wunused \
--      -o bustle-dbus-monitor bustle-dbus-monitor.c
-+      -o bustle-dbus-monitor bustle-dbus-monitor.c \
-+      `pkg-config --cflags --libs dbus-1`
- clean:
-       rm -f bustle-dbus-monitor
--- 
-1.7.3.4
-
diff --git a/dev-util/bustle/files/bustle-0.2.3-ghc-7.4.patch b/dev-util/bustle/files/bustle-0.2.3-ghc-7.4.patch
deleted file mode 100644 (file)
index 3c4544e..0000000
+++ /dev/null
@@ -1,89 +0,0 @@
-Starting with ghc-7.4 base and haskell98 are incompatible:
-
- Ambiguous module name `Prelude':
-  it was found in multiple packages: base haskell98-2.0.0.1
-
-Gentoo-bug: https://bugs.gentoo.org/428226
-Reported-by:  Chris Reffett
-diff --git a/Bustle/Noninteractive.hs b/Bustle/Noninteractive.hs
-index 2aa1e05..4a4d9b0 100644
---- a/Bustle/Noninteractive.hs
-+++ b/Bustle/Noninteractive.hs
-@@ -3,7 +3,8 @@ where
- import Prelude hiding (log)
--import System
-+import System.Environment (getArgs)
-+import System.Exit (exitFailure)
- import System.IO (hPutStrLn, stderr)
- import Bustle.Parser (readLog)
-diff --git a/Bustle/Stats.hs b/Bustle/Stats.hs
-index da374a5..939cafd 100644
---- a/Bustle/Stats.hs
-+++ b/Bustle/Stats.hs
-@@ -36,7 +36,7 @@ frequencies = reverse
-     where alt Nothing  = Just 1
-           alt (Just n) = Just (n + 1)
--mean :: Fractional a => [a] -> a
-+mean :: (Eq a, Fractional a) => [a] -> a
- mean = acc 0 0
-    where acc 0 _ [] = error "mean of empty list"
-          acc n t [] = t / n
-diff --git a/bustle-dot.hs b/bustle-dot.hs
-index aa7c45e..77d6f18 100644
---- a/bustle-dot.hs
-+++ b/bustle-dot.hs
-@@ -3,7 +3,9 @@ import Prelude hiding (log)
- import Control.Monad
- import Data.List
- import Data.Maybe
--import System
-+import System.IO
-+import System.Environment
-+import System.Exit
- import Bustle.Parser (readLog)
- import Bustle.Types
-diff --git a/bustle.cabal b/bustle.cabal
-index 7ad7412..0a49ca1 100644
---- a/bustle.cabal
-+++ b/bustle.cabal
-@@ -27,11 +27,11 @@ Executable bustle
-   if flag(PostCabalizedGtk2HS)
-     -- Since gtk2hs 0.11, pango is a separate package, and its module names
-     -- have changed.
--    Build-Depends:  haskell98, mtl, base >= 4 && < 5, containers, parsec,
-+    Build-Depends:  mtl, base >= 4 && < 5, containers, parsec,
-                     filepath, process,
-                     gtk > 0.11, glade, pango, glib, cairo
-   else
--    Build-Depends:  haskell98, mtl, base >= 4 && < 5, containers, parsec,
-+    Build-Depends:  mtl, base >= 4 && < 5, containers, parsec,
-                     filepath, process,
-                     gtk > 0.10 && < 0.11, glade, pango, glib, cairo
-@@ -39,18 +39,18 @@ Executable bustle-count
-   Main-is:        bustle-count.hs
-   Other-modules:  Bustle.Parser, Bustle.Stats, Bustle.Types,
-                   Bustle.Noninteractive
--  Build-Depends:  haskell98, base >= 4 && < 5, containers, parsec
-+  Build-Depends:  base >= 4 && < 5, containers, parsec
-   Ghc-options:    -Wall -fno-warn-unused-imports -fno-warn-unused-do-bind
- Executable bustle-time
-   Main-is:        bustle-time.hs
-   Other-modules:  Bustle.Parser, Bustle.Stats, Bustle.Types,
-                   Bustle.Noninteractive
--  Build-Depends:  haskell98, base >= 4 && < 5, containers, parsec
-+  Build-Depends:  base >= 4 && < 5, containers, parsec
-   Ghc-options:    -Wall -fno-warn-unused-imports -fno-warn-unused-do-bind
- Executable bustle-dot
-   Main-is:        bustle-dot.hs
-   Other-modules:  Bustle.Parser, Bustle.Types
--  Build-Depends:  haskell98, base >= 4 && < 5, containers, parsec
-+  Build-Depends:  base >= 4 && < 5, containers, parsec
-   Ghc-options:    -Wall -fno-warn-unused-imports -fno-warn-unused-do-bind
diff --git a/dev-util/bustle/files/bustle-0.2.3-restrict-gtk2hs-deps-to-gtkplus2.patch b/dev-util/bustle/files/bustle-0.2.3-restrict-gtk2hs-deps-to-gtkplus2.patch
deleted file mode 100644 (file)
index 1809135..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
---- bustle-0.2.3-orig/bustle.cabal     2013-04-03 15:15:36.278582601 +1100
-+++ bustle-0.2.3/bustle.cabal  2013-04-03 15:21:14.334592030 +1100
-@@ -27,30 +27,30 @@
-   if flag(PostCabalizedGtk2HS)
-     -- Since gtk2hs 0.11, pango is a separate package, and its module names
-     -- have changed.
--    Build-Depends:  mtl, base >= 4 && < 5, containers, parsec,
-+    Build-Depends:  haskell98, mtl, base >= 4 && < 5, containers, parsec,
-                     filepath, process,
--                    gtk > 0.11, glade, pango, glib, cairo
-+                    gtk > 0.11 && < 0.13, glade < 0.13, pango < 0.13, glib < 0.13, cairo < 0.13
-   else
--    Build-Depends:  mtl, base >= 4 && < 5, containers, parsec,
-+    Build-Depends:  haskell98, mtl, base >= 4 && < 5, containers, parsec,
-                     filepath, process,
--                    gtk > 0.10 && < 0.11, glade, pango, glib, cairo
-+                    gtk > 0.10 && < 0.11, glade < 0.13, pango < 0.13, glib < 0.13, cairo < 0.13
- Executable bustle-count
-   Main-is:        bustle-count.hs
-   Other-modules:  Bustle.Parser, Bustle.Stats, Bustle.Types,
-                   Bustle.Noninteractive
--  Build-Depends:  base >= 4 && < 5, containers, parsec
-+  Build-Depends:  haskell98, base >= 4 && < 5, containers, parsec
-   Ghc-options:    -Wall -fno-warn-unused-imports -fno-warn-unused-do-bind
- Executable bustle-time
-   Main-is:        bustle-time.hs
-   Other-modules:  Bustle.Parser, Bustle.Stats, Bustle.Types,
-                   Bustle.Noninteractive
--  Build-Depends:  base >= 4 && < 5, containers, parsec
-+  Build-Depends:  haskell98, base >= 4 && < 5, containers, parsec
-   Ghc-options:    -Wall -fno-warn-unused-imports -fno-warn-unused-do-bind
- Executable bustle-dot
-   Main-is:        bustle-dot.hs
-   Other-modules:  Bustle.Parser, Bustle.Types
--  Build-Depends:  base >= 4 && < 5, containers, parsec
-+  Build-Depends:  haskell98, base >= 4 && < 5, containers, parsec
-   Ghc-options:    -Wall -fno-warn-unused-imports -fno-warn-unused-do-bind
diff --git a/dev-util/bustle/files/bustle-0.4.0-ghc-7.4.patch b/dev-util/bustle/files/bustle-0.4.0-ghc-7.4.patch
deleted file mode 100644 (file)
index 0262dd8..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-diff --git a/Bustle/Noninteractive.hs b/Bustle/Noninteractive.hs
-index 56e5d74..48d9461 100644
---- a/Bustle/Noninteractive.hs
-+++ b/Bustle/Noninteractive.hs
-@@ -25,7 +25,7 @@ where
- import Prelude hiding (log)
--import System
-+import System.Exit (exitFailure)
- import System.IO (hPutStrLn, stderr)
- import Data.Maybe (fromMaybe, mapMaybe)
- import Data.List (nub)
-diff --git a/Bustle/Stats.hs b/Bustle/Stats.hs
-index 8a3e206..d822058 100644
---- a/Bustle/Stats.hs
-+++ b/Bustle/Stats.hs
-@@ -68,7 +68,7 @@ frequencies = reverse
-     where alt Nothing  = Just 1
-           alt (Just n) = Just (n + 1)
--mean :: Fractional a => [a] -> a
-+mean :: (Eq a, Fractional a) => [a] -> a
- mean = acc 0 0
-    where acc 0 _ [] = error "mean of empty list"
-          acc n t [] = t / n
-diff --git a/bustle.cabal b/bustle.cabal
-index 93b16bd..cd47efa 100644
---- a/bustle.cabal
-+++ b/bustle.cabal
-@@ -94,7 +94,6 @@ Executable bustle
-                  , glade
-                  , glib
-                  , gtk > 0.11
--                 , haskell98
-                  , mtl
-                  , pango
-                  , parsec
-@@ -114,7 +113,6 @@ Executable bustle
-                  , glade
-                  , glib
-                  , gtk > 0.10 && < 0.11
--                 , haskell98
-                  , mtl
-                  , pango
-                  , parsec
diff --git a/dev-util/bustle/files/bustle-0.4.0-restrict-gtk2hs-deps-to-gtkplus2.patch b/dev-util/bustle/files/bustle-0.4.0-restrict-gtk2hs-deps-to-gtkplus2.patch
deleted file mode 100644 (file)
index fb7a149..0000000
+++ /dev/null
@@ -1,76 +0,0 @@
---- bustle-0.4.0-orig/bustle.cabal     2013-04-03 15:59:57.193656822 +1100
-+++ bustle-0.4.0/bustle.cabal  2013-04-03 15:09:21.825572157 +1100
-@@ -86,16 +86,17 @@
-     Build-Depends: base >= 4 && < 5
-                  , binary
-                  , bytestring
--                 , cairo
-+                 , cairo < 0.13
-                  , containers
-                  , dbus-core == 0.9.*
-                  , directory
-                  , filepath
--                 , glade
--                 , glib
--                 , gtk > 0.11
-+                 , glade < 0.13
-+                 , glib < 0.13
-+                 , gtk > 0.11 && < 0.13
-+                 , haskell98
-                  , mtl
--                 , pango
-+                 , pango < 0.13
-                  , parsec
-                  , pcap
-                  , process
-@@ -105,16 +106,17 @@
-     Build-Depends: base >= 4 && < 5
-                  , binary
-                  , bytestring
--                 , cairo
-+                 , cairo < 0.13
-                  , containers
-                  , dbus-core == 0.9.*
-                  , directory
-                  , filepath
--                 , glade
--                 , glib
-+                 , glade < 0.13
-+                 , glib < 0.13
-                  , gtk > 0.10 && < 0.11
-+                 , haskell98
-                  , mtl
--                 , pango
-+                 , pango < 0.13
-                  , parsec
-                  , pcap
-                  , process
-@@ -133,8 +135,8 @@
-   C-sources: c-sources/pcap-monitor.c
-   pkgconfig-depends: glib-2.0
-   Build-Depends: base >= 4 && < 5
--               , gtk > 0.11
--               , glib
-+               , gtk > 0.11 && < 0.13
-+               , glib < 0.13
- Executable dump-messages
-   if flag(InteractiveTests) && flag(PostCabalizedGtk2HS)
-@@ -177,14 +179,14 @@
-     main-is: Test/Renderer.hs
-     other-modules: Bustle.Renderer
-     Build-Depends: base
--                 , cairo
-+                 , cairo < 0.13
-                  , containers
-                  , dbus-core
-                  , directory
-                  , filepath
--                 , gtk
-+                 , gtk < 0.13
-                  , mtl
--                 , pango
-+                 , pango < 0.13
-                  , test-framework
-                  , test-framework-hunit
-                  , HUnit