app-arch/file-roller: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sat, 5 Sep 2015 11:44:26 +0000 (13:44 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sat, 5 Sep 2015 11:44:26 +0000 (13:44 +0200)
Package-Manager: portage-2.2.20.1

app-arch/file-roller/Manifest
app-arch/file-roller/file-roller-3.16.4.ebuild [new file with mode: 0644]

index 39cb4a0f7dae2a057fd2234852e39c9077749f39..40e5c56306b3a11a82f21fcd311bd1b91b3c1ab0 100644 (file)
@@ -1,3 +1,4 @@
 DIST file-roller-3.14.2.tar.xz 1387784 SHA256 1815e736715afe8c0f3fbda41c76c07289220d4855345f779c632adf5e074e50 SHA512 92ff42e4fe06e3ea54e71806157fbb95f9e5f247142e9e857f61f61748fd0e1b99a73cfb35fd3ea890c3e19da0d2176af9a017a8eb918eff9ddc0371b09ed11d WHIRLPOOL db4e5519fe298759dbb0f048a597d4cd8ef6610b04eab9f77ee21905726f19e15312cdfc47aa80c2f55490ad4f400e7cac0664e24376b40a340d780e5f0809bf
 DIST file-roller-3.16.2.tar.xz 1409944 SHA256 60897ff24d4822395a227b62811c3b8768b701844961e93303d6d6d9463d7e3f SHA512 ac8c36c3b186bd4eb2ae41fe2e777a15074f09863402a56614a8ad0a89d6e480046fb2566db1be907ea1155ebe4aff6733e32e0f59547435db451757fb3cb15f WHIRLPOOL 3e20ba55d57d69a838f1602322478752eb2f172e8f713c23099edd3446c4b811306d101e23393a8d088382145d4bbf72c66c7ec62796e6eba47e4a4f46fd3ff7
 DIST file-roller-3.16.3.tar.xz 1411360 SHA256 2b3a1111caba26e67b96559a3118a700dbfb6a4c6ad7ebd3e509df227995411c SHA512 999d08d6ea5ae975a026c351c5f216fd503b78eb65e8f417f8afdce152c816f631bd5c6b1a430a5baefa19541e3d718c59beef4773242a6ba087479061ed42ea WHIRLPOOL 2534ae5ad2bb3886d4963bb30a5ef67a82c698f74d64fc0ddc1cac0a37ab258b4fa7e569d031ec1a715a0d3f99b70aae54d16f88d18b95ce7f77654cede4f176
+DIST file-roller-3.16.4.tar.xz 1412224 SHA256 5455980b2c9c7eb063d2d65560ae7ab2e7f01b208ea3947e151680231c7a4185 SHA512 76378e16cd7f37a336b3eb3c6106cf36c2ea6e9209c23175810e2b80dc13a7b62b04cfcdea0b2bf69251baf7b164e85c34d99813cdbfd07433f73aba9c7361ae WHIRLPOOL 0d8736e13b97a4a005ae53bd9885b10c8a7797e10e0d8f4548e4112490ebc3ce91b0e5349b251bdca5d0f392318be7ea4fb324e3399300e362f47b024217849d
diff --git a/app-arch/file-roller/file-roller-3.16.4.ebuild b/app-arch/file-roller/file-roller-3.16.4.ebuild
new file mode 100644 (file)
index 0000000..b6fda2e
--- /dev/null
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 readme.gentoo
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+IUSE="nautilus packagekit"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+       >=app-arch/libarchive-3:=
+       >=dev-libs/glib-2.36:2
+       >=dev-libs/json-glib-0.14
+       >=x11-libs/gtk+-3.13.2:3
+       >=x11-libs/libnotify-0.4.3:=
+       sys-apps/file
+       x11-libs/cairo
+       x11-libs/gdk-pixbuf:2
+       x11-libs/pango
+       nautilus? ( >=gnome-base/nautilus-3 )
+       packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${RDEPEND}
+       dev-util/desktop-file-utils
+       >=dev-util/intltool-0.40.0
+       dev-util/itstool
+       sys-devel/gettext
+       virtual/pkgconfig
+"
+# eautoreconf needs:
+#      gnome-base/gnome-common
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip   - app-arch/p7zip
+ace     - app-arch/unace
+arj     - app-arch/arj
+cpio    - app-arch/cpio
+deb     - app-arch/dpkg
+iso     - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha     - app-arch/lha
+lzop    - app-arch/lzop
+rar     - app-arch/unrar or app-arch/unar
+rpm     - app-arch/rpm
+unstuff - app-arch/stuffit
+zoo     - app-arch/zoo"
+
+src_prepare() {
+       # File providing Gentoo package names for various archivers
+       cp -f "${FILESDIR}"/3.6.0-packages.match data/packages.match || die
+       gnome2_src_prepare
+}
+
+src_configure() {
+       DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+       # --disable-debug because enabling it adds -O0 to CFLAGS
+       gnome2_src_configure \
+               --disable-run-in-place \
+               --disable-static \
+               --disable-debug \
+               --enable-magic \
+               --enable-libarchive \
+               $(use_enable nautilus nautilus-actions) \
+               $(use_enable packagekit)
+}
+
+src_install() {
+       gnome2_src_install
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       gnome2_pkg_postinst
+       readme.gentoo_print_elog
+}