Major cleanup & revbump
authorGustavo Zacarias <gustavoz@gentoo.org>
Fri, 16 Jun 2006 20:32:54 +0000 (20:32 +0000)
committerGustavo Zacarias <gustavoz@gentoo.org>
Fri, 16 Jun 2006 20:32:54 +0000 (20:32 +0000)
Package-Manager: portage-2.1

sys-boot/silo/ChangeLog
sys-boot/silo/files/digest-silo-1.4.12 [new file with mode: 0644]
sys-boot/silo/silo-1.4.12.ebuild [new file with mode: 0644]

index 783acb3a38ca7c1b570d9a1fa034b349e47f23e6..681d6d33147ac3d02569feefe5fbd5d8193fc4e3 100644 (file)
@@ -1,6 +1,15 @@
 # ChangeLog for sys-boot/silo
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.28 2006/04/24 20:41:39 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.29 2006/06/16 20:32:54 gustavoz Exp $
+
+*silo-1.4.12 (16 Jun 2006)
+
+  16 Jun 2006; Gustavo Zacarias <gustavoz@gentoo.org>
+  -files/silo-1.4.9-sparc_cpu.patch, -silo-1.3.1.ebuild,
+  -silo-1.3.1-r1.ebuild, -silo-1.3.2.ebuild, -silo-1.3.2-r1.ebuild,
+  -silo-1.4.8.ebuild, -silo-1.4.9.ebuild, -silo-1.4.10.ebuild,
+  +silo-1.4.12.ebuild:
+  Major cleanup & revbump
 
   24 Apr 2006; Gustavo Zacarias <gustavoz@gentoo.org> silo-1.4.11-r1.ebuild:
   Stable on sparc
diff --git a/sys-boot/silo/files/digest-silo-1.4.12 b/sys-boot/silo/files/digest-silo-1.4.12
new file mode 100644 (file)
index 0000000..8204879
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 15e77558c57cae19a790fc100783d8f3 silo-1.4.12.tar.gz 168839
+RMD160 68ec1291630c7d1e58f6d52f31529c226fa982b0 silo-1.4.12.tar.gz 168839
+SHA256 232d23a18236a71bff3c9fe0d081a7bbb5913056a4637496782401b0ed5bdf60 silo-1.4.12.tar.gz 168839
diff --git a/sys-boot/silo/silo-1.4.12.ebuild b/sys-boot/silo/silo-1.4.12.ebuild
new file mode 100644 (file)
index 0000000..f23ccfe
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.12.ebuild,v 1.1 2006/06/16 20:32:54 gustavoz Exp $
+
+inherit mount-boot flag-o-matic toolchain-funcs
+
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="http://www.sparc-boot.org/pub/silo/${P}.tar.gz"
+HOMEPAGE="http://www.sparc-boot.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* ~sparc"
+IUSE="hardened"
+
+PROVIDE="virtual/bootloader"
+
+DEPEND="sys-fs/e2fsprogs
+       sys-apps/sparc-utils"
+
+ABI_ALLOW="sparc32"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       epatch ${FILESDIR}/silo-1.4.x-noglibc_time.patch
+}
+
+src_compile() {
+       filter-flags "-fstack-protector"
+
+       if use hardened
+       then
+               make ${MAKEOPTS} CC="$(tc-getCC) -fno-stack-protector -fno-pic"
+       else
+               make ${MAKEOPTS} CC="$(tc-getCC)" || die
+       fi
+}
+
+src_install() {
+       make DESTDIR=${D} install || die
+       dodoc COPYING ChangeLog first-isofs/README.SILO_ISOFS docs/README*
+
+       # Fix maketilo manpage
+       rm ${D}/usr/share/man/man1/maketilo.1
+       dosym /usr/share/man/man1/tilo.1 /usr/share/man/man1/maketilo.1
+}
+
+pkg_postinst() {
+       ewarn "NOTE: If this is an upgrade to an existing SILO install,"
+       ewarn "      you will need to re-run silo as the /boot/second.b"
+       ewarn "      file has changed, else the system will fail to load"
+       ewarn "      SILO at the next boot."
+}