app-editors/ghex: ebuild touchups, EAPI-7 bumps, restrict tests
authorMart Raudsepp <leio@gentoo.org>
Tue, 16 Jul 2019 19:04:46 +0000 (22:04 +0300)
committerMart Raudsepp <leio@gentoo.org>
Tue, 16 Jul 2019 19:05:25 +0000 (22:05 +0300)
* Bump to EAPI-7
* Downgrade yelp-tools dep to correct itstool dep
* Ensure bug-free ITS supporting gettext
* Depend on libxml2 for xml-stripblanks gresource usage
* Depend on appstream-glib for appdata translation due to tags
  used not present in gettext own provided appdata.its
* Restrict tests, as upstream thinks it's great to depend on
  an unreleased appstream-glib for tests to succeed

Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
app-editors/ghex/ghex-3.18.4-r1.ebuild [moved from app-editors/ghex/ghex-3.18.4.ebuild with 65% similarity]

similarity index 65%
rename from app-editors/ghex/ghex-3.18.4.ebuild
rename to app-editors/ghex/ghex-3.18.4-r1.ebuild
index 4a0528c9e5c73fb21685cbf3a4e5d4b2458de5bd..a735e8d30a0678d7180b3f1ec8cf909c9dab3638 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 inherit gnome.org gnome2-utils meson xdg
 DESCRIPTION="GNOME hexadecimal editor"
 HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
@@ -12,16 +12,22 @@ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
 IUSE=""
 
 RDEPEND="
-       >=dev-libs/atk-1
+       >=dev-libs/atk-1.0.0
        >=dev-libs/glib-2.31.10:2
        >=x11-libs/gtk+-3.3.8:3
 "
-DEPEND="${RDEPEND}
-       >=sys-devel/gettext-0.17
-       app-text/yelp-tools
+DEPEND="${RDEPEND}"
+BDEPEND="
+       dev-libs/appstream-glib
+       dev-libs/libxml2:2
+       dev-util/itstool
+       >=sys-devel/gettext-0.19.8
        virtual/pkgconfig
 "
 
+# Requires unreleased appstream-glib-0.7.16 for tests to pass..
+RESTRICT="test" # https://gitlab.gnome.org/GNOME/ghex/issues/18
+
 pkg_postinst() {
        xdg_pkg_postinst
        gnome2_schemas_update